Installer TclTLS

From AMSN
Jump to: navigation, search

Tcl TLS est une extension pour le langage TCL pour soutenir les connexions sécurisées OpenSSL.

D'habitude TLS est installé par aMSN lui-même lors de la première tentative de connexion au réseau cependant, rarement, ceci peut échouer. Voici les instructions pour obtenir le fonctionnement de TLS. Si vous n'installez pas TLS, vous serez dans l'incapacité de vous connecter.

Linux

Il faut généralement attremper votre gestionnaire de paquets et tapez quelque chose du genre "tcltls". Sur les systèmes basés sur Debian (tels que Ubuntu ou Linspire) vous devriez être capable de faire simplement :

 apt-get install tcltls

Il se peut que ça ne fonctionne pas si vous avez installé Tcl/tk8.5 et vous pourriez avoir besoin de faire des liens symboliques avec certains fichiers.

Par défaut, les fichiers sont situés dans /usr/lib.

 /usr/lib/tls1.50/tls.tcl
 /usr/lib/tls1.50/pkgIndex.tcl
 /usr/lib/tls1.50/libtls1.50.so

Si vous installez tcl/tk8.5, vous pourriez avoir besoin de les lier (avec des liens symboliques) à /usr/local/lib comme dans

 ln -s /usr/lib/tls1.50 /usr/local/lib/tls1.50

Vous pouvez également télécharger le paquet à partir de SourceForge et le décompresser. Vous pouvez le déplacer dans le sous-répertoire plugins de aMSN ou ~/.amsn ou dans /usr/lib.

Si cela ne fonctionne pas pour vous, reportez-vous à la section "Dépannage" de cette page.

Dépannage

Q : J'ai installé TclTLS mais il se plaint toujours de ne pas le trouver.

R : Utilisez-vous Tcl/Tk8.5 ? Regardez les instructions ci-dessus à propos des liens symboliques.

Q : J'ai installé TclTLS mais il se plaint de la version.

R : S'il vous plaît editez pkgIndex.tcl (dans : usr/lib/tls1.50/) de sorte que cette ligne

 package ifneeded tls 1.5

devient comme cela

 package ifneeded tls 1.50

(il suffit d'ajouter le zéro)

Personal tools