aMSN Forums
March 20, 2018, 06:32:34 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
   Home   Help Search Login Register  
Pages: [1]
Author Topic: aMSN and TLS on Linux 64 bits systems  (Read 11428 times)

Offline Offline

Posts: 1

View Profile
« on: April 15, 2010, 09:38:14 am »

Hello all,

I've recently (re)installed aMSN 0.98.3 on a new machine, a 64 bits computer, running SuSE Linux E.D.
And I had to face (again:-) a reccurent problem with the TLS plugin installation.
The TLS wizard downloads the plugin, says install is Ok, and upon connexion pretends the plugin is missing and propose to download, again and again and again...

After investigations, I think the problem rises because the wizard does download the tls package but doesn't check. And upon a connexion attempt, starting the library fails and aMSN thinks the package is not present instead of detecting a wrong package.
Shareable libraries are sensible code and very architecture dependent. The TLS lib relies on the TCL lib and the OpenSSL lib, and all should be compiled/installed with exactly the same architecture.
And this is NOT the default on 64 bits machines ! Too bad, but...

My problems came from architecture mismatch. From the aMSN TLS wizard, I selected a x86_64 module, but my TCL install was 32 bits (I didn't notice it was the default). And selecting from the wizard a x86 module didn't solve the problem because my OpenSSL instal lwas 64 bits. In all cases, the couldn't load and this made aMSN believe the lib wasn't installed.

So, here are some guidelines to install a working solution :

1. Download TCL and TK packages, I've downloaded 8.5, and be sure to build them for 64 bits architecture:
    cd tcl8.5.8/unix
    ./configure --enable-64bit
    make install

    Same for TK, with the --enable-64bit option (the default is OFF)

    NB: make default builds, with default installation dir, don't use the --prefix option to avoid path problems.

2. Download and build OpenSSL. The latest fixed version is 1.0.0
    The default build is 64 bits, so this is Ok for us. After installation, one can check the presence of /usr/local/ssl/lib64 directory.
    Add a symbolic link, /usr/local/ssl/lib -> /usr/local/ssl/lib64, for some configure scripts that won't look for the lib64 subdir and may complain ssl is not installed.

3. Download a TLS source package, latest is tls1.6
    Configure with the TCL installation, above, AND 64 bits architecture (not the default)
    ./configure --with-tcl=/usr/local/lib --with-tclinclude=/usr/local/include --with-ssl=/usr/local/ssl --enable-64bit
    make install

    NB: here again, avoid using the --prefix option and use standard installation paths, the tls module will then
    be placed in a consistent way, wrt TCL.

4. Last, configure and compile aMSN, pointing to the full TCL with TLS installation
    ./configure --with-tcl=/usr/local/lib --with-tk=/usr/local/lib
    make install

Start aMSN. It works, no TLS wizard dialog box, connexion is Ok, can meet friends. Effffff :-)

Super Power User
Offline Offline

Posts: 886

View Profile WWW
« Reply #1 on: April 15, 2010, 01:48:42 pm »

Really nice tutorial! I could make it sticky so other users with the same problem can read it. Thanks!
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!