aMSN Forums
May 21, 2018, 09:55:03 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Remember my choice option for Offline Messages doesn't work!  (Read 7358 times)
alroger
Newbie

Offline Offline

Posts: 5



View Profile WWW
« on: November 11, 2009, 03:16:14 pm »

Every time I login and have offline messages aMSN asks me if I want to read them. I check the "Remember my choice" option and click NO, but it doesn't remember it. Very anoying.
Does anyone know how to fix this? I simply want to IGNORE all offline messages!

Using aMSN 0.98.1 that comes with Ubuntu 9.10 with all updates.

Any ideas?
Logged

So little time... so many systems.
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #1 on: November 11, 2009, 05:47:07 pm »

This is the code
Code:

# we only remember if they want to read OIM's.
if { $answer == "yes" && $remember == 1} {
::config::setKey no_oim_confirmation 1
}

There is no 'ignore all offline messages' option anyways..
What you could do is go to amsn's directory, edit the file hotmail.tcl, find the function askReadReceivedOIMs :
Code:
proc askReadReceivedOIMs { oim_count oim_messages } {
if {[config::getKey no_oim_confirmation 0] == 1 } {
set answer "yes"
} else {
set answerAndRemember [::amsn::customMessageBox \
[trans receivedoimread $oim_count] yesno {} [trans newoim] {} 1]
set answer [lindex $answerAndRemember 0]
set remember [lindex $answerAndRemember 1]

# we only remember if they want to read OIM's.
if { $answer == "yes" && $remember == 1} {
::config::setKey no_oim_confirmation 1
}
}
if { $answer == "yes" } {
::OIM_GUI::MessagesReceived $oim_messages
}
}

Change that second line from "set answer yes" to "set answer no"
you can then make it remember that choice by enabling the option to not ask for oims in the advanced tab of the preferences..
but I'd like to ask, why would you not want to read messages that people send you ?
Logged

KaKaRoTo
alroger
Newbie

Offline Offline

Posts: 5



View Profile WWW
« Reply #2 on: November 11, 2009, 08:24:38 pm »

O great, the code for remembering only applies to Yes... how strange.

Thank you, I will try messing around with that part.

Thing is IM is for instant messages, and I get very annoyed when people start using it as an answering machine. I already have an answering machine and an email for customers to contact me. So in my working evironment trusting MSN worries me. All oficial requests have to come through email or helpdesk. I always told everyone that I do not accept offline messages... but aMSN and other MSN clients  started activating this offline protocol and no option to disable it.

When I do read them, usually I don't even know what people are talking about (they presume I do) and half the time I don't even know who they are with those strange nicks.
Logged

So little time... so many systems.
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #3 on: November 11, 2009, 09:47:32 pm »

hehe, ok, I understand, no problem then. Like I said, it's quite simple.. just replace "yes' by "no" in that file, and that's it, just restart amsn (no compilation required or anything like that)
Logged

KaKaRoTo
alroger
Newbie

Offline Offline

Posts: 5



View Profile WWW
« Reply #4 on: November 12, 2009, 12:01:49 am »

Thank you! It worked! Cheesy

Changed the second line to "no", then went into advanced preferences e checked "Do not ask for confirmation when sending/receiving Offline messages".
Logged

So little time... so many systems.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!