aMSN Forums
February 20, 2018, 03:06:20 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 [2] 3 4 5
  Print  
Author Topic: music plugin does not work in OS X Snow Leopard  (Read 73921 times)
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #15 on: September 19, 2009, 12:42:17 am »

welcome to the forums maiden_acdc...
Did you take the time to actually READ the answers given in this thread? the solution is right there, you just need to read it....
Logged

KaKaRoTo
maiden_acdc
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #16 on: September 19, 2009, 04:47:41 am »

I did read through the entire thread, but I don't have the /Library/ScriptingAdditions/Adobe Unit Types.osax, probably because I haven't installed any Adobe Suite yet. So I'm guessing it might be interfering with some other service? :/
Logged
maiden_acdc
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #17 on: September 19, 2009, 04:58:34 am »

hey! It works now, it wasn't loaded! I had to load it from the plugins page.. thanks for all the help anyway.

Cheers
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #18 on: September 19, 2009, 06:15:43 am »

lol!
oh well, at least it works :p
Logged

KaKaRoTo
koalaepilettico
Newbie

Offline Offline

Posts: 15


View Profile
« Reply #19 on: September 21, 2009, 03:45:02 pm »

hi!
i'm new in amsn forum, so hi all!
i have a problem with the music plugin (version 1.6), it doesn't show music in my nickname. i use leopard 10.5.8 and amsn version 0.98. i tried to do alt-p to see the log but it doesn't appear anything. it seems there is no problem, but it still not working. few days ago there was an update for the music plugin, i did it, but it doesn't work..
What can i do? it is loaded from the plugin list, and i use itunes 9, i've never had problems until now..
Logged
nicolunacba
Super Power User
**
Offline Offline

Posts: 349


View Profile
« Reply #20 on: September 21, 2009, 05:09:50 pm »

Hi! and welcome to the forum (I'm not an admin or developer, only saying hello xD). First, in Mac is Command + P. Second: you're right. I was testing it in my MacBook (10.5.8 with fu@#ing libraries compiled so It's going to die lol) and aMSN doesn't display the current song. My log says:

Code:
[13:14:16] Music: Actualsong isn't yet defined by asynchronous exec
[13:14:16] Music: Get song: 0
[13:14:17] Music: Error retreiving song : Play
Give me novacaine
Green Day
/Users/macbook/Music/iTunes/iTunes Music/Green Day/American Idiot/07 Give me novacaine.mp3
/Users/macbook/Library/Application Support/amsn/plugins/artworkitunes.png


What's happening?
Logged

I am a Mac user, but I use it like a Unix system ... Terminal.app for life!
koalaepilettico
Newbie

Offline Offline

Posts: 15


View Profile
« Reply #21 on: September 21, 2009, 08:54:28 pm »

well, using command + p it shows me logs. lol!

anyway this is my log when i'm listening to music:

Code:
[21:53:05] Music: Actualsong isn't yet defined by asynchronous exec
[21:53:05] Music: Get song: 0
[21:53:06] Music: Error retreiving song : Play
Cento mondi
Radiodervish
/Users/L***a/Music/iTunes/iTunes Music/Radiodervish/In search of Simurgh/10 Cento mondi.mp3
/Users/L***a/Library/Application Support/amsn/plugins/artworkitunes.png
[000:027] MagicCam 0: Current process: osascript, Flash is loaded: no
[000:027] Error(magiccammac.cc:276): MagicCam 0: MagicCamOpen: Not an allowed process!
[000:002] MagicCam 0: Current process: osascript, Flash is loaded: no
[000:002] Error(magiccammac.cc:276): MagicCam 0: MagicCamOpen: Not an allowed process!
[000:001] MagicCam 1: Current process: osascript, Flash is loaded: no
[000:001] Error(magiccammac.cc:276): MagicCam 1: MagicCamOpen: Not an allowed process!
[000:002] MagicCam 1: Current process: osascript, Flash is loaded: no
[000:002] Error(magiccammac.cc:276): MagicCam 1: MagicCamOpen: Not an allowed process!
[21:53:10] Music: Actualsong isn't yet defined by asynchronous exec
[21:53:10] Music: Get song: 0
[21:53:11] Music: Error retreiving song : Play
Cento mondi
Radiodervish
/Users/L***a/Music/iTunes/iTunes Music/Radiodervish/In search of Simurgh/10 Cento mondi.mp3
/Users/L***a/Library/Application Support/amsn/plugins/artworkitunes.png
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #22 on: September 22, 2009, 08:14:37 am »

yeah, this is more complicated unfortunately.. i'll have a look at it this week, but mainly, even if it does work, there is a file (for MagicCam) that does something wrong and makes amsn think that it failed to retreive the music info... hopefully, if we can change those applescripts into text instead of binary, maybe we'll be able to avoid all those problems! I'll post here when there is a solution...
Logged

KaKaRoTo
koalaepilettico
Newbie

Offline Offline

Posts: 15


View Profile
« Reply #23 on: September 22, 2009, 09:03:42 am »

The strange thing is that one of my friend, with the same plugin version, using the same amsn version, and leopard 10.5.8 with itunes 9 doesn't have any problem! how is it possible? -.-
What is MagicCam?

EDIT: i think the problem is in google talk browser plugin, a plugin for video conversations in igoogle, ONLY with the version 1.0.15. I solved the music plugin problem by deleting google plugin. Anyway music plugin for amsn and google talk browser plugin work using the previous version of the google plugin (1.0.13), but i don't know where i can find this version (in fact my friend has that version).
thanks for your help!  Cheesy
Logged
deschansons
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #24 on: October 07, 2009, 08:58:30 pm »

Hello, I don't have a /Library/ScriptingAdditions/Adobe Unit Types.osax file (I can't find it, I don't have a ScriptingAdditions folder that I know of). And the Music plugin isn't working for me. I'm new to mac, so if it's in an obvious place, feel free to laugh at me.
Logged
_aeon
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #25 on: October 09, 2009, 04:53:17 pm »

Here it's not working either... Sad

Mac OS X 10.6.1 (Snow Leopard)
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #26 on: October 09, 2009, 08:57:37 pm »

@deschansons, @_aeon: now, both of you, go read the damn thread and figure out what you have to do to get it fixed, I'm not going to repeat myself everytime a new user comes in!
Logged

KaKaRoTo
_aeon
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #27 on: October 09, 2009, 09:58:15 pm »

Quote from: "kakaroto"
@deschansons, @_aeon: now, both of you, go read the damn thread and figure out what you have to do to get it fixed, I'm not going to repeat myself everytime a new user comes in!


I did read the "damn thread" but if I delete 'Adobe Unit Types.osax' and/or 'QXPScriptingAdditions.osax', Photoshop CS4 stops working! So, that's not the best solution, is it?

Here is the pic:



UPDATE: Ok, Music Plugin is working now and Photoshop is also working after all. I get this notice everytime I run it but hey... *sigh* Tongue
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #28 on: October 10, 2009, 01:00:04 am »

Well, deleting it is the best solution because even if you keep the file, it doesn't change the fact that the file will *not work* on snow leopard.. so.. would you rather have a completely useless file on your mac that breaks amsn's music plugin, or remove the file that is useless and endure an apparently stupid photoshop warning..
anyways, I've downloaded photoshop and i'll try to reproduce this and see if I can find a fix...
Logged

KaKaRoTo
nicolunacba
Super Power User
**
Offline Offline

Posts: 349


View Profile
« Reply #29 on: October 10, 2009, 02:15:52 am »

Kakaroto, In my case I don't have Adobe Ps (so I don't have that osax file) and I can't get it works! It's not only a Snow Leopard problem, it's Leopard too! Is it working in your Mac?
Logged

I am a Mac user, but I use it like a Unix system ... Terminal.app for life!
Pages: 1 [2] 3 4 5
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!