aMSN Forums
February 19, 2018, 04:53:15 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: "Ignore the conversations from the contact"  (Read 9824 times)
juan123
Newbie

Offline Offline

Posts: 5


View Profile
« on: May 21, 2009, 03:37:53 pm »

I selected a contact in aMSN and looked at their properties.  On the Settings tab, I noticed that "Ignore the conversations from the contact" is checked and in red.  What does this mean?  Does it imply  that if this contact sends me a message I won't see it?  Or do I have to initiate the conversation to see their messages?  I'm a bit confused.

And what is this "red"??  If I uncheck a box that is white, it turns red with no checkmark. Then if I check it again, it is checked but still red.  What does the red indicate???
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #1 on: May 21, 2009, 05:06:52 pm »

Hi, welcome to the forums,
the ignore conversations is a smart way to 'block' someone without actually blocking him.. if someone is annoying but you don't want to block him, you just enable that checkbox so that aMSN will ignore his messages and you won't see them. this is whether you open the chat or not... (I think if he/she opens the chat, aMSN won't answer, so all his messages will be returned to him with "unable to send message", so that he/she may think you have connection problems and not that you decided to block him/her).
the checkbox is red because Tk (the toolkit) shows it like that, being red doesn't mean that it's enabled, there are two version of Tk, one where disabeld is grey and enabled is red, and the other version is where disabled is red and enabled is red with a little check on it.
Logged

KaKaRoTo
juan123
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #2 on: May 21, 2009, 07:59:24 pm »

Quote from: "kakaroto"

the checkbox is red because Tk (the toolkit) shows it like that, being red doesn't mean that it's enabled, there are two version of Tk, one where disabeld is grey and enabled is red, and the other version is where disabled is red and enabled is red with a little check on it.


Hi kakaroto, thank you for the reply.  I noticed the the option is "checked".  I don't remember checking it, so I was a little confused as to what was the default.   I didn't want to accidently block the contact because I didn't understand what it is.  

So... just to confirm I'm understanding you. If I am seeing that option with a 'check'... I've basically soft blocked the contact? I am using 0.97.2 on windows.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #3 on: May 21, 2009, 08:44:59 pm »

yes.. by default they are unchecked (of course), but you might have checked it accidently at some point... if the option is checked, then the user is as you nicely described it 'soft-blocked' Smiley
Logged

KaKaRoTo
juan123
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #4 on: May 22, 2009, 08:55:48 am »

Quote from: "kakaroto"
yes.. by default they are unchecked (of course),


From what I am seeing, it is defaulting to 'checked' visually, but acting as if it is 'unchecked'..... here is what I did:

I made a fake windows live account and entered it using a different msn client in order to interact with aMSN on the same local computer.  

From aMSN, I sent an invite to the other client.  The other client accepted.  aMSN did not register the other client online, until they signed out and signed in again.  Fair enough...aMSN probably only puts a client 'online' when they send the signal at first login... although maybe 'accepting' the invite is sufficient to assume the client is online?? (Not a big deal but I thought I'd mention it)

So with the new contact accepted and now 'online' in aMSN, I selected the contact, right clicked, selected Properties>Settings, and looked for the 'ignore' option.  *It IS CHECKED BY DEFAULT*, but has a 'grey' background.   I then sent a message from the new contact and aMSN accepted it.  So although it is checked by default, it does not 'ignore'...  which is good otherwise aMSN would auto-ignore all new contacts.

I tried playing around with the check box. It starts grey, then once clicked it goes red and will never goes back to grey.  [I have a feeling 'grey' means 'uninitialized state' which probably defaults to checked as well ... is the UI getting initialized on load?].

So, from the default 'checked/grey' state, I unchecked the 'ignore', then checked it.  Now it is checked and red.   The contact can still send messages.  On a hunch, I logged out of aMSN and entered again (didn't need to restart..just log out/in).  Now the ignore funcionality works and I confirmed the contact cannot send messages to aMSN.

Confirmed the behavior of ignore as follows: if I send a message to an 'ignored' contact, they recieve the message and the contact can then respond to me within that chat window. But if I didn't initiate the communication, and the other client tries to send a message, the message is 'ignored'.

It would be *a really good idea* to have some sort of visual indication in the contact list, that a contact is ignored, otherwise, an 'accidently ignored' user could maintain that state forever and no one would know why their friend cannot contact them... probably ending in blaming aMSN as not working and abandoning the program.

On a side note, I think what happened in my circumstances, is I was clicking around while exploring the features of aMSN.  I know that I had curiosity about the 'grey/red thing' and was trying to figure out what it signified.  Since I didn't want to 'change anything', I probably took note that 'ignore' was checked by default,  clicked it a few times to see if it would change color, then returned it to its initial checked state without actually reading what I was clicking.

Again.. this is 0.97.2 (07/25/2008) running on Windows XP, SP2.  I am pretty sure I just did a default install.. if you need any additional information on the version/install just ask.
Logged
juan123
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #5 on: May 22, 2009, 09:23:23 am »

Okay.. then it gets even more complicated from there....

I can't repeat my steps.  Some are lost.  But I clicked the ignore a few times.  Although I left it unchecked, the contact could not send me messages.  I logged in and out.  Still not working.  I exited aMSN and restarted. Still not working.  I finally deleted the contact (with the chat window open..some wierd scrolling of the conversation happened).  I resent the invite from aMSN.  Now.. 'ignore' is unchecked and red.  I can receive messages from the contact.  Clicked the 'ignore' check box to activate it.  It takes immediate affect.  I uncheck 'ignore'.  Doesn't take immediate affect.. the contact has to go offline then online before they can send messages again.  That is *bad* because if you temporarily ignored someone, you wouldn't know they are still being ignored.
Logged
Blargh76
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #6 on: February 14, 2011, 05:29:23 am »

 
yes.. by default they are unchecked (of course)

 
No, by default it looks like this:
 


...just after you've added a contact, and click on their properties and go to Settings.
 
If you click on any of the boxes, they turn red (and remain ticked)...
If you click again, they become unticked and are still red...
If you click once more, they become ticked again and are still red.


---

sidenote: I just added some contacts and then signed out and then signed in again and all those
newly added contacts were now suddenly blocked. I mean, really blocked. I had to unblock them.


(all of the above is using the latest release offered in the downloads, 0.98.4. On Win XP.
« Last Edit: February 14, 2011, 05:36:49 am by Blargh76 » Logged
Stadt
Newbie

Offline Offline

Posts: 32


View Profile
« Reply #7 on: February 14, 2011, 08:45:23 pm »

After aMSN had some problems with config.xml all my contacts have the same settings as in Blargh76's screenshot (gray checkmarks). I think it is pretty stupid.
Logged
Blargh76
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #8 on: February 15, 2011, 12:52:19 am »

I should add that Alarms, next to Settings, appears the same way... Every option is ticked with a gray background.
 
So weird.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!