aMSN Forums
December 04, 2020, 06:57:53 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 2 [3] 4 5 ... 8
  Print  
Author Topic: Installing Amsn svn : A repository for Ubuntu users  (Read 175316 times)
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9425


View Profile WWW
« Reply #30 on: May 24, 2009, 02:27:01 am »

Hi, welcome to the forums!
well, first, make sure you are installing the correct version.. and also that you have the latest SVN revision... if you compiled farsight2/gstreamer/etc.. yourself, make sure you installed it in /usr not /usr/local/ if the ./configure of amsn doesn't find farsight, then upload the config.log file somewhere, i'll have a look...
Logged

KaKaRoTo
Menion
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #31 on: May 24, 2009, 11:47:32 am »

That is the point:

Quote
configure:7145: checking for FARSIGHT2
configure:7154: $PKG_CONFIG --exists --print-errors "\
             farsight2-$GST_MAJORMINOR >= $FARSIGHT_REQUIRED"
Requested 'farsight2-0.10 >= 0.0.9' but version of Farsight2 is 0.0.2
configure:7158: $? = 1
configure:7175: $PKG_CONFIG --exists --print-errors "\
             farsight2-$GST_MAJORMINOR >= $FARSIGHT_REQUIRED"
Requested 'farsight2-0.10 >= 0.0.9' but version of Farsight2 is 0.0.2
configure:7179: $? = 1
Requested 'farsight2-0.10 >= 0.0.9' but version of Farsight2 is 0.0.2
configure:7210: result: no


So it seems I have the correct package installed (and I have because I got the amsn repository) but for some reason in the packages configuration it is detected as 0.0.2!!!
How can I fix it?
Bye and thanks!
Logged
Menion
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #32 on: May 24, 2009, 11:47:54 am »

That is the point:

Quote
configure:7145: checking for FARSIGHT2
configure:7154: $PKG_CONFIG --exists --print-errors "\
             farsight2-$GST_MAJORMINOR >= $FARSIGHT_REQUIRED"
Requested 'farsight2-0.10 >= 0.0.9' but version of Farsight2 is 0.0.2
configure:7158: $? = 1
configure:7175: $PKG_CONFIG --exists --print-errors "\
             farsight2-$GST_MAJORMINOR >= $FARSIGHT_REQUIRED"
Requested 'farsight2-0.10 >= 0.0.9' but version of Farsight2 is 0.0.2
configure:7179: $? = 1
Requested 'farsight2-0.10 >= 0.0.9' but version of Farsight2 is 0.0.2
configure:7210: result: no


So it seems I have the correct package installed (and I have because I got the amsn repository) but for some reason in the packages configuration it is detected as 0.0.2!!!
How can I fix it?
Bye and thanks!
Logged
Menion
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #33 on: May 24, 2009, 01:13:26 pm »

Update:

I found I had installed the 0.0.2 version in /usr/local. So I removed it, or better to be sure that I didn't have any strange library setup I installed farsight2 both in /usr and /usr/local. Now configure correctly report farsight2 (latest version 0.10) is installed. But I still can't have it working...
Any clue of what I can look for? I did also a strace, all the library seems to work corretly, the only "problem" I have is:

lstat64("/usr/lib/farsight2-0.0/pkgIndex.tcl", 0xbfc8792c) = -1 ENOENT (No such file or directory)

but I don't think it is important. Shall I use version 0.9 instead?

Bye

//Antonio

P.S. When I check for Audio/Video preferences and it fails with farsight2 extension, Details button doesn't work
Logged
Menion
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #34 on: May 24, 2009, 01:46:56 pm »

Update2:

Finally I got the point: I have to run amsn as root to have farsight2 working. This could explain all this problems users report sometimes about farsight2 not working even if ./configure detects it. I'm running Ubuntu 9.04
Bye
Logged
afv
Newbie

Offline Offline

Posts: 31


View Profile
« Reply #35 on: May 25, 2009, 02:29:27 am »

Hi, thanks for the PPA.

I had to do
Code:
sudo chmod +x /usr/share/amsn/plugins/music/infosongbird

because I was getting this error when enabling the music plugin:
Code:
Music: Error retreiving song : couldn't execute "/usr/share/amsn/plugins/music/infosongbird": permission denied
Logged
AL3X2
Newbie

Offline Offline

Posts: 29


View Profile
« Reply #36 on: May 25, 2009, 03:03:42 am »

Hi, I tried the repo. Instalation went very well. But I launch amsn and try to login, but I get the famous "TLS not installed" prob.
I have tried placing the tls1.50 folder in ~/.amsn/plugins, in /usr/shared/amsn/, and no luck.

If I open amsn's log (ctrl + s) and I type "package require tls" I get:

"couldn't load file "home........../amsn/plugins/tls1.50/libtls-1.50.so": libssl.so.0.9.7: cannot open shared object file: No such file or directory."

I have installed libssl0.9.8 (the default in jaunty) and tls 1.5

I have tried placing the 0.9.7 so, but no luck.

What could I do?
Thanks
Logged
kjir
Power user
*
Offline Offline

Posts: 133


View Profile
« Reply #37 on: May 25, 2009, 07:43:17 pm »

The error message means that libtls-1.50.so is linked against libssl.so.0.9.7, you'll need to recompile libtls in order to make it work...
Logged
AL3X2
Newbie

Offline Offline

Posts: 29


View Profile
« Reply #38 on: May 26, 2009, 12:48:48 am »

I can't remove tcl-tls from my pc (-> I can't rebuild it from src) because when I do "sudo apt-get install amsn" it install automatically "tcl-tls".

Any other ideas :/ ?

Thanks!
Logged
Stemp
Power user
*
Offline Offline

Posts: 71



View Profile WWW
« Reply #39 on: May 26, 2009, 10:42:40 am »

You probably have an older (on hand) installation of tcl-tls.
The version in Jaunty is linked to libssl0.9.8
Logged

AL3X2
Newbie

Offline Offline

Posts: 29


View Profile
« Reply #40 on: May 26, 2009, 01:33:38 pm »

Ok. I did "sudo apt-get install libssl0.9.8" and I keep getting the same error.
I'm on Jaunty, official repos. Searching for libssl in synaptic shows me version 0.9.8

What could be wrong?
Logged
kjir
Power user
*
Offline Offline

Posts: 133


View Profile
« Reply #41 on: May 26, 2009, 02:54:33 pm »

I'd say stop reinstalling libssl and start reinstalling tcl-tls Wink That's the package with problems, not libssl
Logged
flomar34
Newbie

Offline Offline

Posts: 47


View Profile
« Reply #42 on: May 26, 2009, 02:58:44 pm »

hello,

did you try to remove the amsn folder in your home ( home/yourname/.amsn)

Be carefull, you will lose your preferences and your login identification (make a backup of it)
     
uninstall amsn

Code:
sudo apt-get autoremove amsn

with the autoremove it will uninstall tls
 and install it

Code:
sudo apt-get install amsn
Logged
AL3X2
Newbie

Offline Offline

Posts: 29


View Profile
« Reply #43 on: May 26, 2009, 03:12:52 pm »

Ok, I did both things.
I removed .amsn and tried installing without luck.
Then I removed amsn, amsn-data, tcl-tls.
Then I installed tcl-tls and then amsn. No luck. Still the same error... libssl0.9.7 not found... :S
Logged
kjir
Power user
*
Offline Offline

Posts: 133


View Profile
« Reply #44 on: May 26, 2009, 03:28:34 pm »

The file "home........../amsn/plugins/tls1.50/libtls-1.50.so" has been reinstalled? Is it installed by Ubuntu??
Logged
Pages: 1 2 [3] 4 5 ... 8
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!