aMSN Forums
December 04, 2020, 06:10:30 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 ... 3 4 [5] 6 7 8
  Print  
Author Topic: Installing Amsn svn : A repository for Ubuntu users  (Read 175297 times)
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9425


View Profile WWW
« Reply #60 on: June 03, 2009, 06:56:00 pm »

great, thanks Stemp!
Logged

KaKaRoTo
stimpyjcat
Newbie

Offline Offline

Posts: 7


View Profile
« Reply #61 on: June 05, 2009, 05:38:13 pm »

good, i will see what can do during the weekend ^^

the sound problems looks like is on other part of the system, cos i have tried another voice chat soft (empathy with gmail) with the same effect when calling from the machine with amsn (maybe is gstreamer or the sound driver)
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9425


View Profile WWW
« Reply #62 on: June 12, 2009, 01:37:42 am »

libnice 0.0.7 has been released.. I don't know if it fixes your current issue, so could you just get me the gdb backtrace with what you currently have now that Stemp uploaded debug symbols ?
thanks
Logged

KaKaRoTo
stimpyjcat
Newbie

Offline Offline

Posts: 7


View Profile
« Reply #63 on: June 14, 2009, 06:43:16 am »

Quote from: "kakaroto"
libnice 0.0.7 has been released.. I don't know if it fixes your current issue, so could you just get me the gdb backtrace with what you currently have now that Stemp uploaded debug symbols ?
thanks
ok, got all the updates ( including kernel ) and all the debugging symbols

this time dont last a minute  Tongue  (calling from wlmsn to amsn)

bt
Code:
[Thread 0x7ff68ef91950 (LWP 31771) exited]                                          

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ff6a851b950 (LWP 31752)]    
priv_turn_allocate_refresh_retransmissions_tick (pointer=0x7ff6a5c87010)
    at conncheck.c:741                                                  
741     conncheck.c: No such file or directory.                        
        in conncheck.c                                                  
(gdb) bt                                                                
#0  priv_turn_allocate_refresh_retransmissions_tick (pointer=0x7ff6a5c87010)
    at conncheck.c:741                                                      
#1  0x00007ff6af7c097b in g_timeout_dispatch (source=0x443a5a0, callback=0x24000,
    user_data=0x7ff6a5ca7000) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:3253  
#2  0x00007ff6af7c020a in IA__g_main_context_dispatch (context=0x2ab3210)        
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814                            
#3  0x00007ff6af7c38e0 in g_main_context_iterate (context=0x2ab3210, block=1,    
    dispatch=1, self=<value optimized out>)                                      
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448                            
#4  0x00007ff6af7c3dad in IA__g_main_loop_run (loop=0x3e551a0)                    
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2656                            
#5  0x00007ff69ecccda1 in fs_nice_agent_main_thread (data=0x28a98c0)              
    at fs-nice-agent.c:315                                                        
#6  0x00007ff6af7e9ae4 in g_thread_create_proxy (data=0x3e546e0)                  
    at /build/buildd/glib2.0-2.20.1/glib/gthread.c:635                            
#7  0x00007ff6b51c33ba in start_thread (arg=<value optimized out>)                
    at pthread_create.c:297                                                      
#8  0x00007ff6b389afcd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112                            
#9  0x0000000000000000 in ?? ()    


bt full

Code:
#0  priv_turn_allocate_refresh_retransmissions_tick (pointer=0x7ff6a5c87010)      
    at conncheck.c:741                                                            
No locals.                                                                        
#1  0x00007ff6af7c097b in g_timeout_dispatch (source=0x443a5a0, callback=0x24000,  
    user_data=0x7ff6a5ca7000) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:3253    
No locals.                                                                        
#2  0x00007ff6af7c020a in IA__g_main_context_dispatch (context=0x2ab3210)          
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814                              
No locals.                                                                        
#3  0x00007ff6af7c38e0 in g_main_context_iterate (context=0x2ab3210, block=1,      
    dispatch=1, self=<value optimized out>)                                        
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448                              
        max_priority = 2147483647                                                  
        timeout = 3231                                                            
        some_ready = 1                                                            
        nfds = 1                                                                  
        allocated_nfds = <value optimized out>                                    
        fds = (GPollFD *) 0x3e54730                                                
        __PRETTY_FUNCTION__ = "g_main_context_iterate"                            
#4  0x00007ff6af7c3dad in IA__g_main_loop_run (loop=0x3e551a0)                    
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2656                              
        self = (GThread *) 0x3e546e0                                              
        __PRETTY_FUNCTION__ = "IA__g_main_loop_run"                                
#5  0x00007ff69ecccda1 in fs_nice_agent_main_thread (data=0x28a98c0)              
    at fs-nice-agent.c:315                                                        
No locals.                                                                        
#6  0x00007ff6af7e9ae4 in g_thread_create_proxy (data=0x3e546e0)
    at /build/buildd/glib2.0-2.20.1/glib/gthread.c:635
        __PRETTY_FUNCTION__ = "g_thread_create_proxy"
#7  0x00007ff6b51c33ba in start_thread (arg=<value optimized out>)
    at pthread_create.c:297
        __res = <value optimized out>
        pd = (struct pthread *) 0x7ff6a851b950
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {0, -739566533635011961,
        8392704, 0, 140697588297792, 140736377210304, 743613477367253639,
        743624038779783815}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0,
      0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        robust = <value optimized out>
#8  0x00007ff6b389afcd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
No locals.
#9  0x0000000000000000 in ?? ()
No symbol table info available.


thanks in advance ^^

ps: i have a lot of options with farsight at the video configuration window (one of the latest in the wizard) will try to play with that too
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9425


View Profile WWW
« Reply #64 on: June 18, 2009, 03:36:12 am »

Ah, thanks stimpycat!
I just saw your post, I guess I missed it before, sorry!
Thanks for the backtrace! Yep, indeed, that's a new bug in libnice! Somehow it looks like the TURN server doesn't refresh the allocations correctly... I wonder why... One possibility is that the UDP refresh messages get lost if you are receiving/sending too much data for your bandwidth!
I'd really like to know how it happens exactly... does the sound work correctly for 5 minutes and then it crashes ? or is it different ?
In any case, the next release should fix it.. I had already changed a few things in the last couple of days that coincidently fix this same bug, so you should be fine with the current git... I'd like to test it a little bit more and hopefully release 0.0.8 sometime this week!
Thanks!
Logged

KaKaRoTo
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9425


View Profile WWW
« Reply #65 on: June 20, 2009, 12:13:29 am »

@stimpycat: libnice 0.0.8 has just been released! If you update to it, it shouldn't crash anymore...
@Stemp: could you update the repository with libnice 0.0.8? thanks!
Logged

KaKaRoTo
Stemp
Power user
*
Offline Offline

Posts: 71



View Profile WWW
« Reply #66 on: June 20, 2009, 10:21:39 am »

Quote from: "kakaroto"
@Stemp: could you update the repository with libnice 0.0.8? thanks!


Done  :wink:
Logged

flomar34
Newbie

Offline Offline

Posts: 47


View Profile
« Reply #67 on: June 20, 2009, 10:46:35 am »

Hi,

Thanks Stemp.

kakaroto: With the last update (last svn and libnice 0.0.8 ) i have an error message when y want to try farsight

Code:
can't read "fsaudiosrcs": no such variable
    while executing
"set srcs $fsaudiosrcs"
    (procedure "::AVAssistant::StepFarsightClBk" line 62)
    invoked from within
"::AVAssistant::StepFarsightClBk .assistant1 .assistant1.bodyf.contentf 1 1"
    ("eval" body line 1)
    invoked from within
"eval [linsert $callbk end 1]"
    (procedure "::MSNSIP::FarsightTestSucceeded" line 31)
    invoked from within
"::MSNSIP::FarsightTestSucceeded {::AVAssistant::StepFarsightClBk .assistant1 .assistant1.bodyf.contentf 1}"
    ("eval" body line 1)
    invoked from within
"eval $options(-prepared)"


Hope it helps
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9425


View Profile WWW
« Reply #68 on: June 20, 2009, 06:04:08 pm »

cool, thanks Stemp for your fast work!
flomar34, the assistant is being worked on... don't use the assistant for now, just make the call from the chat window!
Logged

KaKaRoTo
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9425


View Profile WWW
« Reply #69 on: June 26, 2009, 07:56:07 pm »

alright, the assistant should be fixed now.. it's not functional, but at least it won't bug on you...
Logged

KaKaRoTo
Kreuger
Super Power User
**
Offline Offline

Posts: 204


View Profile WWW
« Reply #70 on: August 12, 2009, 10:26:46 pm »

Today there was an update available and I had trouble installing the lib of libgupnp-igd-1.0.2 so I removed it from /usr/lib (because it said it wouldnt overwrite it) and now when I run amsn it gives me an error about TkCxImage because it cant load  libgupnp-igd-1.0.2 in /utils/TkCxImage. I tried a whereis and got this:

Quote
kreuger@kreuger-desktop:~/Desktop$ whereis  libgupnp-igd-1.0.2
libgupnp-igd-1.0: /usr/lib/libgupnp-igd-1.0.la /usr/lib/libgupnp-igd-1.0.a /usr/lib/libgupnp-igd-1.0.so
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9425


View Profile WWW
« Reply #71 on: August 13, 2009, 04:37:11 am »

Kreuger.. recompile amsn.. I think that amsn should be compiled with the flag --as-needed to gcc, this way it won't link TkCximage to the libgupnp-igd library since it doesn't need it...
We hope to finally fix our makefiles in the future so that libraries only get linked against what they really need...
Logged

KaKaRoTo
Kreuger
Super Power User
**
Offline Offline

Posts: 204


View Profile WWW
« Reply #72 on: August 13, 2009, 05:53:43 am »

Yeah I removed it and just grabbed the svn tar off the website. It's weird though because for the longest time Ive had no trouble with this repo
Logged
Stemp
Power user
*
Offline Offline

Posts: 71



View Profile WWW
« Reply #73 on: August 13, 2009, 07:19:41 am »

Quote from: "Kreuger"
Yeah I removed it and just grabbed the svn tar off the website. It's weird though because for the longest time Ive had no trouble with this repo


What is exactly your problem with the repo ? gupnp-igd wasn't updated since june.
Logged

kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9425


View Profile WWW
« Reply #74 on: August 13, 2009, 08:44:00 am »

maybe gupnp-igd was updated in the official repositories...
Logged

KaKaRoTo
Pages: 1 ... 3 4 [5] 6 7 8
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!