aMSN Forums
April 26, 2018, 10:53:58 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 [2] 3 4 ... 8
  Print  
Author Topic: Installing Amsn svn : A repository for Ubuntu users  (Read 136725 times)
linux3114a
Newbie

Offline Offline

Posts: 22



View Profile WWW
« Reply #15 on: April 20, 2009, 06:04:03 pm »

Quote from: "CyberAngel"
Hi,
I installed amsn from the ppa repository but I get this error having to do with farsight:

Code:
Farsight : Preparing
Farsight Prepare error : couldn't load file "utils/farsight/tcl_farsight.so": utils/farsight/tcl_farsight.so: wrong ELF class: ELFCLASS32


I didn`t have farsight installed before nor I did any attempt to compile it from svn on my own in the past...

I`m using kubuntu jaunty.
Any clue?



Have the same problem after using this reposit with intrepid..... not serious
raoul
Logged
flomar34
Newbie

Offline Offline

Posts: 47


View Profile
« Reply #16 on: April 20, 2009, 06:28:31 pm »

For intrepid there is NO farsight in this repo for the moment. So you have to install farsight by yourself.

What is not serious for you ... ?
Stemp will update it when he will have enough free time.

I think that it's a very good idea to have a repo with all the updated dependencies needed for amsn svn.
Logged
CyberAngel
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #17 on: April 20, 2009, 07:14:51 pm »

is there any known problem for the amd64 architecture and the farsight?
If yes, is there any known workaround?

Thanks
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #18 on: April 20, 2009, 10:52:14 pm »

@CyberAngel: no known problem for amd64, but if you tell us what your problem is then we might help (but use the correct thread please)
Logged

KaKaRoTo
CyberAngel
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #19 on: April 20, 2009, 11:10:09 pm »

Quote from: "kakaroto"
@CyberAngel: no known problem for amd64, but if you tell us what your problem is then we might help (but use the correct thread please)


Actually I was thinking that there might be a known problem with the packages from the repositories (and with amsn itself) cause when I first asked in this thread why the audio conference is not working I had this reply from flomar34:

Quote
Hello,

Are you using a 64 bits system? Maybe there is a problem with it


My problem is that even if farsight is installed from the repository, I get this error in the Preferences -> Others -> Edit audio and video settings:

Code:
Farsight : Preparing
Farsight Prepare error : couldn't load file "utils/farsight/tcl_farsight.so": utils/farsight/tcl_farsight.so: wrong ELF class: ELFCLASS32


And I get this error in the conversation window:

Code:
You cannot make an Audio Call. Please install Farsight2 and try again.


if you see below, I have the farsight library installed from the repositories...

Code:
:/usr/share/amsn/utils/farsight$ ls
pkgIndex.tcl  tcl_farsight.so


Code:
:/usr/share/amsn/utils/farsight$ apt-cache policy libgstfarsight0.10-0
libgstfarsight0.10-0:
  Installed: 0.0.9-1~jjamsn2
  Candidate: 0.0.9-1~jjamsn2
  Version table:
 *** 0.0.9-1~jjamsn2 0
        500 http://ppa.launchpad.net jaunty/main Packages
        100 /var/lib/dpkg/status
     0.0.7-1ubuntu1 0
        500 http://gr.archive.ubuntu.com jaunty/universe Packages


Code:
:/usr/share/amsn/utils/farsight$ apt-cache policy gstreamer0.10-plugins-farsight
gstreamer0.10-plugins-farsight:
  Installed: 0.12.11-1~jjamsn1
  Candidate: 0.12.11-1~jjamsn1
  Version table:
 *** 0.12.11-1~jjamsn1 0
        500 http://ppa.launchpad.net jaunty/main Packages
        100 /var/lib/dpkg/status
     0.12.10-2 0
        500 http://gr.archive.ubuntu.com jaunty/universe Packages
Logged
kjir
Power user
*
Offline Offline

Posts: 133


View Profile
« Reply #20 on: April 21, 2009, 05:32:44 pm »

I'd say that the repository is for 32bit ONLY, you have to recompile farsight.
Logged
CyberAngel
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #21 on: April 21, 2009, 08:46:55 pm »

Quote from: "kjir"
I'd say that the repository is for 32bit ONLY, you have to recompile farsight.


If you check this link http://ppa.launchpad.net/amsn-daily/ppa/ubuntu/pool/main/f/farsight2/, you can see that amd64 packages exists too!
More than that, amsn svn is working fine from this repository in my 64bits system except the calls.
Logged
kjir
Power user
*
Offline Offline

Posts: 133


View Profile
« Reply #22 on: April 21, 2009, 09:20:46 pm »

Well the above errors mean that you are trying to load a 32 bit library on a 64bit system. I can assure you that farsight 2 works flawlessly with amd64, I compiled it and it works fine...
Logged
Kreuger
Super Power User
**
Offline Offline

Posts: 204


View Profile WWW
« Reply #23 on: April 23, 2009, 02:34:32 pm »

Quote
Your preferences are saved in your home in the .amsn folder

Oh that's right. Still have the problem though.
Logged
flomar34
Newbie

Offline Offline

Posts: 47


View Profile
« Reply #24 on: April 23, 2009, 03:38:04 pm »

@Kreuger : Sorry for that Kreuger, but the only similar problem i found is from harrydb who had an older version of farsiht in the same time

Maybe you compiled yourself before or installed in an other way and then made a

sudo ldconfid

so now amsn is looking for this librairy in the wrong place
maybe try to find if there is no an older version of farsight in your computer, uninstall it and try

Code:
sudo ldconfig



Stemp updated the ppa to the revision 11149 so if it's working for somebody  Tongue  you could test the audio and video using MSNP18
(jaunty is out today, so maybe the  ppa could be down )
Logged
Kreuger
Super Power User
**
Offline Offline

Posts: 204


View Profile WWW
« Reply #25 on: April 30, 2009, 02:16:13 pm »

Yeah I did try to install it myself, before. It was version 2.0.0.8 though, isn't that what's in the repo?
Logged
flomar34
Newbie

Offline Offline

Posts: 47


View Profile
« Reply #26 on: May 06, 2009, 03:12:47 pm »

Hi,

No, in the repo it's the 0.0.9 version of farsight.

(since jaunty is out, it needs about 12 hours to update PPA's,so before installing it look here if its built)

The 11163 revision should be built in 9 hours from now  :lol:

Hope it will be faster last week
Logged
Stemp
Power user
*
Offline Offline

Posts: 71



View Profile WWW
« Reply #27 on: May 06, 2009, 07:47:39 pm »

version 11163 wkt3 should fix the farsight problem on 64 bits system Wink
Logged

flomar34
Newbie

Offline Offline

Posts: 47


View Profile
« Reply #28 on: May 09, 2009, 05:46:23 pm »

Hi,

Kreuger: Some people had problem with an older version of farsight installed in them system
before the last version of the amsn-dayli repo
and the solution was with this 2 commands

Code:
mv /home/$USER/.gstreamer-0.10 /home/$USER/.gstreamer-0.10.bak
mv /home/$USER/.farsight /home/$USER/.farsight.bak


If you can understand the french,
http://forum.ubuntu-fr.org/viewtopic.php?pid=2630483#p2630483

Hope it helps  Smiley
Logged
Menion
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #29 on: May 23, 2009, 10:39:31 am »

Hi
I still can't get farsight2 working with AMSN. I'm trying both a self build SVN and Ubuntu package from the repository. I also either downloaded farsight2 as Ubuntu package either selfcompiled it. Nope! If I compile aMSN by myself ./configure doesn't detect farsight2 package, even if I followed the wiki instructions and downloaded all the dependencies. I tried also do selfcompile libnice with the same result. Do you know what I can check to see if I have everything it is needed to have farsight2 working in aMSN? I'm placing the question here, because as I saif it seems that also Ubuntu package have something wrong, at least on my system.
Bye
Logged
Pages: 1 [2] 3 4 ... 8
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!