aMSN Forums
October 22, 2014, 07:18:40 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 2 [3]
  Print  
Author Topic: UPNP an feature wanted..  (Read 34834 times)
H@t Trick
Super Power User
**
Offline Offline

Posts: 340



View Profile
« Reply #30 on: March 12, 2009, 02:24:21 am »

@kakaroto: Thanks! It was great!! But who said I was back from Brazil? I could still be there? Tongue I could have stayed for the conference lol naw I am home, back to work already Sad
And I see now, wasn't too clear, sorry.
Logged

There's no place like 127.0.0.1!
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #31 on: March 12, 2009, 04:56:16 am »

hehe, I knew it because your PSM on msn said "back home" or something like that... :p
Logged

KaKaRoTo
H@t Trick
Super Power User
**
Offline Offline

Posts: 340



View Profile
« Reply #32 on: March 12, 2009, 05:00:46 am »

haha, yeah I know! plus I told you I'd be back by now!
Logged

There's no place like 127.0.0.1!
matthaeus123
Newbie

Offline Offline

Posts: 12


View Profile
« Reply #33 on: March 24, 2009, 06:58:22 am »

if anybody is interested. I just made a ubuntu PPA repo for the gupnp dependencies for AMSN. I should have everything up and running and ready to install in a few hours.

Link to the repo:
https://launchpad.net/~matthaeus123/+archive/ppa
Logged
matthaeus123
Newbie

Offline Offline

Posts: 12


View Profile
« Reply #34 on: March 24, 2009, 07:21:01 pm »

I just installed the packages and tested them out. And they work perfectly.

use these repos:
deb http://ppa.launchpad.net/matthaeus123/ppa/ubuntu jaunty main
or
deb http://ppa.launchpad.net/matthaeus123/ppa/ubuntu intrepid main

then:
sudo apt-get install libgupnp-1.0-dev libgssdp-1.0-dev libgupnp-igd

and then it is all setup correctly
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #35 on: March 24, 2009, 07:37:30 pm »

thanks matthaeus123...
aren't these versions depending on glib 2.18 ? I suppose jaunty has 2.18, but is intrepid too ?
Thanks!
Logged

KaKaRoTo
matthaeus123
Newbie

Offline Offline

Posts: 12


View Profile
« Reply #36 on: March 26, 2009, 01:49:31 am »

actually i set the dependencies for 2 of the packages at just "libglib2.0-dev", and for gupnp the dependency is set at 2.14, so it should be good for most newer builds.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #37 on: March 26, 2009, 06:23:05 pm »

Humm... well, if you look at the gupnp configure.ac file, it actually requires the version to be >= 2.18 so you might want to fix your control file to add the dep on >= 2.18!
Logged

KaKaRoTo
matthaeus123
Newbie

Offline Offline

Posts: 12


View Profile
« Reply #38 on: April 13, 2009, 09:23:44 pm »

Well, intrepid now uses glib 2.18, so these packages should work now. I rebuild the intrepid builds yesterday.
Logged
Montblanc
Super Power User
**
Offline Offline

Posts: 173



View Profile WWW
« Reply #39 on: April 15, 2009, 07:27:55 pm »

Quote from: "matthaeus123"
Well, intrepid now uses glib 2.18, so these packages should work now. I rebuild the intrepid builds yesterday.


I noticed the packages update notification, thank you!
Logged
matthaeus123
Newbie

Offline Offline

Posts: 12


View Profile
« Reply #40 on: April 30, 2009, 09:47:51 pm »

I made a released the newest versions of the packages in the PPA. The new gupnp-igd is currently in queue for being built. It should be built in a few hours hopefully.
Logged
Pages: 1 2 [3]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!