aMSN Forums
July 18, 2018, 07:07:14 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Webcam not working  (Read 57076 times)
almann12
Newbie

Offline Offline

Posts: 2


View Profile
« on: March 18, 2009, 10:09:20 pm »

hi i have to new beta for amsn but my webcam isnt working with only some of my contacts. it says connecting and then it cancels straight away. also my appears to them as white. it has worked before with them so i dont know whats wrong

Please help

Alex :?
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #1 on: March 19, 2009, 09:55:42 pm »

Hi,
welcome to the forums.
please take the time to search the forums as your issue has been answered before.
There is a bug in windows live messenger. your friends have updated their windows live messenger (WLM) version and there is a bug in WLM itself, since the bug comes from WLM and not from aMSN, there is nothing we can do about it! The problem will happen between two windows messengers too.
The reason for this bug is that you are both firewalled and so you can't connect to each other, which forces you to use a third party server to act as a relay, but WLM doesn't work with it correctly anymore, they should (hopefully) fix that in a future version.
In the meantime, you should just configure your router to forward ports to your PC (google 'how to forward ports' if you need help), aMSN would need you to forward the port range 6890 to 6900. Try again, then it should work.
Logged

KaKaRoTo
almann12
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #2 on: March 19, 2009, 10:04:07 pm »

yeah  sorry about that i looked a bit but their was nothing as about just some people not working.
anyway  i seemed to have fixed it myself messing around with the router.

thank you anyway

alex
Logged
mix9001
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #3 on: August 23, 2009, 12:13:37 pm »

Kakaroto, since this is a sticky, you might want to make the answers here as clear and thorough as possible, since people have still been posting on these webcam and port topics.

As kjir said more clearly in the thread "No more webcam support after I've changed my Netgear router":

Quote
"The answer, which has been given over and over, is that you need to have a port open on either side, so either you or your contact should have a TCP port open for direct connection. This is due to a bug in WLM."


This might be a useful distinguishing hint for some people (like me) who are used to their routers using SPI at the application layer to maintain sessions initiated locally on an outgoing port.  I assume that this behavior is insufficient with a direct connection in aMSN, requiring an explicit opening of the port on one end of the direct connect?
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #4 on: October 14, 2009, 02:03:29 am »

Yes, well, the answer should basically be :
look at your router, find the model number and then open google and search for "how to forward ports for <insert the router's model here>" and you'll find your answer.. the ports that need forwarding are (like I said) 6890 to 6900 (configurable in the preferences->connection tab)..
Then go to preferences->connection and click Test to make sure the ports were correctly forwarded.
(Thanks mix9001 for specifying the needed extra information)
Logged

KaKaRoTo
ENVY16
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #5 on: October 24, 2009, 05:15:06 pm »

Hi, I'm trying to open ports 6890-6900 for my router, however I'm being asked the service type of the application, what service type is aMSN? I have options TCP/UDP, TCP and UDP

Thanks
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #6 on: October 24, 2009, 05:17:34 pm »

The service type is TCP.

(Usually people will just use the option 'Both', but it's nice to know exactly).
Logged

KaKaRoTo
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!