aMSN Forums
November 12, 2018, 11:58:07 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Incorrect Chinese appearance.  (Read 6869 times)
Afante
Newbie

Offline Offline

Posts: 4


View Profile
« on: February 22, 2009, 10:24:20 am »

Hi!  Today, I just downloaded aMSN.  I found it better than KMess, which cannot display simplified Chinese with Japanese.

However, I found font effects of Chinese characters do not apply correctly.  The Chinese character cannot appear italic and in correct size, just as shown in accompanying pictures.





In fact, all the characters are Chinese, the only difference is that the incorrectly shown Characters are not available in Japanese.

I didn't find any option to correct it.  Did I miss them?  Or, could you please correct it?
Logged
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #1 on: February 22, 2009, 07:03:32 pm »

My guess is that you should install another font which contains all the correct glyphs for all Chinese characters. It looks like tk cannot find the correct glyphs in any fonts and decides to display them in non-italics.

EDIT: make sure you use tcl/tk 8.5 , as it fixes a lot of font-related issues
Logged
billiob
Administrator
Super Power User
*****
Offline Offline

Posts: 1352


View Profile
« Reply #2 on: February 22, 2009, 07:04:33 pm »

I think it's related to the font used. You can change it in the Appearance tab of the Preferences window.
Logged
Afante
Newbie

Offline Offline

Posts: 4


View Profile
« Reply #3 on: February 22, 2009, 08:03:08 pm »

Quote from: "billiob"
I think it's related to the font used. You can change it in the Appearance tab of the Preferences window.


It is often difficult to find a font that supports all languages.  gedit on my PC works pretty acceptable, so does OpenOffice.
Logged
billiob
Administrator
Super Power User
*****
Offline Offline

Posts: 1352


View Profile
« Reply #4 on: February 22, 2009, 08:59:38 pm »

Try to use the DejaVu font.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!