aMSN Forums
February 19, 2020, 03:41:37 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 [2]
  Print  
Author Topic: amsn can't find snack SOLVED  (Read 35304 times)
Jean_
Newbie

Offline Offline

Posts: 16


View Profile
« Reply #15 on: April 01, 2008, 05:25:27 pm »

Quote from: "trv"
well, those kind of scripts cause all sorts of problems... 90% of problems here are caused by those **** :/


Hey, I didn't write that script. Smiley

But you are right , it's so easy to mess things up.

Quote
drag n drop support is as simple as creating a folder under /home/user/.amsn/utils/tkdnd and placing 3 files you will download there


I was gonna ask, which files. But I don't have a map utils there. lol

Greets.
Logged
seenxu
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #16 on: April 30, 2008, 07:50:22 pm »

in ubuntu 8.04, make sure I had installed the libsnack2

sudo find / -iname "*snack*"

find following path
/usr/lib/tcltk/snack2.2

then make two symbolic link to the library.
sudo ln -s /usr/lib/snack2.2 /usr/lib/tcltk/snack2.2/
sudo ln -s /usr/local/lib/snack2.2 /usr/lib/tcltk/snack2.2/

right now, in your preference->others, you can select "use the snack library (tck internal)" checkbox. restart amsn.

make sure, the "set ::autopath" output is the following.

Code:

/usr/lib/tls1.50 utils utils/linux /home/seen/.amsn/plugins /usr/local/lib/tcl8.5 /usr/local/lib /usr/local/lib/tk8.5 /usr/local/lib/tk8.5/ttk


and it shall work now.  :twisted:
Logged
fitlad
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #17 on: August 10, 2008, 10:40:35 pm »

Quote from: "seenxu"
in ubuntu 8.04, make sure I had installed the libsnack2

sudo find / -iname "*snack*"

find following path
/usr/lib/tcltk/snack2.2

then make two symbolic link to the library.
sudo ln -s /usr/lib/snack2.2 /usr/lib/tcltk/snack2.2/
sudo ln -s /usr/local/lib/snack2.2 /usr/lib/tcltk/snack2.2/

right now, in your preference->others, you can select "use the snack library (tck internal)" checkbox. restart amsn.

make sure, the "set ::autopath" output is the following.

Code:

/usr/lib/tls1.50 utils utils/linux /home/seen/.amsn/plugins /usr/local/lib/tcl8.5 /usr/local/lib /usr/local/lib/tk8.5 /usr/local/lib/tk8.5/ttk


and it shall work now.  :twisted:


My linux box is running fedora core 9 and I've installed amsn 0.97. When I tried to setup my microphone, an error message was displayed stating that snack cannot be loaded. I made a symbolic link to the library however the error has not been resolved!!!

Code:
(amsn) 1 % set ::auto_path
utils utils/linux /home/fitlad/.amsn/plugins /usr/share/tcl8.5 /usr/lib/tcl8.5 /usr/lib/tk8.5 /usr/share/tk8.5 /usr/share/tk8.5/ttk /usr/share/tcl8.5/tcllib-1.10
(amsn) 2 % package require snack
can't find package snack


Code:
[root@Shell fitlad]# ln -s /usr/lib/snack2.2.10 /usr/lib/tcl8.5/snack2.2.10


Code:
(amsn) 3 % package require snack
couldn't load file "/usr/lib/tcl8.5/snack2.2.10/libsnack.so": /usr/lib/tcl8.5/snack2.2.10/libsnack.so: symbol _snd_pcm_mmap_hw_ptr, version ALSA_0.9 not defined in file libasound.so.2 with link time reference


Can anyone help me to load snack with my amsn please? I cannot figure out what is the root cause of the problem. Thanks
Logged
Phil
Administrator
Super Power User
*****
Offline Offline

Posts: 653


View Profile
« Reply #18 on: August 11, 2008, 08:22:23 pm »

You must recompile snack on your computer.
Logged

Phil

AMsn is great, and it will be greater :wink:
fitlad
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #19 on: August 11, 2008, 08:58:37 pm »

Quote from: "Phil"
You must recompile snack on your computer.


How can I recompile snack from source? I downloaded the original snack package but it contains neither make nor configure file to install this software! I don't know what I shall do!   :cry:
Logged
Phil
Administrator
Super Power User
*****
Offline Offline

Posts: 653


View Profile
« Reply #20 on: August 11, 2008, 09:18:10 pm »

./unix/configure --enable-alsa
You can specify some other options
Logged

Phil

AMsn is great, and it will be greater :wink:
fitlad
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #21 on: August 11, 2008, 09:28:57 pm »

Quote from: "Phil"
./unix/configure --enable-alsa
You can specify some other options


I followed your instruction but I got this error
Code:
[root@Shell fitlad]# cd /usr/lib/snack2.2.10
[root@Shell snack2.2.10]# ./unix/configure --enable-alsa
bash: ./unix/configure: No such file or directory


Please help me.
Logged
Phil
Administrator
Super Power User
*****
Offline Offline

Posts: 653


View Profile
« Reply #22 on: August 11, 2008, 09:32:29 pm »

No you must do that in the source directory of snack
Not in your binary tree
If you plan to install it in /usr/lib don't forget --prefix=/usr
Logged

Phil

AMsn is great, and it will be greater :wink:
fitlad
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #23 on: August 11, 2008, 09:37:09 pm »

Quote from: "Phil"
No you must do that in the source directory of snack
Not in your binary tree
If you plan to install it in /usr/lib don't forget --prefix=/usr


I tried to recompile snack in the source directory but it didn't work too!
Code:
[root@Shell snack2.2.10]# cd /home/fitlad/Download/snack2.2
[root@Shell snack2.2]# ./unix/configure --enable-alsa
bash: ./unix/configure: No such file or directory


What do I do?
Logged
Phil
Administrator
Super Power User
*****
Offline Offline

Posts: 653


View Profile
« Reply #24 on: August 11, 2008, 10:03:07 pm »

Are you sure that's a source package ?
Logged

Phil

AMsn is great, and it will be greater :wink:
fitlad
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #25 on: August 12, 2008, 12:01:53 am »

Quote from: "Phil"
Are you sure that's a source package ?


I believe I downloaded the wrong package; I got the linux binary package instead of the source package
http://www.speech.kth.se/snack/dist/snack2.2.10-linux.tar.gz
So, I visited snack web page and downloaded the proper source code
http://www.speech.kth.se/snack/dist/snack2.2.10.tar.gz

then I went to terminal and typed the following codes:
Code:
[root@Shell fitlad]# cd /home/fitlad/Download/snack2.2.10/unix
[root@Shell unix]# ./configure --enable-alsa --with-tcl=/usr/lib --with-tk=/usr/lib
checking for Tcl configuration... configure: error: /usr/lib directory doesn't contain tclConfig.sh


I searched my linux box for "tclConfig.sh" but I couldn't find it. What shall I do?
Logged
trv
Super Power User
**
Offline Offline

Posts: 154


View Profile WWW
« Reply #26 on: August 12, 2008, 09:47:24 am »

do you have tcl and tk installed?

you can use --with-tcl=/usr/lib/tcl8.5 and --with-tk=/usr/lib/tk8.5   (your tclConfig.sh will be inside tcl8.5 directory if you have tcl8.5 installed)
Logged
Phil
Administrator
Super Power User
*****
Offline Offline

Posts: 653


View Profile
« Reply #27 on: August 12, 2008, 03:50:33 pm »

You must install tcl-devel and tk-devel packages.
Then, maybe you will have to use trv trick (can't remember).
Logged

Phil

AMsn is great, and it will be greater :wink:
trv
Super Power User
**
Offline Offline

Posts: 154


View Profile WWW
« Reply #28 on: August 12, 2008, 06:21:17 pm »

The truth is that you must install tcl8.5-dev and tk8.5-dev packages. Then you have to use the trick i mentioned earlier.

The tcl-dev package gives tou a tclConfig.sh file in /usr/lib BUT it installs tcl8.4-dev and it's that file there.. You don't want that. Just install tcl8.5-dev and adjust the configure script like i said.
Logged
Phil
Administrator
Super Power User
*****
Offline Offline

Posts: 653


View Profile
« Reply #29 on: August 12, 2008, 10:05:21 pm »

I was giving him the packages name for Fedora 9 Wink
Logged

Phil

AMsn is great, and it will be greater :wink:
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!