aMSN Forums
April 17, 2014, 10:48:48 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 ... 32 33 [34] 35 36 ... 46
  Print  
Author Topic: Audio/Video conversation  (Read 398251 times)
dpetka2001
Newbie

Offline Offline

Posts: 7


View Profile
« Reply #495 on: December 24, 2008, 08:53:57 pm »

well i tried to make a call with a friend of mine who uses windows live messenger and though it shows that the connection is established there is no audio from either sides...how could i tell what is wrong? any help would be appreciated...
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #496 on: December 24, 2008, 10:45:38 pm »

Hi dpetka2001, it looks fine to me. Probe shows that you have alsa installed and that it works, and the assistant shows farsight working correctly for you.. the level_IN window is just temporary (just like it says in the text box). If you wait long enough for farsight to finish getting tested, then you can close it...
During your call, make sure the volume is set correctly and that your microphone is working.. try talking in the microphone and you should see the bar in the level_IN window move.. when the other person is talking to you, the level_OUT bar should move too.
We'll soon add the possibility to configure which microphone to use (you seem to have two inputs in alsa), maybe that's your problem...
In the meantime, you can set it by typing this in amsn's console :
Code:
::Farsight::Config -source-device "hw:0,2"

(or "hw:0,0")
hope that helps...
Logged

KaKaRoTo
dpetka2001
Newbie

Offline Offline

Posts: 7


View Profile
« Reply #497 on: December 25, 2008, 12:37:24 am »

excuse me but i forgot to paste the error amsn exited after the unsuccessful voice call i tried to make...here it is
Code:
invalid command name "::MSNSIP::SIPConnection11"
    while executing
"$sip Bye $callid"
    (procedure "::MSNSIP::HangUp" line 3)
    invoked from within
"::MSNSIP::HangUp $sip $callid"
    (procedure "::amsn::HangupSIPCall" line 6)
    invoked from within
"::amsn::HangupSIPCall kiki-xxx@sad-amsn-user.com ::MSNSIP::SIPConnection11 0346b276c46d27bc76898b5e0b84a549"
    invoked from within
".container_2.msg_2.f.bottom.left.buttons.inner.call invoke"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list $w invoke]"
    (procedure "tk::ButtonUp" line 22)
    invoked from within
"tk::ButtonUp .container_2.msg_2.f.bottom.left.buttons.inner.call"
    (command bound to event)
as far the level_IN window is concerned i left for about half an hour without doing anything and nothing happened...still it was stuck at 1% as provided in the picture in my previous post...so i don't really know where it stucks...will try tomorrow when i will be able to talk to my friend the command you suggested for the amsn console...thanks in advance...
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #498 on: December 25, 2008, 04:38:16 am »

Hi,
that error can happen if the call got canceled too fast or something like that.. it will be fixed before we release 0.98, just ignore it, and retry...
About the window being stuck at 1%, it's just because when you login, it will test if farsight is correctly configured, and when it is, you'll see that window, then once it finds farsight working, it will close everything, but it won't close that window.. of course it will be stuck since it gets no more input from your microphone because it closed it.. so just forget about it and close it... during the call, as long as the call is working, the level_IN should be there and should change with the input of your microphone..
anyways, as I said, don't pay attention to that window.
Logged

KaKaRoTo
dpetka2001
Newbie

Offline Offline

Posts: 7


View Profile
« Reply #499 on: December 26, 2008, 06:11:00 pm »

well i tried again to talk to my friend without success...i start the call,the other end answers but after that there is no sound...also when i try to talk the level_IN flunctuates between 1% and 2%...but after that a windows pops up saying "Your audio call has ended"...take a look at the picture...after that the level_IN stays stuck at 1%...at no point however is there a sound during the communication...i tried with both "hw:0,2" and "hw:0,0" without success...with "hw:0,0" it doesn't even start the call and shows the other end always busy...with "hw:0,2" happens what i've already told you...
Logged
dpetka2001
Newbie

Offline Offline

Posts: 7


View Profile
« Reply #500 on: December 29, 2008, 11:15:05 pm »

is this normal what i described in my previous post? to pop up an unknown conversation window saying my conversation has ended like in the picture i attached?
Logged
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #501 on: December 29, 2008, 11:19:38 pm »

Sorry, I cannot see your picture...

Have you tried raising the volume for your microphone? Make sure it's not too low
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #502 on: December 29, 2008, 11:38:36 pm »

dpetka2001: yes, that unknown conversation window is a bug, but it shouldn't affect your call.. the reason why it seems to end the call automatically is probably because it couldn't connect... could you paste here the output of the status log (Ctrl-S) ? That would be helpful!
also, what type of network do you have ? what router ? what configuration? do you have UDP blocked ?
Logged

KaKaRoTo
zyazhou
Newbie

Offline Offline

Posts: 11


View Profile
« Reply #503 on: January 20, 2009, 10:07:54 am »

Anyone tried the lastest MSN client v2009. I tried, but the audio call failed.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #504 on: January 21, 2009, 01:47:50 am »

i haven't, but I will as soon as I get back home (currently in Australia http://linux.conf.au )
Logged

KaKaRoTo
zyazhou
Newbie

Offline Offline

Posts: 11


View Profile
« Reply #505 on: January 21, 2009, 05:20:59 pm »

MSN v2009 uses MSNP18, and it seems the protocol for audio has changed a lot. I'm not sure, just caught some packets with wireshark.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #506 on: January 21, 2009, 11:54:33 pm »

yeah.. it did change.. but I don't know to what extent.. i'll look at it next week.. all I know is that when I tried to send an audio call to someone using WLM2009, he received the message :
Quote
KaKaRoTo is using a version of Messenger that does not have improvements to support a Computer Call.  Please ask your contact to upgrade to the latest version of Messenger and try your call again


so... I'll have to see if they changed the whole damn thing, or if it's just some minor changes that can be fixed...
Logged

KaKaRoTo
peter
Power user
*
Offline Offline

Posts: 68


View Profile
« Reply #507 on: January 26, 2009, 03:02:33 am »

Hi there.

Even with the latest svn 10880 I'm having the same error regarding farsight config.

Well I do have /usr/lib/gstreamer-0.10 and /usr/lib/gstreamer-0.8.

I have openssl 0.9.8 ( libssl.so.0.9.7)


Quote


compile time options summary
============================

X11 : yes
Tcl : 8.4
TK : 8.4
DEBUG : no
STATIC : no
FARSIGHT : yes
LIBV4L : no

[pedro@localhost msnCopia]$ make
CC utils/farsight/src/tcl_farsight.o
LD utils/farsight/src/tcl_farsight.so
cp utils/farsight/src/tcl_farsight.so utils/farsight/tcl_farsight.so
[pedro@localhost msnCopia]$ ./amsn
Farsight : Preparing

(<unknown>:6323): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstice.so': libssl.so.0.9.7: cannot open shared object file: No such file or directory

(<unknown>:6323): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstvolume.so': /usr/lib/gstreamer-0.10/libgstvolume.so: undefined symbol: oil_function_class_ptr_scalarmultiply_f64_ns

(<unknown>:6316): GLib-GObject-CRITICAL **: g_type_class_unref: assertion `g_class != NULL' failed
Farsight Prepare error : Error while creating new session (1): Could not create GstRtpBin  



Quote

gst-inspect-0.10 nice

(gst-inspect-0.10:4653): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstice.so': libssl.so.0.9.7: cannot open shared object file: No such file or directory

(gst-inspect-0.10:4653): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstvolume.so': /usr/lib/gstreamer-0.10/libgstvolume.so: undefined symbol: oil_function_class_ptr_scalarmultiply_f64_ns
Plugin Details:
  Name:                 nice
  Description:          Interactive UDP connectivity establishment
  Filename:             /usr/lib/gstreamer-0.10/libgstnice.so
  Version:              0.0.4
  License:              LGPL
  Source module:        nice
  Binary package:       nice
  Origin URL:           http://telepathy.freedesktop.org/wiki/

  nicesink: ICE sink
  nicesrc: ICE source

  2 features:
  +-- 2 elements



Quote

gst-inspect-0.10 gstrtpbin

(gst-inspect-0.10:4661): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstice.so': libssl.so.0.9.7: cannot open shared object file: No such file or directory

(gst-inspect-0.10:4661): GStreamer-WARNING **: Failed to load plugin '/usr/lib/gstreamer-0.10/libgstvolume.so': /usr/lib/gstreamer-0.10/libgstvolume.so: undefined symbol: oil_function_class_ptr_scalarmultiply_f64_ns
No such element or plugin 'gstrtpbin'



gstreamer-tools 0.10.21 and 0.8.12

gstreamer0.10-farsight 0.10.0.1


Sorry for posting in the other forum  :oops:
Logged
peter
Power user
*
Offline Offline

Posts: 68


View Profile
« Reply #508 on: January 28, 2009, 12:29:23 am »

Well I have to say that farsight is now working... (compile time... Tongue ), apart from creating source (null), but that's because right now I don't have permission to write to dsp :?. Nevertheless I can't use another account as it gets stuck after all that local codecs (...).

I still have to try amsn<->wlm call .

Svn 10885

Quote

[23:20:56] Farsight : Preparing
[23:20:56] Farsight : Preparing
[23:20:56] Farsight debug : CODECS ARE READY
[23:20:56] Farsight debug : CODECS ARE READY
[23:20:56] Farsight debug : Creating source : (null)  --- (null) -- (null)
[23:20:56] Farsight debug : Creating source : (null)  --- (null) -- (null)
[23:20:56] Farsight debug : Using source gconfaudiosrc
[23:20:56] Farsight debug : Using source gconfaudiosrc
[23:20:56] Farsight debug : stun ip : 64.14.48.28 : 3478
[23:20:56] Farsight debug : stun ip : 64.14.48.28 : 3478
[23:20:56] logging in, destroying loginscreen : loggingIn
[23:20:57] Farsight debug : CANDIDATES ARE PREPARED
[23:20:57] Farsight debug : CANDIDATES ARE PREPARED
[23:20:57] Farsight : Farsight is now prepared!
local codecs : {SIREN 111 16000 bitrate=16000} {PCMA 8 8000} {PCMU 0 8000} {telephone-event 98 8000 0-16}
local candidates : {DWLgGz+tLMCoUmYk/Hl49FVzduNeOlzHr612Pqv+2c4= 1 Sk/2w6vT025FBSwb58wUvw== UDP 0.83 192.168.1.64 32805} {tpXgAXaDvOIbNGZzVmdngXHDsP5L8F7sH9eN9U2pEz4= 1 6U0qqWWRSPQdph21177ndg== UDP 0.55 85.241.142.80 50472} {DWLgGz+tLMCoUmYk/Hl49FVzduNeOlzHr612Pqv+2c4= 2 Sk/2w6vT025FBSwb58wUvw== UDP 0.83 192.168.1.64 32806} {tpXgAXaDvOIbNGZzVmdngXHDsP5L8F7sH9eN9U2pEz4= 2 6U0qqWWRSPQdph21177ndg== UDP 0.55 85.241.142.80 50473}
[23:20:57] Farsight : Farsight is now prepared!
local codecs : {SIREN 111 16000 bitrate=16000} {PCMA 8 8000} {PCMU 0 8000} {telephone-event 98 8000 0-16}
local candidates : {DWLgGz+tLMCoUmYk/Hl49FVzduNeOlzHr612Pqv+2c4= 1 Sk/2w6vT025FBSwb58wUvw== UDP 0.83 192.168.1.64 32805} {tpXgAXaDvOIbNGZzVmdngXHDsP5L8F7sH9eN9U2pEz4= 1 6U0qqWWRSPQdph21177ndg== UDP 0.55 85.241.142.80 50472} {DWLgGz+tLMCoUmYk/Hl49FVzduNeOlzHr612Pqv+2c4= 2 Sk/2w6vT025FBSwb58wUvw== UDP 0.83 192.168.1.64 32806} {tpXgAXaDvOIbNGZzVmdngXHDsP5L8F7sH9eN9U2pEz4= 2 6U0qqWWRSPQdph21177ndg== UDP 0.55 MyIP 50473}
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #509 on: January 28, 2009, 01:40:10 am »

ok cool, well it works.. that 'creating source (null)' is just a debug that shows if you manually configured farsight to use a specific device or pipeline (like read from a file instead of using a microphone, etc...).. there's no UI for this, so you can't specify it yet, so the creating source will always show (null).. and since it's NULL, it will automatically try to detect and use any audio device it finds... also note that the latest SVN version *should* (not really tested) work even if you have no microphone, it will just become a receive only session..
Logged

KaKaRoTo
Pages: 1 ... 32 33 [34] 35 36 ... 46
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!