aMSN Forums
April 23, 2018, 02:41:44 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 ... 4 5 [6]
  Print  
Author Topic: Problems typing foreign languages?(was Arabic Fonts Problem)  (Read 165054 times)
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #75 on: June 29, 2009, 01:59:28 am »

Hi,

I ended up removing scim and using uim instead. Works like a charm.

I could not solve the freezing keyboard issue with scim, and this was the main reason why I removed it and went for uim. It's way less buggy anyway, and you don't need the XMODIFIERS trick!
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #76 on: June 29, 2009, 02:08:53 am »

humm.. ok thanks vivia!
So, we can basically summarize this whole thread with "use UIM instead of SCIM" ? wow.. what a waste of text ! :p
Logged

KaKaRoTo
berdux
Newbie

Offline Offline

Posts: 4


View Profile
« Reply #77 on: July 04, 2009, 09:12:18 am »

hello!

so i uninstalled SCIM and installed UIM. the problem with the freezing keyboard has gone. i can write japanese now on most windows, except amsn and skype (maybe others as well, haven't tested it yet). i should search this more before posting but i really do not have the time now (again :S). just reporting my status Tongue
i will find some time tomorrow and find the solution to this, i think i saw it someplace when i was searching for my first problem Smiley

ありがとうございます。



(ps. by the way, i just noticed, vivia are you greek?)
Logged
afv
Newbie

Offline Offline

Posts: 31


View Profile
« Reply #78 on: July 04, 2009, 04:04:36 pm »

I just uninstalled SCIM and installed UIM and seems to me (maybe I didn't test enough) that the problem with the accented letters (áéíóú…) appearing with a delay is gone! Thanks!! Cheesy

(It also seems to be quicker when pasting some text (sometimes the text pasted took some seconds to appear, before this) Smiley)
Logged
fhoffmann
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #79 on: July 31, 2009, 08:57:53 am »

I was having the exact problem as berdux-- losing keyboard functionality when keeping an IM window open and the other person would enter or leave conversation. While replacing SCIM with UIM does indeed avoid this problem now I am unable to type Japanese on aMSN, also like berdux... When I'm in an aMSN window the keyboard shortcuts I have assigned to switch between languages seem to be ignored by UIM.. If I manually select the input type via the UIM toolbar I still get my default input, which is english. Am I overlooking a simple setting?
Logged
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #80 on: July 31, 2009, 06:50:54 pm »

berdux: ότι θα βοηθούσα Έλληνα να γράφει Ιαπωνικά στο aMSN, δε θα το φανταζόμουν!! Smiley

@berdux, fhoffmann: Which distribution are you using? Can you try typing Japanese in xterm? If not, maybe the problem is that the uim-xim bridge is not installed. Unfortunately I cannot remember by heart how to install it and I cannot find the nice howto that I had. You could at least try running uim-xim manually before starting aMSN.
Logged
fhoffmann
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #81 on: July 31, 2009, 10:02:17 pm »

vivia -
I am using Ubuntu, Jaunty... I discovered I had a few references to SCIM left over:
im-switch -c then choose one of the UIM options
now UIM recognizes my keyboard shortcuts and Japanese and Korean text input work with aMSN. The only problem I have is-- as I type, instead of showing the hiragana or katakana I see boxes then when I press enter it shows the correct font... I suspect it is just that... an issue with a font. I will post back here when I figure what I'm missing incase anyone else has this problem. It would be great if we could figure out all these little hangs people are having when using multi-lingual setups with aMSN and throw it to the wiki... It was a bit annoying to read through 4 pages of posts then see that the workaround is to use some other software...  :lol:
Logged
Stian1979
Newbie

Offline Offline

Posts: 10


View Profile
« Reply #82 on: August 16, 2009, 09:03:26 am »

I tryed scim and refuse to work on amsn and openoffice.
uim don't seam to have mps traditional chinese.
I'm back to fighting with scim
Logged
setzer
Newbie

Offline Offline

Posts: 21


View Profile WWW
« Reply #83 on: October 05, 2009, 10:09:43 pm »

Stian1979 - Well, I suppose that u followed the entire topic and is still having problems. I's been some time since I last read this topic so I don't remember everything that it says. However, I suggest you to try using iBus as your default IM. I recently swtched to iBus and didn't find any problems with amsn. In fact, I didn't configure anything to make it work, except for exporting XMODIFIERS, GTK_IM_MODULE, QT_IM_MODULE and TK_IM_MODULE. You should give it a shot...
Logged
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #84 on: January 02, 2010, 06:20:25 pm »

Problem with accented characters getting misplace is fixed: http://www.amsn-project.net/forums/index.php/topic,7610.0.html
Logged
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #85 on: July 15, 2010, 05:50:48 pm »

I just found two workarounds to the problem with scim input freezing: https://bugs.launchpad.net/ubuntu/+source/scim/+bug/66104
Logged
Pages: 1 ... 4 5 [6]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!