aMSN Forums
September 02, 2014, 03:00:00 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 2 3 [4] 5 6
  Print  
Author Topic: Problems typing foreign languages?(was Arabic Fonts Problem)  (Read 123872 times)
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #45 on: September 08, 2007, 08:47:50 pm »

Hello here, I don't really read all your posts because I understand nothing about all that, and I never use it :p
But I think that you've been able to gather some very helpful information in here, and I think it might be a good idea to put this as a tutorial in the wiki of aMSN.
If one of you is willing to help and would like to write that in the wiki, please tell me and I'll create an account for you (send me the username/password you'd want to have by PM (you can change the password after)).

Thank you in advance Smiley
Logged

KaKaRoTo
faneca
Newbie

Offline Offline

Posts: 16


View Profile
« Reply #46 on: September 08, 2007, 10:29:04 pm »

Well, I can do it, but I'll start working on a new job in two days, and I'll be very busy from then. You'll have to be patient until I finally get the job done. And, in connection with the subject we are talking about in the last messages on this tread, I must say a few thing:

1.- There's a lot of people who have been working with scim enabled tk apps without problems at all, in several different Linux distributions. At least that's what it seems, and actually I thought I was suffering a "marginal" problem caused by my very particular setup (made almost completely by hand), so no one should have interest on the solution. But now that Skippy has appeared with the same problem, on a different distribution than me, it made me remember there was someone else in the spanish section of the forum with this issue, so I agree with you in that this is worth a troubleshooting section on the wiki/FAQ.

2.- This leads me to the second point. I solved the problem on my machine, but I tried so much different things that now I just can't recall which one did the trick. What makes it even worse, apart from my very bad memory Smiley, is that things started to go well from one day to the other, giving me the impression that it wasn't me who solved it. This would have made sense if I only had updated some of my installed packages, but none of the related ones have been touched. And until now, I couldn't reproduce the previous buggy behavior. Nor have we solved Skippy problem yet.

What I really want to say with all this, is that IMHO we should first get to the root of the problem, fix it for Skippy as we work on it, and only then, write about it. I hope it won't take too long. We'll see.

Anyway, the workaround permits users to write properly, using their own keyboard layout, when they are not interested in using "exotic" input methods while at amsn or other tk apps, so maybe it already deserves a small answer in the FAQ. This could be enough (well written, of course):
Quote

Problems with scim/linux/dead keys?

Launch amsn this way from a terminal:
Code:
XMODIFIERS='' amsn &
It will deactivate scim for the app, but at least you'll be able to write deadkey+letter combinations. We are working on this issue.

Maybe you'll want to add this yourself right now ;-) Let me know what you think.

Regards,

faneca
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #47 on: September 09, 2007, 07:03:55 am »

ok, thanks faneca. As I said, I didn't read all your posts since this is beyond me, I had a friend asking me about scim the  other day, and he tried amsn and scim and it didn't work, I tried it myself on his machine and it didn't work, so I thought that scim just doesn't work with Tk unless you use some trick. Which is why I asked for the solution (the 'trick') to be written in the wiki. I thought it was as simple as the XMODIFIERS thing you posted above (but to enable scim, not disable it). I also thought your post helped Skippy solve the problem...
When I get time, I'll try and read this post, or ask someone who understand scim to read it and draw conclusions and write them in the wiki.
Thanks for clarifying things.
Logged

KaKaRoTo
Skippy le Grand Gourou
Newbie

Offline Offline

Posts: 15


View Profile
« Reply #48 on: September 09, 2007, 09:14:57 pm »

Ok, it works ! Cheesy
Many thanks, faneca. After some tests, I figured out that the point was to add my unicode locale to the first line of /etc/scim/global. So in my case :
Code:
/SupportedUnicodeLocales = fr_FR.UTF-8,en_US.UTF-8

instead of just en_US.UTF-8. Then I am able to use dead-keys, and to switch scim methods ! Cheesy

BTW, you were right, it seems that the 'scim' argument in XMODIFIERS has to be in capital letters.

So kakaroto, here are the steps to follow, if you want to adapt them for a tutorial :


Quote from: "[b
How to make SCIM to work within aMSN[/b]"]
1) Install tcl/tk >= 8.4.13, amsn >= 0.96, scim, and scim's language-specific packages (for instance, scim-pinyin for Chinese, scim-anthy for Japanese or scim-hangul for Korean).

2) If you have only one user or you want to enable SCIM for a specific user, create or modify the ~/.xinitrc file and add these lines at the beginning :
Code:
# SCIM
export XMODIFIERS='@im=SCIM'
export GTK_IM_MODULE="scim"
export XIM_PROGRAM="scim -d"
export QT_IM_MODULE="scim"
scim -d
If you want SCIM to be enabled for all users, you can put these lines in /etc/profile or create an initialization script.

3) Be sure to have your current locale in the first line of /etc/scim/global. For instance, if you use fr_FR.UTF-8 (you can know it by typing locale in a terminal), this line should look like :
Code:
/SupportedUnicodeLocales = fr_FR.UTF-8,en_US.UTF-8
If this is not the case, edit it (as root).

4) Restart your X server or reboot.

5) Enjoy ! Cheesy
Logged
faneca
Newbie

Offline Offline

Posts: 16


View Profile
« Reply #49 on: September 10, 2007, 12:05:37 am »

Quote from: "Skippy le Grand Gourou"
Ok, it works ! Cheesy
Many thanks, faneca.
You're welcome! Your feedback has been important to me: after all, I wanted to know what the hell I had done to get it working, I was becoming crazy.
Donc, merci à vous aussi, vous m'avez aidé beaucoup Wink.

Ok, we are ready for the wiki, Kakaroto. I think the previous Skippy post is perfect, he explained all the steps very well. So IMHO there's no need to open accounts for me/us, you can do it yourself; but you can count on me anyway if you want Wink

BTW I'll try and test restoring that /etc/scim/global line this week, to see if I can reproduce the problem and confirm that was the cause -- even if it seems pretty straightforward to me now.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #50 on: September 10, 2007, 05:07:26 am »

ok thanks guys, faneca and Skippy, this will probably be very helpful to others. I'll make it into the wiki!
Glad it works for both of you.
Skippy, the post you gave is also a very good tutorial, I don't think there's a need to modify it! Smiley
Bonne soiree! Smiley
Logged

KaKaRoTo
Skippy le Grand Gourou
Newbie

Offline Offline

Posts: 15


View Profile
« Reply #51 on: September 10, 2007, 02:12:48 pm »

Thanks for your comments. One thing that might be added is that there is also a "global" file in ~/.scim. Faneca, I think you'd better try with this one if you want, in order to be able to say if it's customizable for several users. Wink
Logged
faneca
Newbie

Offline Offline

Posts: 16


View Profile
« Reply #52 on: September 10, 2007, 09:06:07 pm »

Quote from: "Skippy le Grand Gourou"
One thing that might be added is that there is also a "global" file in ~/.scim. Faneca, I think you'd better try with this one if you want, in order to be able to say if it's customizable for several users. Wink

You read my mind Wink. Just give me a couple of days, right now I'm really busy and I'd like to avoid the inconvenience of closing my session. It won't go beyond week end, though.

Regards
Logged
faneca
Newbie

Offline Offline

Posts: 16


View Profile
« Reply #53 on: September 22, 2007, 08:02:14 pm »

I'm sorry it took me so long to test that, I've been really busy the last two weeks. Thanks for your patience.

Anyway, I have good news. I confirmed in my own system those were both the problem and the solution. And it works no matter if the "/SupportedUnicodeLocales = ..., your_locale, ..." line goes in /etc/scim/global or in ~/.scim/global, as long as it is in one of them (the latter overriding the settings of the former, if they conflict). So even if a user does not have root access, he/she can set scim working properly. It also means each user could have a different configuration.

Add this to the FAQ properly, Kakaroto. And keep the good work!

Regards.
Logged
billiob
Administrator
Super Power User
*****
Offline Offline

Posts: 1352


View Profile
« Reply #54 on: September 23, 2007, 05:08:31 pm »

You can edit the FAQ, it's a wiki !
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #55 on: September 24, 2007, 11:52:28 am »

thanks for the answer, I will do it when I get time...
and billiob, no, it's a wiki, but we've resitricted access to it. those who want to help have to request us to create a user/pass for them because we were fed up of all the spam we were getting...
Logged

KaKaRoTo
Skippy le Grand Gourou
Newbie

Offline Offline

Posts: 15


View Profile
« Reply #56 on: November 04, 2007, 05:14:31 pm »

Mmmh... There might be another issue. On my girlfriend's computer which is under Ubuntu (Edgy), this procedure does not seem to be enough, I still can't get dead keys to work without exporting null into XMODIFIERS. However, .xinitrc does not seem to be taken into account, and I can't figure out (for the moment) how scim is launched. As I have no continuous access to this computer, it may take some time for me to understand what's wrong, so if another ubuntu user read these lines... Wink

Edit: Oh, yes : and XIM_PROGRAM is not set. I have to check which scim packages are installed, but I have to go for now.
Logged
faneca
Newbie

Offline Offline

Posts: 16


View Profile
« Reply #57 on: November 04, 2007, 10:16:40 pm »

Hi, Skippy, comment ça va? Well, Edgy is already a little outdated (I've upgraded from feisty to gutsy a few weeks ago and scim still works), but I hope I can help you ^_~. The problem is I don't know which Xorg/Xfree86 version is your girlfriend's computer running; mine was always Xorg 7.x (and I've never used .xinitrc, FYI). I guess if you have a /etc/X11/Xsession.d/ directory, you're lucky. Create there a file (I did it myself some time ago) with the following contents, and name it, for instance, 74custom-scim_startup:

Code:

export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
export XIM_PROGRAM="scim -d"
export QT_IM_MODULE="scim"


That's for the environment vars. It won't harm to have them set system-wide. You can also launch the scim daemon there, I think, but I'd better put it on the user's session startup scripts.

The issue then is you'll have to find the right startup script to launch the scim daemon. If she's using ubuntu I suppose her desktop is a gnome; ~/.gnomerc may (or may not) be a valid place for it. A good alternative could be simply using the gnome session config tool (In the gnome's main menu, go to "System | Preferences | Sessions", then click on "Add" and put the command "scim -d" there) to configure that. With gutsy, I think my startup files are now *.desktop stuff placed into ~/.config/autostart (you know, freedesktop thing).

I'm not sure if I'm really answering your questions, and I was a little messy, so please give me some feedback. Regards.
Logged
Skippy le Grand Gourou
Newbie

Offline Offline

Posts: 15


View Profile
« Reply #58 on: November 05, 2007, 10:10:23 pm »

Hi faneca. You are right in all your assumptions. Smiley And by the way, I don't really want to upgrade from edgy to gutsy, because I played with so many files that I would not be able to repair anything in a few hours (which would already be to long for her...) in case of problems.

After posting yesterday, I had a look on which packages were installed, and figured out that it was a mess... I removed all uim related packages, tried to play with im-switch which was installed, but then removed it also to restart from a clean base. Now there are only scim related packages.

Unfortunately it was late and I don't remember what I did after that for now... I wanted to kill the launch of scim in order to start from nothing then apply the good ol'method, however scim restarted all the time... Then I left. I'll try again next week-end or the one after.

Thanks for your support. Wink
Logged
Splatt
Newbie

Offline Offline

Posts: 2


View Profile WWW
« Reply #59 on: November 19, 2007, 05:38:13 pm »

For me i only had problem with some chars. It worked for me to set it to iso-8859-1. Even if i should use UTF-8 (the one that's supposed to be used (with the chars))
Logged
Pages: 1 2 3 [4] 5 6
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!