aMSN Forums
October 22, 2018, 12:21:24 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 [2] 3 4 ... 6
  Print  
Author Topic: Problems typing foreign languages?(was Arabic Fonts Problem)  (Read 170179 times)
gesteur
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #15 on: September 22, 2006, 08:16:13 pm »

Hi have the same problem, i cannot write arabic or armenian fonts, I'm using  amsn-0.96_rc1 on gentoo
I added these 2 languages in the "control center" ->"keyboard layout"
if i write something in kwrite or firefox i can see these utf-8 characters without problems....only in msn i wont see them.
if i write armenian or arabic in kwrite and then copy & paste it to the amsn chat box...it displays it, but it's a bit unconfortable to copy and paste everytime, lol.
I also tried to change the encodings in amsn preferences.....

could someone help me?
Logged
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #16 on: September 23, 2006, 11:54:29 am »

Look for help on http://tcl.tk - it depends on them, not us, sorry...
Logged
gesteur
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #17 on: October 06, 2006, 03:02:39 pm »

Quote from: "vivia"
Look for help on http://tcl.tk - it depends on them, not us, sorry...


Under Suse I can write in armenian....but under gentoo not. It wont let me write the characters...
could it depend on the tcl/tk version?
Logged
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #18 on: October 06, 2006, 03:48:39 pm »

Well, there are two possible causes (that we can think of now) : One was with scim, so make sure you use tcl/tk 8.4.13 or later. Another one was with xorg, a user got it right after upgrading from ubuntu dapper to edgy, and it got fixed after a xorg upgrade. Good luck anyway........
Logged
gesteur
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #19 on: October 06, 2006, 03:56:07 pm »

I've installed tcl/tk 8.4.13 now, I'm using xorg 7.1 but the window chat wont let me type armenian characters....



the strange thing is that with suse 9.1 (XFree, tcl/tk 8.4.6) i could write without problems in amsn.
and there the software is surely older....
Logged
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #20 on: October 06, 2006, 11:05:40 pm »

Smiley The problem didn't exist on Dapper but it did on Edgy (which is a later version). Unfortunately I cannot help you any further, ask the tcl/tk team for help (They are always active and helpful on irc.freenode.net #tcl )
Logged
gesteur
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #21 on: October 07, 2006, 11:27:01 am »

efxaristò vivia for the help Smiley
Logged
gesteur
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #22 on: October 09, 2006, 10:40:56 pm »

the guys at #tcl helped me to solve the problem.
So, my problem was that the system encoding was set to iso-blabla the western european code.
First I had to change the system encoding to UTF-8.
Then I recompiled glibc and tcl/tk with unicode USE flag activated (do not know if it is necessary).




After this I can write armenian in aMSN.

to check which encoding TCL/TK uses tipe in the console
Code:
$wish

this opens a window
then type in the console

Code:
% encoding system


if it is UTF-8
try this command
Code:
% pack [text .t]


and now try to type in the opened windows with the language u want, the correct characters should appear.

recall: the system encoding which wish returns must be UTF-8.
Of course the aMsn preferences->appearance-> encoding must also be set to UTF-8.


NB: to use KDE, Firefox, Skype, KWrite, etc etc I did not have to change the system encoding to UTF-8, KDE did already the conversions.
somehow tcl/tk used the system encoding...and amsn uses tcl/tk...


cheers hov
Logged
Oet
Newbie

Offline Offline

Posts: 8


View Profile
« Reply #23 on: November 30, 2006, 12:04:26 am »

Well, this doesn't solve my problems.

I'm typing in dutch, using chars like é and á en ë and so on.
trying to type those chars in aMSN doesn't work and gets me some strange \ue04 or so thing.
Tried that pack [text .t] thing on wish, and i can type the é chars and so just fine, so i'm guessing it's not tcl/tk that is the cause of this problem.
Also never had this with the 0.95 release..

any ideas? (using UTF-8 on aMSN and iso8859-1 on system)

Edit: Ok, after setting the same coding on amsn as found in wish using the encoding system cmd, it's working again!
Logged
chy1013m1
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #24 on: December 03, 2006, 08:02:56 am »

not too sure what happened.. I installed xgl , then revert back to just Xorg+Gnome, now my previously working SCIM+aMSN doesn't work anymore. I tried to recompile tcl/tk 8.5, aMSN 0.96, none of which worked. All I can think now is that Xorg-x-server 1.1.1 has a bug in it or something.

any thoughts?

I also switched to OXIM just to see what'd happen, but same for OXIM..sigh..
other applications work fine with either SCIM/OXIM.
Logged
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #25 on: December 05, 2006, 02:33:33 pm »

there *was* a bug in some version of xorg...
Logged
nesh87
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #26 on: March 27, 2007, 07:41:29 am »

hey guys sorry for the bump, but i was just wondering if there is a solution for this yet? i have installed the Arabic locale but still the letters are backwards..

i looked at tcl's site, couldnt find anything..?

thanks
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #27 on: March 27, 2007, 03:12:07 pm »

Hi,
afaik, the solution was found and you should set your encoding to utf-8, did you try that ?
Logged

KaKaRoTo
nesh87
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #28 on: March 29, 2007, 09:52:26 am »

yup i tried that, my system encoding is UTF-8 so is my Amsn encoding...i think i have tried everything that might solve the problem with no luck
Logged
vega
Newbie

Offline Offline

Posts: 1


View Profile
« Reply #29 on: June 18, 2007, 07:39:35 pm »

Hello,

Maybe the problem is not from the encoding.

if you choose encoding:cp1252, and any font that supports arabic, then it will work but not correctly.
what I mean is that after choosing the encoding cp1252, and any font that supports arabic language then
I can see the arabic fonts but in reverse order after typing it, but while I'm typing I can't see it.

I have compared aMSN with GAIM, GAIM solved the problem by the following:
if you change the keyboard to arabic keyboard, then the layout of typing will change from left-to-right to right-to-left
and that will solve it.

I know that maybe all/most of the languages use left-to-right, except for arabic language.

It is better to develop aMSN so that it can handle the arabic language by the following:
when a user changes the keyboard to arabic, then the writing will be right-to-left instead of left-to-right.
otherwise it will be left-to-right.


I hope that will help.

thanks.
Logged
Pages: 1 [2] 3 4 ... 6
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!