aMSN Forums
June 18, 2018, 09:47:58 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 [2] 3
  Print  
Author Topic: Solved: aMSN keeps trying to download tls (and failing)  (Read 70324 times)
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #15 on: October 09, 2007, 12:21:02 am »

what update ? amsdn update? in which case, from which version to which version? if ubuntu update, then do you know which packages got installed ? can you check if you use tcl/tk 8.4 or tcl/tk 8.5 and finally, if you download the tls module from SF (the one we built in the amsn project), you should extract the .tar.gz file into /usr/share/amsn/utils not /usr/share/amsn
Logged

KaKaRoTo
mxl2003
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #16 on: October 09, 2007, 02:14:18 am »

The OS pushed an auto-update from 0.96 to 0.97RC1, which caused the problem. However, the steps/script found here solved the problem, and are recommended for anyone using Ubuntu.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #17 on: October 13, 2007, 11:28:28 pm »

@clope2000 : I split your post, as it was unrelated to this issue. If you're looking for your post+answer, you'll find it here : http://www.amsn-project.net/forums/viewtopic.php?t=4177
thanks
Logged

KaKaRoTo
clope2000
Newbie

Offline Offline

Posts: 4


View Profile
« Reply #18 on: October 16, 2007, 07:10:08 am »

I see a direct relation between my replies and the subject of this post ( aMSN keeps trying to download tls (and failing)). Moreover, I know that I'm not alone to be unable to install aMsn because TLS download fails. So, to keep in a single post all the replies regarding to the same problem, I would like to persist and sign here, in this post, but rendez-vous in the new topic.  :roll:
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #19 on: October 16, 2007, 07:55:33 am »

alright, now if you want to move it up here, ok, but the error you posted was that you weren't able to install amsn, caused by autopackage, it had nothing to do with tls since you couldn't install amsn so you couldn't even launch amsn for it to complain about download tls failed...
anyways, now that your error looks more like the tls error (and not the install error), you can continue it in here, it's your choice, in any case, I answered you on the other thread, but you can continue it in here if you feel like it.
Logged

KaKaRoTo
Nille
Newbie

Offline Offline

Posts: 1


View Profile
« Reply #20 on: December 12, 2007, 02:08:31 am »

I get the same error that mxl2003 posted an screen dump of.
And when it try tclsh i get this.
Code:

root@mybox:# tclsh
% package require tls
can't find package tls

i also tried 'amsn require tls' if i missunderstod the syntax.
I use slackware 12 with tcl 8.4.15.

Seems to me that many people got this download problem so it needs to be fixed before it gets stable.
But unpacking tls-1.5.0-linux-x86.tar.gz and copying tls1.50 to /usr/share/amsn/utils then 'chown root.root tls1.50' worked.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #21 on: December 12, 2007, 04:53:13 am »

Hi Nille,
if it worked, then what's the problem ?
Logged

KaKaRoTo
sean_zhang
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #22 on: January 06, 2008, 03:13:32 am »

Hi
This is the first time I installed AMSN.
AMSN prompts that the tls should be installed and it automatically downloads the tls-1.5.0-linux-x86 package from Internet, after that it says that the tls is installed. However, AMSN still prompts that the tls is not installed when I try to log in.
I found that the .tar.gz package is downloaded in /root/.amsn-recieved folder, its size is 1.5MB (the package from sourceforge.net is much much smaller).
I extracted the .tar.gz package and found 3 files: libtls1.50.so (size 1.5MB), tls.tcl, and pkgIndex.tcl. I created the folder /usr/lib/tls1.50 and placed all these files in it; however, AMSN still prompted the tls is not installed.
I ran the command tclsh, no error or warning message showed up.
What shall I do now?
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #23 on: January 06, 2008, 03:19:04 am »

1 - don't run any programs from root, that's very bad!
2 - read carefully everything written above and follow those instructions.
Logged

KaKaRoTo
sean_zhang
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #24 on: January 06, 2008, 03:58:49 am »

Oh I finally log in AMSN successfully.
# tclsh
% package require tls
couldn't load file "/usr/share/tcl8.4/libtls1.50.so": /usr/share/tcl8.4/libtls1.50.so: cannot open shared object file: No such file or directory
% su
# cp ~/.amsn/plugins/tls1.50/*.so /usr/share/tcl8.4
# exit
% package require tls
couldn't load file "/usr/share/tcl8.4/libtls1.50.so": /usr/share/tcl8.4/libtls1.50.so: cannnot restore segment prot after reloc: Permission denied
% su
# chcon -t texrel_shlib_t /usr/share/tcl8.4/*.so
# exit
% package require tls
1.50
%

After that, the AMSN finally works.
OS: RHEL5.1
Logged
PandaBill
Newbie

Offline Offline

Posts: 1


View Profile
« Reply #25 on: September 02, 2008, 07:25:11 pm »

Hi

I googled aMSN and found a site to downloade it (http://www.amsn-project.net/) then i'm stuck i found another place to download but no mater how i try i cant manage to download can someone link me a direct link to the download of aMSN for linux

btw; i'm not that good on cumputers Tongue

PS; i tried the libary but get the 404 error and sum of the links i cannot open :S

xoxo PandaBill
Logged

jessica therese
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #26 on: September 02, 2008, 10:59:50 pm »

http://prdownloads.sourceforge.net/amsn/amsn-0.97.2-1.tcl85.x86.package

Also read this: http://www.autopackage.org/docs/howto-install/
Logged
Daniel
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #27 on: September 07, 2008, 04:47:56 pm »

unimatrix script fixed the install tls loop for me

 https://www.amsn-project.net/forums/viewtopic.php?t=3242&postdays=0&postorder=asc&start=0
Logged
Keter
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #28 on: November 22, 2008, 01:40:56 pm »

Hello, I have recently switched to Ubuntu 64bit (from 32bit) and since then I always get the tls prompt loop, no matter what I do.
I tried installing it manually like specified in this thread, I tried installing it via apt-get, with no success at all.
If I enter TCL shell (tclsh) and type "package require tls" I get "1.50", which as far as I know is what it's supposed to be.

I have Ubuntu 8.10 64bit (same problem in 8.04 64bit) and I use AMSN from SVN, with TCL/TK 8.5 from Ubuntu repos.
I even tried to make clean and even to re-download everything, but nothing changed.

Maybe there's something I missed?
Any kind of advice are more than welcome.
Thanks in advance.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #29 on: November 22, 2008, 08:49:30 pm »

@Keter: delete the one that amsn downloaded! it's in ~/.amsn/plugins/tls1.50 (the ~/.amsn is a hidden directory, starts with a dot and is in your home directory).
Logged

KaKaRoTo
Pages: 1 [2] 3
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!