aMSN Forums
December 12, 2018, 07:18:40 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 2 3 [4] 5
  Print  
Author Topic: Offline Instant Messaging (OIM)  (Read 125564 times)
carmenyen
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #45 on: May 16, 2008, 04:37:13 am »

Hello,
When I logged on to aMSN today, it told me that I had an offline instant message.
However, when I clicked yes to read it, it gave me an error message.
The details said:

illegal character found in input
    while executing
"::base64 -mode decode -- $string"
    (procedure "base64::decode" line 3)
    invoked from within
"base64::decode $data"
    (procedure "parseFieldEncoding" line 14)
    invoked from within
"parseFieldEncoding $nick"
    (procedure "::MSNOIM::getOIMMessageCallback" line 17)
    invoked from within
"::MSNOIM::getOIMMessageCallback {::OIM_GUI::MessagesReceivedCallback {} ovi_cs_h93xxx@sadamsnuser.com =?utf-8?B?1?= 2C6ED277-6595-4E94-9072-DCBD07021E54 {..."
    ("eval" body line 1)
    invoked from within
"eval $callbk [list $message]"


Everytime I log on now, it keeps telling me about the offline message and the same error message appears, since I am never able to read the offline message.
I cannot read the message and I do not know who it is from. I'm very curious about the contents of the message.
Can someone help me out??? Is there a way of retrieving the message?

By the way, I'm using aMSN for mac, version 0,97.

Thank you
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #46 on: May 16, 2008, 06:33:19 am »

Hi,
The data received is invalid obviously, I don't know why or how it got like this, maybe your friend uses some unofficial client that is not working correctly...
in any case, I made a patch in the latest SVN that should recover in case of a similar issue so you should be able to read the OIM.
For more information on how to install/use the SVN version, read here : http://amsn-project.net/wiki/SVN
it's not that complicated...
and the only info I can give you about who sent you that message is that his email address starts with ovi_cs_h93... the rest is censored in the bug report to protect you and your contact's privacy, so I don't know it.
hope that helps!
btw, welcome to the forums Smiley
Logged

KaKaRoTo
carmenyen
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #47 on: May 16, 2008, 01:37:08 pm »

Hello,
First of all, thank you for replying to my first question.

I tried to install SVN with the development archive way buy replacing the old scripts folder. However, when I tried opening aMSN again, I got this message:

"There is a problem loading a module of aMSN (TkCxImage) on this computer. You need to update your system to Mac OS 10.3.9."


I really don't know that much about computers.....
Can you tell me what went wrong???
In the meantime, I put the old scripts folder back and aMSN is working fine except for the same OIM problem that I still have.

Thank you
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #48 on: May 16, 2008, 06:05:04 pm »

humm.. what version of Mac do you have? go to apple->about this mac
are you using a very old version of mac ?
Logged

KaKaRoTo
Yowler
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #49 on: September 24, 2008, 07:33:39 pm »

I see the last reply was in May, however I still have this issue when trying to send a message to an offline user.
Any workarounds?

thanks
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #50 on: September 24, 2008, 08:50:50 pm »

@Yowler : WHAT issue?
which version are you using? what issue are you having ? do you get an error? where's your status log output ? etc... You can't come in here asking for him without giving the minimum details needed to actually get an answer!
and make sure you use the latest SVN version before reporting any problem : http://amsn-project.net/wiki/SVN
Logged

KaKaRoTo
Yowler
Newbie

Offline Offline

Posts: 2


View Profile
« Reply #51 on: September 25, 2008, 10:35:24 pm »

Hello,

I appologise for my incomplete and vague question..i should have provided more information.
Here's the issue:
I couldn't send offline messages, only if the user that was appearin offline was keeping the connection alive by sending messages every now and then.
I was using a version installed directly from Synaptic ( Something 0.87 or some sort, can't remember now as i'm using the version from SVN  ) ( Ubuntu 8.04 TLS , with the latest updates ), I never thought and never came accross a SVN information for Amsn.What I mean by this, is you should give more information to end users, like me, and many others that don't dig much into Amsn forums.

On the other hand, compiling from the SVN worked beautiful.

Thanks again,
Yowler
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #52 on: September 25, 2008, 11:01:42 pm »

hi,
ok, so basically you were using an old version that didn't work well (because MSN keeps changing their protocol).. now SVN works fine!
and the SVN instructions are easy to find, just google for "amsn svn"... and no, we don't want "anyone" from our users to use SVN, because we would then end up with too many people coming here to yell and bitch about bugs on features we are currently working on (it does happen already), because some will think svn is just another version and not a "development version, use at your own risks, it could work beautifully, or it could not even launch"...
Logged

KaKaRoTo
pepo8
Newbie

Offline Offline

Posts: 6


View Profile
« Reply #53 on: October 23, 2008, 09:56:18 pm »

hey.

I am having problems with the MAC 0.97.2 version, I have 12 OIM i can not read. i tried downloding the
SXML.TCL and replaced it. Did not work.
Almost forgeting to mention it, Amsn freezes with the message telling me i have 12 OIM   and makes my computer slowwww..  MBP 2.2GHZ with 4 gigs in ram. It makes it crash.
what can i do to fix the OIM problem? any help?

Thank you very much!
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #54 on: October 23, 2008, 10:27:15 pm »

before connecting, go to preferences->session and select show normal windows (without tabs), then connect.
The bug should be fixed for the next release.
Logged

KaKaRoTo
pepo8
Newbie

Offline Offline

Posts: 6


View Profile
« Reply #55 on: October 24, 2008, 12:51:44 am »

hi again, thx for listening my prayers hehehe

tried what u said about the normal window, though it did not work. have tried to uninstall and install Amsn a few times, still not working.
any other suggestions?

J
Logged
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #56 on: October 24, 2008, 12:32:41 pm »

Actually, I think it's the other way around: you should select one window for all your contacts (not one window for each group)
Logged
pepo8
Newbie

Offline Offline

Posts: 6


View Profile
« Reply #57 on: October 27, 2008, 10:24:42 am »

not working Sad

is there any way to erase those messages, prob erase the log for that account?
i can open other accounts (in which i dont have OIM) and it works flawlessly

or is there any other patch i can download besides the one i mentioned in the 1st post?
Logged
clookie
Power user
*
Offline Offline

Posts: 101



View Profile WWW
« Reply #58 on: October 27, 2008, 10:44:12 am »

Quote from: "pepo8"
not working Sad

is there any way to erase those messages, prob erase the log for that account?
i can open other accounts (in which i dont have OIM) and it works flawlessly

or is there any other patch i can download besides the one i mentioned in the 1st post?

just login for once with another messenger,
receive the offline messages over there,
log off and log on into amsn again =)
that's how I do it when it happens to me
Logged

(\ /)
(O.o)
(> <)
This is Bunny.
Copy Bunny into your signature to help him on his way to world domination.
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #59 on: October 27, 2008, 04:54:30 pm »

@clookie : when it happens to you, you should tell us about it so we can fix it! I didn't know we still had those issues! They were supposed to be fixed... are you guys on Mac ?

Are you sure you are using the latest SVN version ?
Logged

KaKaRoTo
Pages: 1 2 3 [4] 5
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!