aMSN Forums
January 18, 2018, 10:55:35 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 [2] 3 4 5
  Print  
Author Topic: Offline Instant Messaging (OIM)  (Read 115179 times)
Zap
Newbie

Offline Offline

Posts: 43


View Profile
« Reply #15 on: January 29, 2007, 01:28:24 pm »

Same here. But now I got an « Unknown error » again..

Then it seems to have worked with another contact (not error was displayed, but I don't know if he actually got the message).
And now I tried again with another contact, and I get « authentication failed ».

Then with another contact it seems to work again. So, to sum up, either I get no error, « invaliduser », « unknown error » or « authentication failed ». But that last one happened only on one, and always the same, contact.

By the way, how come there is nothing in the protocol log when sending OIMs ? Are they sent another way ?


UPDATE : apparently they didn't receive any message, even when no error was reported.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #16 on: January 30, 2007, 03:51:46 am »

hi Zap,
The OIM code is working rather randomly, it might work, it might not work, and I know I have this same behavior (message could not be sent) when using the original WLM client on windows. I think the OIM server is rather buggy on their part, the 'contact card/spaces' server also have that kind of problem, you'll often get errors from the server like that. But we're still trying to figure it if we can do something about it from amsn's side...
about the protocol thing, no it's not shown in the protocol because we don't send the OIM to the user, nor to the 'msn server', but it's rather a SOAP request (wikipedia can tell you what SOAP is) which goes directly to an OIM server (kind of like a mail server), which is why it doesn't show up in the protocol window.
Logged

KaKaRoTo
Fenix-TX
Super Power User
**
Offline Offline

Posts: 660


View Profile
« Reply #17 on: January 30, 2007, 11:45:42 am »

I don't know if this was posted before, but when i open two contacts or more contacts in invisible mode, on taskbar it's shown Chatwindow instead of the email of the contact.
Logged
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #18 on: January 30, 2007, 08:48:02 pm »

Can you get latest SVN and see if the "authentication failed" issue is fixed? Thanx
Logged
nsma
Power user
*
Offline Offline

Posts: 51


View Profile WWW
« Reply #19 on: January 31, 2007, 02:27:02 am »

oim is working again
but if talking to a contact which is appear offline as soon as msn closes the connection after no activity and i try and send a message to them amsn asks to send a oim but i get  authentication failed
Logged
Zap
Newbie

Offline Offline

Posts: 43


View Profile
« Reply #20 on: January 31, 2007, 04:21:38 am »

I can't say.. The « authentication failed » error was gone before I updated SVN.
Now I only get unknown errors..
Logged
vivia
Administrator
Super Power User
*****
Offline Offline

Posts: 2464


View Profile
« Reply #21 on: January 31, 2007, 02:16:07 pm »

nsma: this is a server problem unfortunately Sad

There are still errors to be fixed, please be patient...
Logged
thecomputerman
Newbie

Offline Offline

Posts: 6


View Profile WWW
« Reply #22 on: February 02, 2007, 09:00:22 am »

OIM is working well with the SVN of 2 February ! But I will have an idea to subject : if a contact is on-line and my status is off-line i can't talk with this on-line contact...in a previous amsn version a bug authorized the off-line/on-line conversation is it possible to reintroduce this "bug" ? I know it's possible to go on-line open a conversation and go off-line...but it's more easy if the off-line/on-line is actived !

Thank you by advance
Logged
billiob
Administrator
Super Power User
*****
Offline Offline

Posts: 1352


View Profile
« Reply #23 on: February 02, 2007, 10:37:02 am »

That's not possible for the moment, since we don't support the msn protocol version 13.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #24 on: February 02, 2007, 04:00:30 pm »

it was a bug in the server, not in the client.
Logged

KaKaRoTo
MastaG
Power user
*
Offline Offline

Posts: 65


View Profile
« Reply #25 on: March 23, 2007, 06:29:29 pm »

amsn seems to freeze when I try to read my OIM messages over http proxy server.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #26 on: March 23, 2007, 06:41:33 pm »

proxy support is not yet finished for oims and spaces...
Logged

KaKaRoTo
swejuggalo
Newbie

Offline Offline

Posts: 37


View Profile
« Reply #27 on: September 27, 2007, 05:23:54 pm »

The following message could not be delivered:
(invaliduser) , when sent to a offline contact...

revision 9059.

Seems to work as long my "offline" contact doesnt get timeout for inactivity...but as soon as she/he writes and connects again it works in both directions until the next timeout.
Logged

linux brings me joy since there is always something you could test, break or fix. A great timekiller AND a timesaver Smiley
clookie
Power user
*
Offline Offline

Posts: 101



View Profile WWW
« Reply #28 on: September 29, 2007, 12:28:48 pm »

Quote from: "swejuggalo"
The following message could not be delivered:
(invaliduser) , when sent to a offline contact...

revision 9059.

Seems to work as long my "offline" contact doesnt get timeout for inactivity...but as soon as she/he writes and connects again it works in both directions until the next timeout.

same thing here

and this thing too:

Problem sending message:
(Flood Protection Activated)
Logged

(\ /)
(O.o)
(> <)
This is Bunny.
Copy Bunny into your signature to help him on his way to world domination.
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #29 on: October 01, 2007, 04:39:39 am »

server problems, could be bugs with the servers, or server unavailable. The flood protection is when you send too much/too often/too long messages. WLM seems to suffer from the same problems, so no reason to blame amsn.
Logged

KaKaRoTo
Pages: 1 [2] 3 4 5
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!