aMSN Forums
December 13, 2018, 09:43:34 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: [1] 2 3 ... 5
  Print  
Author Topic: Offline Instant Messaging (OIM)  (Read 125623 times)
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« on: September 07, 2006, 10:28:01 pm »

Hello,
This is to announce that aMSN SVN version now has support for Offline Instant Messages (OIM), so you can receive them, read them, delete them... and also, in the next couple of days, be able to send them too!!! And you don't even have to wait until MSNP13 is implemented! Cheesy
I hope you'll enjoy it...

p.s. : Remember, no complaints, no bugreports until we officially claim it's "stable".. for now it's still the first draft of the code, it's still experimental and has not been tested very much...

Take care!
Logged

KaKaRoTo
Fabioamd87
Super Power User
**
Offline Offline

Posts: 467



View Profile
« Reply #1 on: September 08, 2006, 12:39:10 am »

tanks! Smiley
Logged
Fenix-TX
Super Power User
**
Offline Offline

Posts: 660


View Profile
« Reply #2 on: September 08, 2006, 11:13:56 am »

Woooooooooooow!!!! I had downloaded the last svn without see this post and i recieved a OIM, and i didn't know what was that, now i know it Cheesy
Logged
snipe2004
Super Power User
**
Offline Offline

Posts: 827


View Profile
« Reply #3 on: September 08, 2006, 11:51:04 pm »

Hey, I saw it in the mailing-list, so it's not a joke Cheesy Cheesy
Great news !!!!
I'm downloading svn right now Wink
Thanks at all for the job Smiley
Logged

Voyager 11.10
WM-666
Super Power User
**
Offline Offline

Posts: 292



View Profile WWW
« Reply #4 on: January 23, 2007, 06:49:02 pm »

LoL...

A few minutes ago, I logged on and got the popup "new offline messages received, do you want to read them?"
When I opened them, I got this: "Thu Jan 01 01:00:00 CET 1970 Saar [ Falco Columbarius ] zegt: "
aMSN is a time-machine!  :lol:
No seriously, I know this from PHP, something with the date-settings... Can it be corrected?

P.S: I asked and the messages were sent today, so... Smiley
Logged

Win7 x64, currently no Ubuntu (will install 10.04)
nsma
Power user
*
Offline Offline

Posts: 51


View Profile WWW
« Reply #5 on: January 24, 2007, 04:14:23 am »

same problem here using latest svn but my date is different than yours
Wed Dec 31 19:00:00 EST 1969
i think they know about this problem
but i didnt see it mentioned anywhere that oim's dont use the senders font and also custom emoticons dont display
not sure about default emoticons
Logged
NoWhereMan
Contributor
Super Power User
**
Offline Offline

Posts: 502



View Profile
« Reply #6 on: January 24, 2007, 10:00:34 am »

that date correspond to the UNIX timestamp 0; the difference is probably due to your different locale settings Smiley
Logged

NoWhereMan
-- Windows mom: «Finish your veggies! There are processes in Ubuntu that are starving to death!»
-- NoWhereBlog (ita)
-- http://flatpress.sf.net
billiob
Administrator
Super Power User
*****
Offline Offline

Posts: 1352


View Profile
« Reply #7 on: January 24, 2007, 11:17:12 am »

i know i have to improve that, but that's the first time i get a 0 timestamp. Weird
Logged
billiob
Administrator
Super Power User
*****
Offline Offline

Posts: 1352


View Profile
« Reply #8 on: January 25, 2007, 03:38:18 pm »

should be fixed in rev 7831.
Logged
sulfur
Newbie

Offline Offline

Posts: 19


View Profile
« Reply #9 on: January 28, 2007, 04:52:56 pm »

Quote from: "billiob"
should be fixed in rev 7831.

Definitely appears to be, but i think that i've come across a bug that seems to have cropped up again recently, but in a slightly altered form.

When you receive an OIM from someone who happens to be online when you read it, you can see their message without an issue.  However, it appears that when you receive an OIM from someone who is offline when you read it, it comes up as an empty message, as per this discussion I previously opened.
Logged
nsma
Power user
*
Offline Offline

Posts: 51


View Profile WWW
« Reply #10 on: January 28, 2007, 09:19:40 pm »

yep thanks timestamps seem to work although not in the same format as other timestamps but at least they work
but now sending a oim doesnt work at all with svn r7854

[15:19:09] The following message could not be delivered:

invaliduser

i get this error and no errors in the status log

except for this which i think is normal

[15:18:44] usersInChat: no SB for chat email@hotmail.com!! (shouldn't happen?)
Logged
Zap
Newbie

Offline Offline

Posts: 43


View Profile
« Reply #11 on: January 28, 2007, 10:20:11 pm »

I can't send any OIM either.. Now it says « invaliduser », but it used to say « unknown error ».. So I suppose it's got improved. Tongue

Also, it's been a while.. I don't think it has ever worked properly for me.
Logged
billiob
Administrator
Super Power User
*****
Offline Offline

Posts: 1352


View Profile
« Reply #12 on: January 28, 2007, 10:24:56 pm »

A question : do you use an account at hotmail.com or msn.com or you're using just a "passport" ?
Logged
nsma
Power user
*
Offline Offline

Posts: 51


View Profile WWW
« Reply #13 on: January 28, 2007, 10:53:04 pm »

im using a @hotmail.com email and so was the 2 people i tried to oim
Logged
sulfur
Newbie

Offline Offline

Posts: 19


View Profile
« Reply #14 on: January 29, 2007, 04:43:05 am »

ditto for me.  @hotmail, so is the other end.
Logged
Pages: [1] 2 3 ... 5
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!