aMSN Forums
January 18, 2018, 10:56:07 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 2 [3]
  Print  
Author Topic: [SOLVED] corrupted png -> crash with *glibc double free..  (Read 78768 times)
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #30 on: August 25, 2007, 02:47:18 am »

good news to everyone having this problem. It is now FIXED! Thanks to your faithful developer : Phil (a.k.a lephilousophe) and big thanks to High_Priest from IRC (a.k.a "Dark" in the forums).
The bug was not from amsn, it was actually a bug in the optimizer of GCC itself. Phil refactored some code and found a work around the bug in GCC, so with latest SVN version, it should now be working correctly.
If any of you here have the bug, please update to latest SVN revision (r8972) and compile amsn again (a "make clean all" would be good).
Logged

KaKaRoTo
panda84
Newbie

Offline Offline

Posts: 17


View Profile
« Reply #31 on: June 05, 2009, 09:06:11 am »

This seems to be a like zombie: you kill him but he always come back.

Tcl / Tk 8.6b1 from sources with threads; aMSN 0.98b from sources; libpng3 1.2.15~beta5-1+etch2; gcc 4.1.1-15. Again the same problem:
Code:
*** glibc detected *** double free or corruption (!prev): 0x0a62f5b8 ***


Would you like to debug the problem or should I just delete broken images and forget about it?
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #32 on: June 05, 2009, 10:47:05 pm »

oh please noooooooooooooo
ok, well, i guess we need/want to see what caused it.. a gdb backtrace would be appreciated.. and if you can find the faulty image (if it is indeed caused by a corrupted image), then that would help to upload it too..
thanks
Logged

KaKaRoTo
panda84
Newbie

Offline Offline

Posts: 17


View Profile
« Reply #33 on: June 06, 2009, 09:50:06 am »

Quote from: "kakaroto"
oh please noooooooooooooo
ok, well, i guess we need/want to see what caused it.. a gdb backtrace would be appreciated.. and if you can find the faulty image (if it is indeed caused by a corrupted image), then that would help to upload it too..
thanks

Ok, I'll try to get a backtrace... and yes, it's faulty image: renaming displaypic/cache and creating an empty one solves the problem. The difficult part is to get which is the faulty image: I use aMSN since 0.95 and I've never cleaned up the profile, so now I have a 60MB displaypic/cache folder!

BTW, I have compiled both Tcl/Tk and aMSN with "-O2" and without "-g" for increased speed. Could this be the cause?
Logged
Pages: 1 2 [3]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!