aMSN Forums

aMSN Support => Linux => Topic started by: flomar34 on April 03, 2009, 01:39:12 pm



Title: Installing Amsn svn : A repository for Ubuntu users
Post by: flomar34 on April 03, 2009, 01:39:12 pm
Hello

There is a new ppa for amsn svn,
https://launchpad.net/~amsn-daily/+archive/ppa

So, normally, you just have to add

deb http://ppa.launchpad.net/amsn-daily/ppa/ubuntu jaunty main

or

deb http://ppa.launchpad.net/amsn-daily/ppa/ubuntu intrepid main

in your sources.list and add the key as explain on the launchpad

Then ....

sudo apt-get install amsn

That's all (we hope) :)
It will install libnice 0.0.6 and farsight 0.0.7 too as dependencies

Many Thanks to Stemp for this repository
And please tell us if anything is missing

Hope it could help


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Montblanc on April 03, 2009, 03:34:03 pm
Thank you for your efforts!  :) Though you should add the old Farsight 0.0.4 as a dependency. Here's what the A/V wiki (http://www.amsn-project.net/wiki/Farsight) sais about it:

Code:
9 - farsight2 - 0.0.4 (farsight2 0.0.5 and 0.0.6 are known not to work properly with aMSN right now, so please use the 0.0.4 version only for now)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: flomar34 on April 05, 2009, 01:40:31 pm
Hi,

Stemp add in the PPA tow pakages

- amsn amsn-extra-skins
- amsn amsn-extra-plugins


Quote from: "Montblanc"
Thank you for your efforts!  :) Though you should add the old Farsight 0.0.4 as a dependency. Here's what the A/V wiki (http://www.amsn-project.net/wiki/Farsight) sais about it:

Code:
9 - farsight2 - 0.0.4 (farsight2 0.0.5 and 0.0.6 are known not to work properly with aMSN right now, so please use the 0.0.4 version only for now)


Thanks for this
Do you think that it's the same problem with farsight 0.0.7 ?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on April 05, 2009, 03:09:08 pm
Hi,
Thanks, great stuff there! :) I'm sure it will be useful!
About farsight, the wiki needs some updating, but 0.0.7 should work just fine! But dont upgrade to 0.0.8 yet!


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Montblanc on April 05, 2009, 05:24:18 pm
Quote from: "kakaroto"
About farsight, the wiki needs some updating, but 0.0.7 should work just fine! But dont upgrade to 0.0.8 yet!


Good news! :D


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Kreuger on April 07, 2009, 09:59:40 pm
Thanks for this, I was hoping it would help me get farsight working. However, I get this error:

Quote
Farsight : Preparing
Farsight Prepare error : couldn't load file "utils/farsight/tcl_farsight.so": utils/farsight/tcl_farsight.so: undefined symbol: fs_stream_set_remote_candidates


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: flomar34 on April 08, 2009, 10:55:52 am
Hello,

I'm not sure to be able to help you  :(
if you compiled it before, have you clean all your install?


In the wiki it'said
Quote
In order to make an Audio Call in aMSN, you will need to have the following dependencies installed on your system :
1 - glib 2.16 or newer
2 - gstreamer 0.10.20 or newer
3 - gst-plugins-base 0.10.20 or newer
4 - gst-plugins-good 0.10.7 or newer
5 - gst-plugins-bad 0.10.6 or newer
7 - gst-plugins-farsight - 0.12.9 or newer

Is it ok for you?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on April 08, 2009, 06:25:58 pm
actually I updated the wiki now with the new needed versions...
Kreuger: make sure you compiled it correctly because there's just no way that symbol can't be found if you linked it with farsight2!


Title: Impossible to make audio calls...
Post by: CyberAngel on April 12, 2009, 10:34:42 am
Hi,
I installed amsn from the ppa repository but I get this error having to do with farsight:

Code:
Farsight : Preparing
Farsight Prepare error : couldn't load file "utils/farsight/tcl_farsight.so": utils/farsight/tcl_farsight.so: wrong ELF class: ELFCLASS32


I didn`t have farsight installed before nor I did any attempt to compile it from svn on my own in the past...

I`m using kubuntu jaunty.
Any clue?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: flomar34 on April 12, 2009, 11:05:26 am
Hello,

Are you using a 64 bits system? Maybe there is a problem with it


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: CyberAngel on April 12, 2009, 11:54:48 am
Quote from: "flomar34"
Hello,

Are you using a 64 bits system? Maybe there is a problem with it


Yes I do use a 64bits system :)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Kreuger on April 13, 2009, 05:44:40 pm
All I did was install the debs from the repo so it did everything itself, I would assume.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: flomar34 on April 13, 2009, 06:05:23 pm
Kreuger: what is your version of ubuntu?

I imagine that you added the repo in your source.list then apt-get update and then apt-get install amsn


could you try an
Code:
sudo apt-get autoremove --purge amsn


and then
Code:
sudo apt-get install amsn


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Kreuger on April 20, 2009, 01:45:40 pm
Quote
Kreuger: what is your version of ubuntu?

Jaunty

Quote
I imagine that you added the repo in your source.list then apt-get update and then apt-get install amsn

That's correct.

Quote
could you try an

Would that not remove all my settings and everything?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: flomar34 on April 20, 2009, 05:57:13 pm
It's very strange because we have no problem with jaunty

Normally with a
sudo apt-get autoremove --purge amsn

It didn't remove the preferences

Your preferences are saved in your home in the .amsn folder


Title: Re: Impossible to make audio calls...
Post by: linux3114a on April 20, 2009, 06:04:03 pm
Quote from: "CyberAngel"
Hi,
I installed amsn from the ppa repository but I get this error having to do with farsight:

Code:
Farsight : Preparing
Farsight Prepare error : couldn't load file "utils/farsight/tcl_farsight.so": utils/farsight/tcl_farsight.so: wrong ELF class: ELFCLASS32


I didn`t have farsight installed before nor I did any attempt to compile it from svn on my own in the past...

I`m using kubuntu jaunty.
Any clue?



Have the same problem after using this reposit with intrepid..... not serious
raoul


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: flomar34 on April 20, 2009, 06:28:31 pm
For intrepid there is NO farsight in this repo for the moment. So you have to install farsight by yourself.

What is not serious for you ... ?
Stemp will update it when he will have enough free time.

I think that it's a very good idea to have a repo with all the updated dependencies needed for amsn svn.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: CyberAngel on April 20, 2009, 07:14:51 pm
is there any known problem for the amd64 architecture and the farsight?
If yes, is there any known workaround?

Thanks


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on April 20, 2009, 10:52:14 pm
@CyberAngel: no known problem for amd64, but if you tell us what your problem is then we might help (but use the correct thread please)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: CyberAngel on April 20, 2009, 11:10:09 pm
Quote from: "kakaroto"
@CyberAngel: no known problem for amd64, but if you tell us what your problem is then we might help (but use the correct thread please)


Actually I was thinking that there might be a known problem with the packages from the repositories (and with amsn itself) cause when I first asked in this thread why the audio conference is not working I had this reply from flomar34:

Quote
Hello,

Are you using a 64 bits system? Maybe there is a problem with it


My problem is that even if farsight is installed from the repository, I get this error in the Preferences -> Others -> Edit audio and video settings:

Code:
Farsight : Preparing
Farsight Prepare error : couldn't load file "utils/farsight/tcl_farsight.so": utils/farsight/tcl_farsight.so: wrong ELF class: ELFCLASS32


And I get this error in the conversation window:

Code:
You cannot make an Audio Call. Please install Farsight2 and try again.


if you see below, I have the farsight library installed from the repositories...

Code:
:/usr/share/amsn/utils/farsight$ ls
pkgIndex.tcl  tcl_farsight.so


Code:
:/usr/share/amsn/utils/farsight$ apt-cache policy libgstfarsight0.10-0
libgstfarsight0.10-0:
  Installed: 0.0.9-1~jjamsn2
  Candidate: 0.0.9-1~jjamsn2
  Version table:
 *** 0.0.9-1~jjamsn2 0
        500 http://ppa.launchpad.net jaunty/main Packages
        100 /var/lib/dpkg/status
     0.0.7-1ubuntu1 0
        500 http://gr.archive.ubuntu.com jaunty/universe Packages


Code:
:/usr/share/amsn/utils/farsight$ apt-cache policy gstreamer0.10-plugins-farsight
gstreamer0.10-plugins-farsight:
  Installed: 0.12.11-1~jjamsn1
  Candidate: 0.12.11-1~jjamsn1
  Version table:
 *** 0.12.11-1~jjamsn1 0
        500 http://ppa.launchpad.net jaunty/main Packages
        100 /var/lib/dpkg/status
     0.12.10-2 0
        500 http://gr.archive.ubuntu.com jaunty/universe Packages


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kjir on April 21, 2009, 05:32:44 pm
I'd say that the repository is for 32bit ONLY, you have to recompile farsight.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: CyberAngel on April 21, 2009, 08:46:55 pm
Quote from: "kjir"
I'd say that the repository is for 32bit ONLY, you have to recompile farsight.


If you check this link http://ppa.launchpad.net/amsn-daily/ppa/ubuntu/pool/main/f/farsight2/, you can see that amd64 packages exists too!
More than that, amsn svn is working fine from this repository in my 64bits system except the calls.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kjir on April 21, 2009, 09:20:46 pm
Well the above errors mean that you are trying to load a 32 bit library on a 64bit system. I can assure you that farsight 2 works flawlessly with amd64, I compiled it and it works fine...


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Kreuger on April 23, 2009, 02:34:32 pm
Quote
Your preferences are saved in your home in the .amsn folder

Oh that's right. Still have the problem though.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: flomar34 on April 23, 2009, 03:38:04 pm
@Kreuger : Sorry for that Kreuger, but the only similar problem i found is from harrydb  (http://www.amsn-project.net/forums/viewtopic.php?p=34790&highlight=#34790)who had an older version of farsiht in the same time

Maybe you compiled yourself before or installed in an other way and then made a

sudo ldconfid

so now amsn is looking for this librairy in the wrong place
maybe try to find if there is no an older version of farsight in your computer, uninstall it and try

Code:
sudo ldconfig



Stemp updated the ppa to the revision 11149 so if it's working for somebody  :P  you could test the audio and video using MSNP18
(jaunty is out today, so maybe the  ppa could be down )


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Kreuger on April 30, 2009, 02:16:13 pm
Yeah I did try to install it myself, before. It was version 2.0.0.8 though, isn't that what's in the repo?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: flomar34 on May 06, 2009, 03:12:47 pm
Hi,

No, in the repo it's the 0.0.9 version of farsight.

(since jaunty is out, it needs about 12 hours to update PPA's,so before installing it look here (https://launchpad.net/~amsn-daily/+archive/ppa/) if its built)

The 11163 revision should be built in 9 hours from now  :lol:

Hope it will be faster last week


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on May 06, 2009, 07:47:39 pm
version 11163 wkt3 should fix the farsight problem on 64 bits system ;)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: flomar34 on May 09, 2009, 05:46:23 pm
Hi,

Kreuger: Some people had problem with an older version of farsight installed in them system
before the last version of the amsn-dayli repo
and the solution was with this 2 commands

Code:
mv /home/$USER/.gstreamer-0.10 /home/$USER/.gstreamer-0.10.bak
mv /home/$USER/.farsight /home/$USER/.farsight.bak


If you can understand the french,
http://forum.ubuntu-fr.org/viewtopic.php?pid=2630483#p2630483

Hope it helps  :)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Menion on May 23, 2009, 10:39:31 am
Hi
I still can't get farsight2 working with AMSN. I'm trying both a self build SVN and Ubuntu package from the repository. I also either downloaded farsight2 as Ubuntu package either selfcompiled it. Nope! If I compile aMSN by myself ./configure doesn't detect farsight2 package, even if I followed the wiki instructions and downloaded all the dependencies. I tried also do selfcompile libnice with the same result. Do you know what I can check to see if I have everything it is needed to have farsight2 working in aMSN? I'm placing the question here, because as I saif it seems that also Ubuntu package have something wrong, at least on my system.
Bye


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on May 24, 2009, 02:27:01 am
Hi, welcome to the forums!
well, first, make sure you are installing the correct version.. and also that you have the latest SVN revision... if you compiled farsight2/gstreamer/etc.. yourself, make sure you installed it in /usr not /usr/local/ if the ./configure of amsn doesn't find farsight, then upload the config.log file somewhere, i'll have a look...


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Menion on May 24, 2009, 11:47:32 am
That is the point:

Quote
configure:7145: checking for FARSIGHT2
configure:7154: $PKG_CONFIG --exists --print-errors "\
             farsight2-$GST_MAJORMINOR >= $FARSIGHT_REQUIRED"
Requested 'farsight2-0.10 >= 0.0.9' but version of Farsight2 is 0.0.2
configure:7158: $? = 1
configure:7175: $PKG_CONFIG --exists --print-errors "\
             farsight2-$GST_MAJORMINOR >= $FARSIGHT_REQUIRED"
Requested 'farsight2-0.10 >= 0.0.9' but version of Farsight2 is 0.0.2
configure:7179: $? = 1
Requested 'farsight2-0.10 >= 0.0.9' but version of Farsight2 is 0.0.2
configure:7210: result: no


So it seems I have the correct package installed (and I have because I got the amsn repository) but for some reason in the packages configuration it is detected as 0.0.2!!!
How can I fix it?
Bye and thanks!


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Menion on May 24, 2009, 11:47:54 am
That is the point:

Quote
configure:7145: checking for FARSIGHT2
configure:7154: $PKG_CONFIG --exists --print-errors "\
             farsight2-$GST_MAJORMINOR >= $FARSIGHT_REQUIRED"
Requested 'farsight2-0.10 >= 0.0.9' but version of Farsight2 is 0.0.2
configure:7158: $? = 1
configure:7175: $PKG_CONFIG --exists --print-errors "\
             farsight2-$GST_MAJORMINOR >= $FARSIGHT_REQUIRED"
Requested 'farsight2-0.10 >= 0.0.9' but version of Farsight2 is 0.0.2
configure:7179: $? = 1
Requested 'farsight2-0.10 >= 0.0.9' but version of Farsight2 is 0.0.2
configure:7210: result: no


So it seems I have the correct package installed (and I have because I got the amsn repository) but for some reason in the packages configuration it is detected as 0.0.2!!!
How can I fix it?
Bye and thanks!


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Menion on May 24, 2009, 01:13:26 pm
Update:

I found I had installed the 0.0.2 version in /usr/local. So I removed it, or better to be sure that I didn't have any strange library setup I installed farsight2 both in /usr and /usr/local. Now configure correctly report farsight2 (latest version 0.10) is installed. But I still can't have it working...
Any clue of what I can look for? I did also a strace, all the library seems to work corretly, the only "problem" I have is:

lstat64("/usr/lib/farsight2-0.0/pkgIndex.tcl", 0xbfc8792c) = -1 ENOENT (No such file or directory)

but I don't think it is important. Shall I use version 0.9 instead?

Bye

//Antonio

P.S. When I check for Audio/Video preferences and it fails with farsight2 extension, Details button doesn't work


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Menion on May 24, 2009, 01:46:56 pm
Update2:

Finally I got the point: I have to run amsn as root to have farsight2 working. This could explain all this problems users report sometimes about farsight2 not working even if ./configure detects it. I'm running Ubuntu 9.04
Bye


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: afv on May 25, 2009, 02:29:27 am
Hi, thanks for the PPA.

I had to do
Code:
sudo chmod +x /usr/share/amsn/plugins/music/infosongbird

because I was getting this error when enabling the music plugin:
Code:
Music: Error retreiving song : couldn't execute "/usr/share/amsn/plugins/music/infosongbird": permission denied


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: AL3X2 on May 25, 2009, 03:03:42 am
Hi, I tried the repo. Instalation went very well. But I launch amsn and try to login, but I get the famous "TLS not installed" prob.
I have tried placing the tls1.50 folder in ~/.amsn/plugins, in /usr/shared/amsn/, and no luck.

If I open amsn's log (ctrl + s) and I type "package require tls" I get:

"couldn't load file "home........../amsn/plugins/tls1.50/libtls-1.50.so": libssl.so.0.9.7: cannot open shared object file: No such file or directory."

I have installed libssl0.9.8 (the default in jaunty) and tls 1.5

I have tried placing the 0.9.7 so, but no luck.

What could I do?
Thanks


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kjir on May 25, 2009, 07:43:17 pm
The error message means that libtls-1.50.so is linked against libssl.so.0.9.7, you'll need to recompile libtls in order to make it work...


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: AL3X2 on May 26, 2009, 12:48:48 am
I can't remove tcl-tls from my pc (-> I can't rebuild it from src) because when I do "sudo apt-get install amsn" it install automatically "tcl-tls".

Any other ideas :/ ?

Thanks!


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on May 26, 2009, 10:42:40 am
You probably have an older (on hand) installation of tcl-tls.
The version in Jaunty is linked to libssl0.9.8


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: AL3X2 on May 26, 2009, 01:33:38 pm
Ok. I did "sudo apt-get install libssl0.9.8" and I keep getting the same error.
I'm on Jaunty, official repos. Searching for libssl in synaptic shows me version 0.9.8

What could be wrong?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kjir on May 26, 2009, 02:54:33 pm
I'd say stop reinstalling libssl and start reinstalling tcl-tls ;) That's the package with problems, not libssl


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: flomar34 on May 26, 2009, 02:58:44 pm
hello,

did you try to remove the amsn folder in your home ( home/yourname/.amsn)

Be carefull, you will lose your preferences and your login identification (make a backup of it)
     
uninstall amsn

Code:
sudo apt-get autoremove amsn

with the autoremove it will uninstall tls
 and install it

Code:
sudo apt-get install amsn


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: AL3X2 on May 26, 2009, 03:12:52 pm
Ok, I did both things.
I removed .amsn and tried installing without luck.
Then I removed amsn, amsn-data, tcl-tls.
Then I installed tcl-tls and then amsn. No luck. Still the same error... libssl0.9.7 not found... :S


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kjir on May 26, 2009, 03:28:34 pm
The file "home........../amsn/plugins/tls1.50/libtls-1.50.so" has been reinstalled? Is it installed by Ubuntu??


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on May 26, 2009, 04:38:11 pm
Quote from: "kjir"
The file "home........../amsn/plugins/tls1.50/libtls-1.50.so" has been reinstalled? Is it installed by Ubuntu??


No, there is no such plugin in Ubuntu PPA packages.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: AL3X2 on May 26, 2009, 05:08:41 pm
I delete the entire .amsn, and when I start amsn, it says that it needs to download the tls package, so, I select x86-64 system and click ok. It dowloads the package and then untar's it in .amsn/plugins folder. (should be there).
And then the error... (or, if I try to login, it ask me to download the tls package, witch I just downloaded...)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on May 26, 2009, 05:19:54 pm
Ok, in Preferences, Advanced you have a TLS option where you set the directory of tls, it's probably at /home/..../plugins/tls


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kjir on May 26, 2009, 05:47:03 pm
Wait...
You're not installing through Ubuntu package manager (apt)? So that's the problem, it is a version compiled with libssl-0.9.7, you need one with libssl-0.9.8. Either install that through Ubuntu, or compile it yourself...


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on May 26, 2009, 06:05:45 pm
wow, ok, way too many posts for this simple issue...
AL3X2: amsn downloads the ~/.amsn/plugins/tls1.50 which is linked with libssl 0.9.7 BUT you have libssl 0.9.8, so you should NOT let amsn download tcl-tls for you, once it downloads it, it will screw things up for you...  so delete the ~/.amsn/plugins/tls1.5 directory and install the ubuntu tcltls package and it should work... you said earlier that you also copied that directory to /usr/share/amsn, so make sure you delete it from there too if it's still in there!


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: AL3X2 on May 26, 2009, 09:03:42 pm
Oh!!! I made it!!!

1. sudo apt-get remove --purge tls tcl-tls

2. whereis tls  and rm -rf all the paths.

3. rm -rf .amsn/

4. sudo apt-get install amsn

5. shutdown virtualbox and annoying wlm 2009 ¬¬

6. Be very happy with amsn :D (L)

Thanks kjir, KaKaRoTo, Stemp ;)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on May 26, 2009, 09:26:45 pm
you're welcome.
Glad you fixed it


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on May 26, 2009, 09:59:36 pm
@kakaroto : do you think tcl-tls should be a dependency in the Ubuntu package ? When do we need it ?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on May 27, 2009, 01:29:03 am
It certainly should be! Isn't it already? we *ALWAYS* need it (otherwise, you can't connect or do anything...)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on May 27, 2009, 03:44:48 pm
Well tcl-tls is a dependency, I was tired ;)


Title: thx
Post by: stimpyjcat on June 01, 2009, 06:51:02 pm
thx for the repos :D

works fine except for the thing that dies after receiving a call from a wlm, still need to test against another amsn (maybe is just farsight fault too)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on June 01, 2009, 08:15:59 pm
Hi stimpyjcat, welcome to the forums..
if you're getting a segmentation fault somewhere, pleaseprovide us with the appropriate gdb backtrace as explained in the FAQ : http://amsn-project.net/wiki/FAQ#How_do_I_capture_bug_report_information_from_a_segmentation_fault.3F_.28LINUX.29


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: stimpyjcat on June 02, 2009, 12:25:27 am
Quote from: "kakaroto"
Hi stimpyjcat, welcome to the forums..
if you're getting a segmentation fault somewhere, pleaseprovide us with the appropriate gdb backtrace as explained in the FAQ : http://amsn-project.net/wiki/FAQ#How_do_I_capture_bug_report_information_from_a_segmentation_fault.3F_.28LINUX.29


oh, was a seg fault...

Code:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f22cc7a9950 (LWP 21911)]    
0x00007f22c2dd7cb1 in ?? () from /usr/lib/libnice.so.0
(gdb) bt                                              
#0  0x00007f22c2dd7cb1 in ?? () from /usr/lib/libnice.so.0
#1  0x00007f22d3aec97b in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f22d3aec20a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#3  0x00007f22d3aef8e0 in ?? () from /usr/lib/libglib-2.0.so.0                    
#4  0x00007f22d3aefdad in g_main_loop_run () from /usr/lib/libglib-2.0.so.0        
#5  0x00007f22c2ffada1 in ?? () from /usr/lib/farsight2-0.0/libnice-transmitter.so
#6  0x00007f22d3b15ae4 in ?? () from /usr/lib/libglib-2.0.so.0                    
#7  0x00007f22d94ee3ba in start_thread () from /lib/libpthread.so.0                
#8  0x00007f22d7bc5fcd in clone () from /lib/libc.so.6                            
#9  0x0000000000000000 in ?? ()


Code:
(gdb) bt full
#0  0x00007f22c2dd7cb1 in ?? () from /usr/lib/libnice.so.0
No symbol table info available.
#1  0x00007f22d3aec97b in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#2  0x00007f22d3aec20a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x00007f22d3aef8e0 in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x00007f22d3aefdad in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#5  0x00007f22c2ffada1 in ?? () from /usr/lib/farsight2-0.0/libnice-transmitter.so
No symbol table info available.
#6  0x00007f22d3b15ae4 in ?? () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#7  0x00007f22d94ee3ba in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#8  0x00007f22d7bc5fcd in clone () from /lib/libc.so.6
No symbol table info available.
#9  0x0000000000000000 in ?? ()
No symbol table info available.


and if helps, dmesg says
Code:
[130198.831887] wish8.5[21449]: segfault at 7f7d6ecac010 ip 00007f7d64fddcb1 sp 00007f7d6e8baf10 error 4 in libnice.so.0.4.0[7f7d64fd4000+21000]



that happens like 5 minutes after the wlm started the call, amsn is running on a kubuntu jaunty 64 with the farsight from the repos (libfarsight0.1-3)


well, this happens when amsn starts the call with a wlm, the call finish after 10 seconds or so with no segmentation faults (cant hear anything in amsn, and just noise in wlm)
Code:
Sonando WAVE '/usr/share/amsn/skins/default/sounds/ring.wav' : Signed 16 bit Little Endian, Ratio 44100 Hz, Mono                                                          
(no debugging symbols found)                                                        
(no debugging symbols found)                                                        
(no debugging symbols found)                                                        
[New Thread 0x7f2c1621c950 (LWP 25370)]  <--- here starts the call                                    
[New Thread 0x7f2c15a1b950 (LWP 25371)]                                              
(no debugging symbols found)                                                        
[Thread 0x7f2c170b1950 (LWP 25367) exited] <---here auto finish                                          
[Thread 0x7f2c180b3950 (LWP 25365) exited]
[Thread 0x7f2c0ea53950 (LWP 25358) exited]
[Thread 0x7f2c0da51950 (LWP 25359) exited]
[Thread 0x7f2c190fd950 (LWP 25362) exited]
[New Thread 0x7f2c190fd950 (LWP 25772)]
[Thread 0x7f2c190fd950 (LWP 25772) exited]
[New Thread 0x7f2c190fd950 (LWP 25773)]
[Thread 0x7f2c190fd950 (LWP 25773) exited]
[Thread 0x7f2c15a1b950 (LWP 25371) exited]
[Thread 0x7f2c188b4950 (LWP 25364) exited]
[Thread 0x7f2c0c794950 (LWP 25363) exited]
[Thread 0x7f2c178b2950 (LWP 25366) exited]
[Thread 0x7f2c1621c950 (LWP 25370) exited]
[Thread 0x7f2c1c18c950 (LWP 25361) exited]


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on June 03, 2009, 07:41:29 am
ouch, that's interesting.. unfortunately, you have no debugging symbols for libnice or farsight :(
Do you think you can compile farsight2 and libnice yourself with debugging symbols enabled so i can see what this bug actually is so i can fix it ?
however, my guess is that the version you have is very old and the bug was fixed already... make sure you have libnice 0.0.6 which is the latest stable one!


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on June 03, 2009, 12:12:17 pm
I just uploaded a new source package for libnice with a debug symbols package libnice0-dbg.
There is already a -dbg for farsight2 libgstfarsight0.10-dbg.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on June 03, 2009, 06:56:00 pm
great, thanks Stemp!


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: stimpyjcat on June 05, 2009, 05:38:13 pm
good, i will see what can do during the weekend ^^

the sound problems looks like is on other part of the system, cos i have tried another voice chat soft (empathy with gmail) with the same effect when calling from the machine with amsn (maybe is gstreamer or the sound driver)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on June 12, 2009, 01:37:42 am
libnice 0.0.7 has been released.. I don't know if it fixes your current issue, so could you just get me the gdb backtrace with what you currently have now that Stemp uploaded debug symbols ?
thanks


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: stimpyjcat on June 14, 2009, 06:43:16 am
Quote from: "kakaroto"
libnice 0.0.7 has been released.. I don't know if it fixes your current issue, so could you just get me the gdb backtrace with what you currently have now that Stemp uploaded debug symbols ?
thanks
ok, got all the updates ( including kernel ) and all the debugging symbols

this time dont last a minute  :P  (calling from wlmsn to amsn)

bt
Code:
[Thread 0x7ff68ef91950 (LWP 31771) exited]                                          

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ff6a851b950 (LWP 31752)]    
priv_turn_allocate_refresh_retransmissions_tick (pointer=0x7ff6a5c87010)
    at conncheck.c:741                                                  
741     conncheck.c: No such file or directory.                        
        in conncheck.c                                                  
(gdb) bt                                                                
#0  priv_turn_allocate_refresh_retransmissions_tick (pointer=0x7ff6a5c87010)
    at conncheck.c:741                                                      
#1  0x00007ff6af7c097b in g_timeout_dispatch (source=0x443a5a0, callback=0x24000,
    user_data=0x7ff6a5ca7000) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:3253  
#2  0x00007ff6af7c020a in IA__g_main_context_dispatch (context=0x2ab3210)        
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814                            
#3  0x00007ff6af7c38e0 in g_main_context_iterate (context=0x2ab3210, block=1,    
    dispatch=1, self=<value optimized out>)                                      
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448                            
#4  0x00007ff6af7c3dad in IA__g_main_loop_run (loop=0x3e551a0)                    
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2656                            
#5  0x00007ff69ecccda1 in fs_nice_agent_main_thread (data=0x28a98c0)              
    at fs-nice-agent.c:315                                                        
#6  0x00007ff6af7e9ae4 in g_thread_create_proxy (data=0x3e546e0)                  
    at /build/buildd/glib2.0-2.20.1/glib/gthread.c:635                            
#7  0x00007ff6b51c33ba in start_thread (arg=<value optimized out>)                
    at pthread_create.c:297                                                      
#8  0x00007ff6b389afcd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112                            
#9  0x0000000000000000 in ?? ()    


bt full

Code:
#0  priv_turn_allocate_refresh_retransmissions_tick (pointer=0x7ff6a5c87010)      
    at conncheck.c:741                                                            
No locals.                                                                        
#1  0x00007ff6af7c097b in g_timeout_dispatch (source=0x443a5a0, callback=0x24000,  
    user_data=0x7ff6a5ca7000) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:3253    
No locals.                                                                        
#2  0x00007ff6af7c020a in IA__g_main_context_dispatch (context=0x2ab3210)          
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814                              
No locals.                                                                        
#3  0x00007ff6af7c38e0 in g_main_context_iterate (context=0x2ab3210, block=1,      
    dispatch=1, self=<value optimized out>)                                        
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448                              
        max_priority = 2147483647                                                  
        timeout = 3231                                                            
        some_ready = 1                                                            
        nfds = 1                                                                  
        allocated_nfds = <value optimized out>                                    
        fds = (GPollFD *) 0x3e54730                                                
        __PRETTY_FUNCTION__ = "g_main_context_iterate"                            
#4  0x00007ff6af7c3dad in IA__g_main_loop_run (loop=0x3e551a0)                    
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2656                              
        self = (GThread *) 0x3e546e0                                              
        __PRETTY_FUNCTION__ = "IA__g_main_loop_run"                                
#5  0x00007ff69ecccda1 in fs_nice_agent_main_thread (data=0x28a98c0)              
    at fs-nice-agent.c:315                                                        
No locals.                                                                        
#6  0x00007ff6af7e9ae4 in g_thread_create_proxy (data=0x3e546e0)
    at /build/buildd/glib2.0-2.20.1/glib/gthread.c:635
        __PRETTY_FUNCTION__ = "g_thread_create_proxy"
#7  0x00007ff6b51c33ba in start_thread (arg=<value optimized out>)
    at pthread_create.c:297
        __res = <value optimized out>
        pd = (struct pthread *) 0x7ff6a851b950
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {0, -739566533635011961,
        8392704, 0, 140697588297792, 140736377210304, 743613477367253639,
        743624038779783815}, mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0,
      0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        robust = <value optimized out>
#8  0x00007ff6b389afcd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
No locals.
#9  0x0000000000000000 in ?? ()
No symbol table info available.


thanks in advance ^^

ps: i have a lot of options with farsight at the video configuration window (one of the latest in the wizard) will try to play with that too


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on June 18, 2009, 03:36:12 am
Ah, thanks stimpycat!
I just saw your post, I guess I missed it before, sorry!
Thanks for the backtrace! Yep, indeed, that's a new bug in libnice! Somehow it looks like the TURN server doesn't refresh the allocations correctly... I wonder why... One possibility is that the UDP refresh messages get lost if you are receiving/sending too much data for your bandwidth!
I'd really like to know how it happens exactly... does the sound work correctly for 5 minutes and then it crashes ? or is it different ?
In any case, the next release should fix it.. I had already changed a few things in the last couple of days that coincidently fix this same bug, so you should be fine with the current git... I'd like to test it a little bit more and hopefully release 0.0.8 sometime this week!
Thanks!


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on June 20, 2009, 12:13:29 am
@stimpycat: libnice 0.0.8 has just been released! If you update to it, it shouldn't crash anymore...
@Stemp: could you update the repository with libnice 0.0.8? thanks!


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on June 20, 2009, 10:21:39 am
Quote from: "kakaroto"
@Stemp: could you update the repository with libnice 0.0.8? thanks!


Done  :wink:


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: flomar34 on June 20, 2009, 10:46:35 am
Hi,

Thanks Stemp.

kakaroto: With the last update (last svn and libnice 0.0.8 ) i have an error message when y want to try farsight

Code:
can't read "fsaudiosrcs": no such variable
    while executing
"set srcs $fsaudiosrcs"
    (procedure "::AVAssistant::StepFarsightClBk" line 62)
    invoked from within
"::AVAssistant::StepFarsightClBk .assistant1 .assistant1.bodyf.contentf 1 1"
    ("eval" body line 1)
    invoked from within
"eval [linsert $callbk end 1]"
    (procedure "::MSNSIP::FarsightTestSucceeded" line 31)
    invoked from within
"::MSNSIP::FarsightTestSucceeded {::AVAssistant::StepFarsightClBk .assistant1 .assistant1.bodyf.contentf 1}"
    ("eval" body line 1)
    invoked from within
"eval $options(-prepared)"


Hope it helps


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on June 20, 2009, 06:04:08 pm
cool, thanks Stemp for your fast work!
flomar34, the assistant is being worked on... don't use the assistant for now, just make the call from the chat window!


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on June 26, 2009, 07:56:07 pm
alright, the assistant should be fixed now.. it's not functional, but at least it won't bug on you...


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Kreuger on August 12, 2009, 10:26:46 pm
Today there was an update available and I had trouble installing the lib of libgupnp-igd-1.0.2 so I removed it from /usr/lib (because it said it wouldnt overwrite it) and now when I run amsn it gives me an error about TkCxImage because it cant load  libgupnp-igd-1.0.2 in /utils/TkCxImage. I tried a whereis and got this:

Quote
kreuger@kreuger-desktop:~/Desktop$ whereis  libgupnp-igd-1.0.2
libgupnp-igd-1.0: /usr/lib/libgupnp-igd-1.0.la /usr/lib/libgupnp-igd-1.0.a /usr/lib/libgupnp-igd-1.0.so


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on August 13, 2009, 04:37:11 am
Kreuger.. recompile amsn.. I think that amsn should be compiled with the flag --as-needed to gcc, this way it won't link TkCximage to the libgupnp-igd library since it doesn't need it...
We hope to finally fix our makefiles in the future so that libraries only get linked against what they really need...


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Kreuger on August 13, 2009, 05:53:43 am
Yeah I removed it and just grabbed the svn tar off the website. It's weird though because for the longest time Ive had no trouble with this repo


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on August 13, 2009, 07:19:41 am
Quote from: "Kreuger"
Yeah I removed it and just grabbed the svn tar off the website. It's weird though because for the longest time Ive had no trouble with this repo


What is exactly your problem with the repo ? gupnp-igd wasn't updated since june.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on August 13, 2009, 08:44:00 am
maybe gupnp-igd was updated in the official repositories...


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on August 13, 2009, 09:30:22 am
gupnp-igd only exist in Karmic (the development version of Ubuntu), it's not in Jaunty.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on August 13, 2009, 06:34:20 pm
on debian unstable :
Quote
kakaroto# apt-cache policy libgupnp-igd-1.0-2
libgupnp-igd-1.0-2:
  Installed: (none)
  Candidate: 0.1.3-2
  Version table:
     0.1.3-2 0
        500 http://ftp.ca.debian.org unstable/main Packages


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: stimpyjcat on August 14, 2009, 12:49:23 am
sorry for the very late answer...

well, after a windows chaos, when managed to make all the system to work fine, when tried again couldnt get the same error anymore (seg fault after 5 minutes of chat calling from wlm to amsn), now both messengers close the call after few seconds without any error from the amsn

i might need to reconfigure some of the audio call related packages but cant remember all the package names (libnice, farsight and others)


OT:
why all the msn open projects dont make a common custom implementation of audio calls to use between free msn clients? (that will turn the cake for m$ as we say around here ^^)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on August 14, 2009, 01:39:47 am
Humm.. if you are able to reproduce your segmentation fault, please provide us with a gdb backtrace so I can fix the crash!
About the common implementation of audio calls, yes, that's farsight 2 using libnice... but anyways, M$ already decided to use a RFC standard protocol for audio calls which is compatible with any other audio implementation, they also added specific stuff for third party client for interoperability, so I don't think that any "cake would turn over on them" :p


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Kreuger on August 16, 2009, 04:43:07 pm
Quote
gupnp-igd only exist in Karmic (the development version of Ubuntu), it's not in Jaunty.
I'm using Jaunty on this machine so I don't know why there was an update but there was and it made a problem for me. I just wanted to report that it seemed to break through this repo and that I was able to recompile the svn by hand fine.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: stimpyjcat on August 23, 2009, 10:33:39 am
Quote from: "kakaroto"
Humm.. if you are able to reproduce your segmentation fault, please provide us with a gdb backtrace so I can fix the crash!
Im trying to get a segmentation fault but the calls closes without any error using gdb

Ill try switching systems and installing win on the notebook (oooh the paaaain :cry: ) to test again in a not-so-frankestein-like-ubuntu

*starts digging for win drivers*


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on August 23, 2009, 08:57:49 pm
hummm.. if it closes without a segmentation fault then what is it ? does it report somehing like an "Abort"? any error shown on the console ?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: stimpyjcat on August 29, 2009, 03:06:36 pm
Quote from: "kakaroto"
hummm.. if it closes without a segmentation fault then what is it ? does it report somehing like an "Abort"? any error shown on the console ?
was the audio device :S (the sink is the one that kills the call)

now, when calling from amsn (using hal) to wlmsn, got a poor quality (on the amsn side) but the connection remains. If call from wlmsn the quality is lot better at first but sometimes gets muted (or sounds really bad) after a couple of minutes (could be the audio device too or farsight). And still got problems with amsn, it gets muted with no reason (error or anything, could be the device again... or farsight)

Im going to test again with different device (pulse, oss and others) and with amsn against amsn (after finding the correct devices), if something goes wrong you will see me yelling around here  :lol:  (if everything goes well too, but louder :P )


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on October 21, 2009, 12:35:50 pm
aMSN 0.98.1 is ready for Karmic in the PPA.

But.... there is probably some installation/upgrade problems (that's why it's only for Karmic for now).

Could you please test the installation and the upgrade using apt-get or aptitude ?

Thanks


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on October 21, 2009, 10:39:12 pm
Thanks for your help, I had not a single feedback. So I guess I'm doing this PPA for nothing.

Anyway 0.98.1 is ready for Jaunty.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: kakaroto on October 22, 2009, 09:38:21 am
hehe, no, it's not for nothing.. I recently stickied your thread and we often tell people to use your PPA! it's very helpful thanks :)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: wild_oscar on October 23, 2009, 03:17:42 pm
Indeed, it is not for nothing.

I am using it myself. I had a problem yesterday - an ubuntu upgrade broke your PPA packge and amsn was removed (and only version 0.97 was available), but it seems it is now back to normal and I'm using your repository again!


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: apostolos_ on November 01, 2009, 11:30:12 am
Hey i installed amsn using ppa repositories...but when i try to start a voice or a video call it says it needs farsight2....But i saw farsight2 in the repositories....something i must do?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on November 01, 2009, 11:42:58 am
Quote from: "apostolos_"
Hey i installed amsn using ppa repositories...but when i try to start a voice or a video call it says it needs farsight2....But i saw farsight2 in the repositories....something i must do?


Karmic, Jaunty, Intrepid ?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: apostolos_ on November 01, 2009, 12:26:00 pm
lol...sorry my fault interpid!!


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on November 01, 2009, 12:56:48 pm
If it's Intrepid indeed there could be some problems.

Could you check if farsight2 package is really installed ?

Code:
apt-cache policy libgstfarsight0.10-0


The fact is I only backported farsight2 0.0.9, so amsn 0.98.1 could be compiled. But I didn't backported the entire gstreamer framework.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: apostolos_ on November 01, 2009, 02:20:39 pm
Installed: 0.0.9-1~iiamsn5
  To be installed(it says something here but its in greek so don't know how they say it in english...): 0.0.9-1~iiamsn5
 Version Table(still  this is my translation):
 *** 0.0.9-1~iiamsn5 0
        500 http://ppa.launchpad.net intrepid/main Packages
        100 /var/lib/dpkg/status
     0.0.2-1 0
        500 http://gr.archive.ubuntu.com intrepid/universe Packages


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on November 01, 2009, 03:53:53 pm
Quote from: "apostolos_"
Installed: 0.0.9-1~iiamsn5
  To be installed(it says something here but its in greek so don't know how they say it in english...): 0.0.9-1~iiamsn5


Strange ! if farsight2 is installed I don't understand why aMsn is complaining.

When you set your audio/video preferences there is no problems ? no messages ?

PS : BTW the english translation is candidate ;)
Little tip try LANG=C command eg :
Code:
LANG=C apt-cache policy libgstfarsight0.10-0


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: apostolos_ on November 01, 2009, 04:28:46 pm
arsight : Preparing
Farsight debug : Error: Error while creating new audio_session (1): Could not create the valve element
Farsight Prepare error :
from the audio video settings


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: apostolos_ on November 01, 2009, 04:45:07 pm
maybe needs a newer version ....i dont know...based on this http://www.amsn-project.net/wiki/Farsight could it be the priviledges?cause i run it as plain user


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on November 01, 2009, 04:54:22 pm
it's not privileges, it's a problem with valve element.

Do you have the gstreamer0.10-plugins-good package ? What version ?

Code:
apt-cache policy gstreamer0.10-plugins-good


If you have it, do you have the valve library in it ?

Code:
dpkg -L gstreamer0.10-plugins-good  | grep valve


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: apostolos_ on November 01, 2009, 04:59:33 pm
gstreamer0.10-plugins-good:
  Installed: 0.10.10.4-1ubuntu1.2
  Candidate: 0.10.10.4-1ubuntu1.2
  Version table:
 *** 0.10.10.4-1ubuntu1.2 0
        500 http://gr.archive.ubuntu.com intrepid-updates/main Packages
        500 http://security.ubuntu.com intrepid-security/main Packages
        100 /var/lib/dpkg/status
     0.10.10.4-1ubuntu1 0
        500 http://gr.archive.ubuntu.com intrepid/main Packages

dpkg -L gstreamer0.10-plugins-good  | grep valve returns nothing


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on November 01, 2009, 05:23:44 pm
:( Bad bad, related to http://www.amsn-project.net/forums/viewtopic.php?t=6425

libvalve was removed from farsight2 in version 0.0.9 and moved in gstreamer0.10-plugins-good. But your version is too old.

NOPE ***** If you're not scared to break everything you could try the PPA for next-media (http://launchpad.net/~next-media/+archive/ppa/+packages) (Don't add this PPA just install the plugins-good package). **** Too old :(

If it's possible I will try to update the aMSN PPA version (but the PPA creation is currently very very slow).


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: apostolos_ on November 01, 2009, 05:34:32 pm
gstreamer0.10-plugins-good-dbg_0.10.13-2~intrepid1_i386.deb  this package?What would be the consequences...and how do i roll back from this?

according to amsn wiki it needs gstreamer plugins-good 0.10.15 or newer....where can i find them?


found them herehttp://gstreamer.freedesktop.org/src/gst-plugins-good/ downloaded the 0.10.16 but no deb package....guess needs to be compiled...right?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on November 01, 2009, 05:40:42 pm
Quote from: "apostolos_"
gstreamer0.10-plugins-good-dbg_0.10.13-2~intrepid1_i386.deb  this package?What would be the consequences...and how do i roll back from this?

Too old, I edited my message :(

Quote from: "apostolos_"
according to amsn wiki it needs gstreamer plugins-good 0.10.15 or newer....where can i find them?

I don't know, I guess I will have to try to build it.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on November 01, 2009, 08:24:30 pm
Quote from: "apostolos_"
found them herehttp://gstreamer.freedesktop.org/src/gst-plugins-good/ downloaded the 0.10.16 but no deb package....guess needs to be compiled...right?


Or you could try the karmic package : http://launchpad.net/ubuntu/karmic/+source/gst-plugins-good0.10/0.10.15-2ubuntu1

But I don't know if it's possible to install it (dependencies). BTW why are you still on Intrepid ?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: apostolos_ on November 01, 2009, 08:45:18 pm
2 reasons....have to make backup for a fresh installl but need to remember what progs i had....and second ati graphics....X1200 for 3d...you think i ll need properiarity?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on November 01, 2009, 09:07:13 pm
Quote from: "apostolos_"
2 reasons....have to make backup for a fresh installl but need to remember what progs i had....and second ati graphics....X1200 for 3d...you think i ll need properiarity?


1° : http://www.110mb.com/forum/how-to-on-ubuntu-save-the-package-list-and-use-it-to-reinstall-packages-later-t22332.0.html by example

2° : from RadeonXpress doc (https://help.ubuntu.com/community/RadeonXpress) : Since Ubuntu 8.10 3D and desktop effects works out of the box with the open source -ati driver.  But you should try with the a live-cd ;)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: apostolos_ on November 01, 2009, 09:43:30 pm
the thing is that if you have a system that works i have the opinion not to change ....but i really like ubuntu 9.10! oh and i liked your links...and i think you can have the "packagelst" graphically through synaptic right?i am on a plain user account so cant check it


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on November 01, 2009, 09:56:42 pm
Quote from: "apostolos_"
and i think you can have the "packagelst" graphically through synaptic right?i am on a plain user account so cant check it


Yep it's also possible ;)


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: apostolos_ on November 02, 2009, 04:52:22 am
so back on topic....can it work for interpid or not?What do u think?


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on November 02, 2009, 10:30:35 am
Quote from: "apostolos_"
so back on topic....can it work for interpid or not?What do u think?


No, I don't think so.


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: apostolos_ on November 02, 2009, 12:13:27 pm
lol....now i see your plan...trying to make everyone install karmic....lol.....!!!!just kidding


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on November 02, 2009, 12:30:58 pm
Quote from: "apostolos_"
lol....now i see your plan...trying to make everyone install karmic....lol.....!!!!just kidding


Yes I got a percentage on every sale, don't forget to give your promotional code : aMSNPPA  :twisted:

In fact I cannot create a gstreamer-plugins-good package for Intrepid, it needs gstreamer >= 0.10.23, and gstreamer need .... endless


Title: Installing Amsn svn : A repository for Ubuntu users
Post by: apostolos_ on November 02, 2009, 01:33:02 pm
lol no problem man....thank you for your time explaining


Title: Re: Installing Amsn svn : A repository for Ubuntu users
Post by: Bocko on April 08, 2010, 10:01:09 am
Just a little question: is there any plan on keeping this PPA alive?
I was just wondering, since the latest build dates from several weeks ago while the SVN is constantly updated...


Title: Re: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on April 10, 2010, 07:56:47 pm
Just a little question: is there any plan on keeping this PPA alive?
I was just wondering, since the latest build dates from several weeks ago while the SVN is constantly updated...

Well, I'm not on Ubuntu anymore and I never really used aMSN.
So if someone want a new version, just ask because I will not do it on regular basis  ;)


Title: Re: Installing Amsn svn : A repository for Ubuntu users
Post by: Bocko on April 12, 2010, 08:51:31 am
Well, I was just asking since it is handy to have auto-update with the repo. Anyway, I can recompile the source myself so you don't really have to build a newer version unless other people ask...


Title: Re: Installing Amsn svn : A repository for Ubuntu users
Post by: bouriquo on April 28, 2010, 10:03:51 pm
And for lucid ? it's the same ?


Title: Re: Installing Amsn svn : A repository for Ubuntu users
Post by: alexandernst on April 29, 2010, 06:03:14 pm
AFAIK this repo isn't maintained anymore, so you'll have to do it the svn way.


Title: Re: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on August 28, 2010, 06:19:17 pm
Well the repo is back on track using the new recipe system from Launchpad.
So it should be updated automatically.
BUT, I don't use Ubuntu anymore so I can't test the packages.

I'll try to do the same for the extra-plugins.


Title: Re: Installing Amsn svn : A repository for Ubuntu users
Post by: nogueira13 on November 17, 2010, 03:22:57 am
I am running Ubuntu 10.10 (Maverik Maarket) and I would like to know if I can add the line: "deb http://ppa.launchpad.net/amsn-daily/ppa/ubuntu maverik main", just changing the word jaunty by maverik in the sources.list, but using the gui synaptic instead of editing the sources.list file. I did it going to Settings --> Repository and adding this line in "other software" by clicking on the "add" tab. I am afraid that I could to damage my sources.list file. Another thing I didn't understand is how "I add the key as explain on the launchpad" (in which launchpad? I didn't understand it). I beg your perdon for my poor English. Thanks in advance.


Title: Re: Installing Amsn svn : A repository for Ubuntu users
Post by: Stemp on November 18, 2010, 11:12:43 pm
Code:
sudo add-apt-repository ppa:amsn-daily

Will add the ppa and the key.
If you want just the key :

Code:
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 28CBC482