aMSN Forums

aMSN Support => Linux => Topic started by: Jean_ on March 27, 2008, 08:21:16 pm



Title: amsn can't find snack SOLVED
Post by: Jean_ on March 27, 2008, 08:21:16 pm
Hi,

Well, any suggestions? I'm using ubuntu 7.10, amsn 098b, compiled snack library with -alsa and tried /lib /usr/lib and /usr/share/amsn/utils/ for destiantions but still amsn can't find snack it seems and I'm out of steam. :)

Greets.


Title: amsn can't find snack SOLVED
Post by: trv on March 27, 2008, 08:56:53 pm
why did you compile snack and not install libsnack library from the repositories? it's there....

well, in some time you wont be needing it at all... Q)


Title: amsn can't find snack SOLVED
Post by: Jean_ on March 28, 2008, 09:16:58 am
Quote from: "trv"
why did you compile snack and not install libsnack library from the repositories? it's there....


I did but it didn't work either and I read on this forum that .deb is compiled without -alsa

Quote
well, in some time you wont be needing it at all... Q)


Microphone working would be great. It still puzzles me why amsn can't find the snack stuff.


Title: amsn can't find snack SOLVED
Post by: setzer on March 28, 2008, 02:59:43 pm
Maybe there's something that you missed with the compilation... could you try to instal libsnack with apt?


Title: amsn can't find snack SOLVED
Post by: Jean_ on March 28, 2008, 08:24:06 pm
Quote from: "setzer"
Maybe there's something that you missed with the compilation... could you try to instal libsnack with apt?


Thanks , but like I said, i did try the deb, it didn't work either.


Title: amsn can't find snack SOLVED
Post by: kakaroto on March 28, 2008, 08:55:43 pm
try with and without alsa support, 50% of users report it works only with --enable-alsa and 50% report it only works with --disable-alsa...
we're working on a new solution to avoid those issues...


Title: amsn can't find snack SOLVED
Post by: Jean_ on March 29, 2008, 08:37:38 am
Thanks, just tried the --disable-alsa switch, same result, amsn can't find the lib.

If amsn is just checking if files exist on a certain location, normally a compiler switch wouldn't make much difference me thinks, but it was worth the try.

Quote from: "kakaroto"
try with and without alsa support, 50% of users report it works only with --enable-alsa and 50% report it only works with --disable-alsa...
we're working on a new solution to avoid those issues...


Title: amsn can't find snack SOLVED
Post by: kakaroto on March 29, 2008, 07:16:21 pm
oh, I thought it was 'not working' not that amsn couldn't find it... if it can't find it, then make sure you have the install snack directory in your /usr/lib and /usr/local/lib (especially if using tcl/tk 8.5)
the snack directory must contain a pkgIndex.tcl file and the .so files that should come with it...


Title: amsn can't find snack SOLVED
Post by: Jean_ on March 30, 2008, 09:26:01 am
Thanks, now I know what to look for.
Both /usr/lib and /usr/local/lib now contain a snack map with the pkgIndex.tcl file and the .so files.
The map was called snack.2.2.10, tried renaming it to snack.2.2
Amsn still can't find things, says 'looking for snack' then show a cross X, meaning it can't find it.

Should I try compile again with the -enable-alsa switch? I'm getting a bit weary. :)

Greets.


Title: amsn can't find snack SOLVED
Post by: kakaroto on March 30, 2008, 09:16:49 pm
no, the best thing you can do now is two things :
open the amsn console by pressing ctrl-shit-C from the main window, the console will show up, in it type the two following commands and paste here the result :
Code:
set ::auto_path

and
Code:
package require snack

these two should give us a bit more info on what the problem really is.


Title: amsn can't find snack SOLVED
Post by: Jean_ on March 31, 2008, 08:39:23 am
Thanks again.

This is the output:

set ::auto_path
utils utils/linux /home/jean/.amsn/plugins /usr/local/tcltk8.5/lib/tcl8.5 /usr/local/tcltk8.5/lib /usr/local/tcltk8.5/lib/tk8.5 /usr/local/tcltk8.5/lib/tk8.5/ttk

package require snack
can't find package snack

Greets.


Title: amsn can't find snack SOLVED
Post by: trv on March 31, 2008, 12:47:29 pm
You have wrong paths... /usr/lib and /usr/lib/tcltk/ are at least is missing!

libsnack2 from ubuntu repositories gets installed in /usr/lib/tcltk/snack2.2/ by default.

This is the output of a correctly configured ubuntu system with tcl8.5, tk8.5 and libsnack2, all from the repositories:

(amsn) 1 % set ::auto_path
utils utils/linux /home/trv/.amsn/plugins /usr/share/tcltk/tcl8.5 /usr/lib /usr/lib/tcltk /usr/share/tcltk /usr/share/tcltk/tk8.5 /usr/share/tcltk/tk8.5/ttk

(amsn) 2 % package require snack
2.2


Title: amsn can't find snack SOLVED
Post by: kakaroto on March 31, 2008, 04:55:34 pm
ahh.. that explains it.. I supposed you compiled tcl/tk 8.5 and gave it --prefix /usr/local/tcltk8.5 which is why the auto_path is like that (the path to search for libraries.. like snack)..
What could fix your issue is simply :
Code:
ln -s /usr/lib/snack2.2 /usr/local/tcltk8.5/lib/snack2.2

(assuming /usr/lib/snack2.2 is the path where snack is installed on your system).
Curious though.. am I right? you compiled tcl/tk yourself with --prefix /usr/local/tcltk8.5 ?


Title: amsn can't find snack SOLVED
Post by: Jean_ on April 01, 2008, 06:58:55 am
It's working!

The link did the trick.
Quite a surprise as I was gotten so used to seeing 'can't find snack'.
This amsn was in fact compiled through a script I found here http://ubuntuforums.org/showthread.php?t=621441 to have drag and drop support which works btw. I had quite forgotten about it.
Thought it was kinda strange not seeing those maps in that path.

Thanks for your help guys. I got my microphone working now.

Jean.


Title: amsn can't find snack SOLVED
Post by: trv on April 01, 2008, 02:47:45 pm
well, those kind of scripts cause all sorts of problems... 90% of problems here are caused by those **** :/

There is no need for things like that now, everything is already available, including amsn.

If you want svn, then go svn for msn only, not tcl tk snack etc etc etc. You just mess up your system, everything is in non-default locations, and you have problems like these.

drag n drop support is as simple as creating a folder under /home/user/.amsn/utils/tkdnd and placing 3 files you will download there


Title: amsn can't find snack SOLVED
Post by: Jean_ on April 01, 2008, 05:25:27 pm
Quote from: "trv"
well, those kind of scripts cause all sorts of problems... 90% of problems here are caused by those **** :/


Hey, I didn't write that script. :)

But you are right , it's so easy to mess things up.

Quote
drag n drop support is as simple as creating a folder under /home/user/.amsn/utils/tkdnd and placing 3 files you will download there


I was gonna ask, which files. But I don't have a map utils there. lol

Greets.


Title: amsn can't find snack SOLVED
Post by: seenxu on April 30, 2008, 07:50:22 pm
in ubuntu 8.04, make sure I had installed the libsnack2

sudo find / -iname "*snack*"

find following path
/usr/lib/tcltk/snack2.2

then make two symbolic link to the library.
sudo ln -s /usr/lib/snack2.2 /usr/lib/tcltk/snack2.2/
sudo ln -s /usr/local/lib/snack2.2 /usr/lib/tcltk/snack2.2/

right now, in your preference->others, you can select "use the snack library (tck internal)" checkbox. restart amsn.

make sure, the "set ::autopath" output is the following.

Code:

/usr/lib/tls1.50 utils utils/linux /home/seen/.amsn/plugins /usr/local/lib/tcl8.5 /usr/local/lib /usr/local/lib/tk8.5 /usr/local/lib/tk8.5/ttk


and it shall work now.  :twisted:


Title: amsn can't find snack SOLVED
Post by: fitlad on August 10, 2008, 10:40:35 pm
Quote from: "seenxu"
in ubuntu 8.04, make sure I had installed the libsnack2

sudo find / -iname "*snack*"

find following path
/usr/lib/tcltk/snack2.2

then make two symbolic link to the library.
sudo ln -s /usr/lib/snack2.2 /usr/lib/tcltk/snack2.2/
sudo ln -s /usr/local/lib/snack2.2 /usr/lib/tcltk/snack2.2/

right now, in your preference->others, you can select "use the snack library (tck internal)" checkbox. restart amsn.

make sure, the "set ::autopath" output is the following.

Code:

/usr/lib/tls1.50 utils utils/linux /home/seen/.amsn/plugins /usr/local/lib/tcl8.5 /usr/local/lib /usr/local/lib/tk8.5 /usr/local/lib/tk8.5/ttk


and it shall work now.  :twisted:


My linux box is running fedora core 9 and I've installed amsn 0.97. When I tried to setup my microphone, an error message was displayed stating that snack cannot be loaded. I made a symbolic link to the library however the error has not been resolved!!!

Code:
(amsn) 1 % set ::auto_path
utils utils/linux /home/fitlad/.amsn/plugins /usr/share/tcl8.5 /usr/lib/tcl8.5 /usr/lib/tk8.5 /usr/share/tk8.5 /usr/share/tk8.5/ttk /usr/share/tcl8.5/tcllib-1.10
(amsn) 2 % package require snack
can't find package snack


Code:
[root@Shell fitlad]# ln -s /usr/lib/snack2.2.10 /usr/lib/tcl8.5/snack2.2.10


Code:
(amsn) 3 % package require snack
couldn't load file "/usr/lib/tcl8.5/snack2.2.10/libsnack.so": /usr/lib/tcl8.5/snack2.2.10/libsnack.so: symbol _snd_pcm_mmap_hw_ptr, version ALSA_0.9 not defined in file libasound.so.2 with link time reference


Can anyone help me to load snack with my amsn please? I cannot figure out what is the root cause of the problem. Thanks


Title: amsn can't find snack SOLVED
Post by: Phil on August 11, 2008, 08:22:23 pm
You must recompile snack on your computer.


Title: amsn can't find snack SOLVED
Post by: fitlad on August 11, 2008, 08:58:37 pm
Quote from: "Phil"
You must recompile snack on your computer.


How can I recompile snack from source? I downloaded the original snack package but it contains neither make nor configure file to install this software! I don't know what I shall do!   :cry:


Title: amsn can't find snack SOLVED
Post by: Phil on August 11, 2008, 09:18:10 pm
./unix/configure --enable-alsa
You can specify some other options


Title: amsn can't find snack SOLVED
Post by: fitlad on August 11, 2008, 09:28:57 pm
Quote from: "Phil"
./unix/configure --enable-alsa
You can specify some other options


I followed your instruction but I got this error
Code:
[root@Shell fitlad]# cd /usr/lib/snack2.2.10
[root@Shell snack2.2.10]# ./unix/configure --enable-alsa
bash: ./unix/configure: No such file or directory


Please help me.


Title: amsn can't find snack SOLVED
Post by: Phil on August 11, 2008, 09:32:29 pm
No you must do that in the source directory of snack
Not in your binary tree
If you plan to install it in /usr/lib don't forget --prefix=/usr


Title: amsn can't find snack SOLVED
Post by: fitlad on August 11, 2008, 09:37:09 pm
Quote from: "Phil"
No you must do that in the source directory of snack
Not in your binary tree
If you plan to install it in /usr/lib don't forget --prefix=/usr


I tried to recompile snack in the source directory but it didn't work too!
Code:
[root@Shell snack2.2.10]# cd /home/fitlad/Download/snack2.2
[root@Shell snack2.2]# ./unix/configure --enable-alsa
bash: ./unix/configure: No such file or directory


What do I do?


Title: amsn can't find snack SOLVED
Post by: Phil on August 11, 2008, 10:03:07 pm
Are you sure that's a source package ?


Title: amsn can't find snack SOLVED
Post by: fitlad on August 12, 2008, 12:01:53 am
Quote from: "Phil"
Are you sure that's a source package ?


I believe I downloaded the wrong package; I got the linux binary package instead of the source package
http://www.speech.kth.se/snack/dist/snack2.2.10-linux.tar.gz
So, I visited snack web page and downloaded the proper source code
http://www.speech.kth.se/snack/dist/snack2.2.10.tar.gz

then I went to terminal and typed the following codes:
Code:
[root@Shell fitlad]# cd /home/fitlad/Download/snack2.2.10/unix
[root@Shell unix]# ./configure --enable-alsa --with-tcl=/usr/lib --with-tk=/usr/lib
checking for Tcl configuration... configure: error: /usr/lib directory doesn't contain tclConfig.sh


I searched my linux box for "tclConfig.sh" but I couldn't find it. What shall I do?


Title: amsn can't find snack SOLVED
Post by: trv on August 12, 2008, 09:47:24 am
do you have tcl and tk installed?

you can use --with-tcl=/usr/lib/tcl8.5 and --with-tk=/usr/lib/tk8.5   (your tclConfig.sh will be inside tcl8.5 directory if you have tcl8.5 installed)


Title: amsn can't find snack SOLVED
Post by: Phil on August 12, 2008, 03:50:33 pm
You must install tcl-devel and tk-devel packages.
Then, maybe you will have to use trv trick (can't remember).


Title: amsn can't find snack SOLVED
Post by: trv on August 12, 2008, 06:21:17 pm
The truth is that you must install tcl8.5-dev and tk8.5-dev packages. Then you have to use the trick i mentioned earlier.

The tcl-dev package gives tou a tclConfig.sh file in /usr/lib BUT it installs tcl8.4-dev and it's that file there.. You don't want that. Just install tcl8.5-dev and adjust the configure script like i said.


Title: amsn can't find snack SOLVED
Post by: Phil on August 12, 2008, 10:05:21 pm
I was giving him the packages name for Fedora 9 ;)