aMSN Forums

aMSN Support => Linux => Topic started by: Marvelous on January 30, 2006, 08:42:09 am



Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Marvelous on January 30, 2006, 08:42:09 am
Hello i am having a problem with arabic fonts..
UBUNTU 5.10 Breezy
AMSN 0.96b

In ubuntu i can view and type in arabic without a problems.. works fine using gaim as well.
But in amsn arabic fonts are not visible.. sending them can be viewed by recipents but i cant see arabic fonts at all.

Any help would be highly appriciated.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on January 30, 2006, 05:23:24 pm
Change your encoding and fonts for aMSN (Tools -> Preferences -> Appearance).


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: snipe2004 on January 30, 2006, 06:29:18 pm
I've got a similar problem : when contacts use in their nicks arabic letters, I can't see them, the only thing I see is for example [\ufea8b\ufe8b]. But I don't use Arab as language in my conversations. Is it possible to change to an encoding with both latin and arab letters ?Wich one must I choose?


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on January 30, 2006, 10:37:10 pm
UTF-8 is a safe choice. :)


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: snipe2004 on February 02, 2006, 10:14:49 pm
I've got a problem with UTF-8:
the "é" and many special letters are not displayed in the correct way.
Must I come back to "default" in place of UTF-8, and I won't read arab, or is there another encoding that I can use with more success?
Tx


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on February 02, 2006, 11:36:38 pm
?????? utf-8 should work correctly with everything! Unless your font is problematic (so try another font)


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Med on February 03, 2006, 01:18:48 pm
Launch aMsn within a console like this :
Code:
LANG=ISO-8859-15 amsn


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on February 03, 2006, 01:24:20 pm
No, I don't think this will help...

snipe2004: How do accented characters appear? Can you paste an example?


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Med on February 03, 2006, 01:57:31 pm
Well, not an offence, but this is the only to make it work properly for me.
Otherwise accented characters looks like a square and a ~ .

Edit : works with contacts in french. Maybe if you adapt with the arabic font code it will be ok.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on February 03, 2006, 07:13:56 pm
I don't know, UTF-8 should be working correctly for everything (This is what it's designed for!). I am using it myself and can see accented characters / Greek / Japanese / Arabic / Korean without any problems (but I don't know arabic to tell if it's really displayed rtl lol). The only thing I can think about is: 1) deficient utf-8 installation in your system 2) deficient font installed in your system. Try a M$ font to see if it works...


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: TheOne on April 08, 2006, 04:58:52 pm
hi all

i have the same problem

i try it on Mandrake 2006 & SuSE 10 & now on Ubuntu 5.10..... with latest ams CVS and/or precompiled

all the programs work perfectly including xchat and all IM's , but aMSN is the only which cant see arabic! all the fonts included and even i added extras and MS TrueType. but hopless.
Note: i tryed all fonts & encodings

Automatic
cp 1256
iso8859-6
utf-8

the only thing work is to change the font type but that only will show u the charectors but in Revers direction. LFT (Left To Rright).
so the problem is with amsn for sure.

anyone can help !?


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: snipe2004 on April 08, 2006, 06:17:01 pm
Sorry, I didn't followed this post after my post :oops:

(http://upload4.postimage.org/154586/ScreenshotUTF.jpg) (http://upload4.postimage.org/154586/photo_hosting.html)

So this is what I get when I use UTF8: Arabic fonts are not displayed (still /u06dc for example) and lok the title bar, it's crazy...
And I've just installed everything about fonts from my DVD Mandriva, so I hope the problem is not coming from this...
And now aMSN is no more working :(
(But it's perhaps due to the fact that I updated my CVS? But I did look in protocol.tcl, and the line with MSNP13 MSNP12 CVR09 (or something like that, I don't remember exactly), is there, but without "MSNP13"... Don't know what to do :()

Ps: launching it with the command LANG=ISO-8859-15 amsn don't work for the moment...

Here's what I get when doing Ctrl-S, perhaps this could help?
Code:

[19:12:14] Catch in proc trans (title ): can't read "lang(title)": no such variable
[19:12:14] Catch in proc trans (followtext ): can't read "lang(followtext)": no such variable
[19:12:14] Catch in proc trans (filters ): can't read "lang(filters)": no such variable
[19:12:14] Catch in proc trans (savetofile ): can't read "lang(savetofile)": no such variable
[19:12:14] Catch in proc trans (clear ): can't read "lang(clear)": no such variable
[19:12:14] Catch in proc trans (close ): can't read "lang(close)": no such variable
[19:12:14] System language is fr_be
[19:12:14] Removed _ variant. Now system language is fr
[19:12:14] Language "fr" is in available languages, using it
[19:12:14] Matching language fr!
[19:12:14] LoadLoginList: starting
[19:12:14] LoadLoginList: HOME=/home/famille/.amsn, HOME2=/home/famille/.amsn, HOMEE=/home/famille/.amsn
[19:12:14] LoadLoginList: adding profile g-unit87@hotmail.com with lock num 0
[19:12:14] LoadLoginList: adding profile titesouris05@hotmail.com with lock num 0
[19:12:14] LoadLoginList: adding profile snipe2004@hotmail.com with lock num 62201
[19:12:14] LoadLoginList: getting an initial profile
[19:12:14] CheckLock: LoginList getlock called. Lock=62201
[19:12:14] CheckLock: Port 62201 is free!!
[19:12:14] LockProfile: Locking snipe2004@hotmail.com
[19:12:14] LockProfile: Got random port 65288
[19:12:14] LoadLoginList: profile snipe2004@hotmail.com is free, locking
[19:12:14] LoadLoginList: we found a free profile: snipe2004@hotmail.com
[19:12:14] load_config: Started. HOME=/home/famille/.amsn/snipe2004_hotmail_com, config(login)=snipe2004@hotmail.com
[19:12:14] load_config: loading file /home/famille/.amsn/snipe2004_hotmail_com/config.xml
[19:12:14] load_config: Config loaded
[19:12:14] Missing Party_smiley.gif from skin MSN7. Using default
[19:12:14] skin MSN7 's scrollbar loaded
[19:12:17] check_web_ver: Current= 0 96b New=0 95 (0.95)
[19:12:17] Three days (in seconds) :604800
[19:12:17] Difference time (in seconds): 604801
[19:12:17] Not yet 3 days or no new version
[19:12:18] cmsn_auth starting, stat=a
[19:12:19] cmsn_auth starting, stat=v
[19:12:19] -----------------------------------------
[19:12:19] >>> GOT TCL/TK ERROR : {{can't find package msnSOAP}}
>>> Stack:
can't find package msnSOAP
    while executing
"package require msnSOAP"
    (file "msnp13.tcl" line 1)
    invoked from within
"source msnp13.tcl"
    ("v" arm line 8)
    invoked from within
"switch [ns cget -stat] {
a {
#Send three first commands at same time, to it faster
if { [::config::getKey protocol] == 11 } {
::MSN::Write..."
    (procedure "cmsn_auth" line 7)
    invoked from within
"cmsn_auth $item"
    ("VER" arm line 2)
    invoked from within
"switch [lindex $item 0] {
MSG {
cmsn_ns_msg $item $message
return 0
}
    IPG {
   ::MSNMobile::MessageReceived "$message"
  ..."
    (procedure "cmsn_ns_handler" line 17)
    invoked from within
"cmsn_ns_handler $command $message"
    ("default" arm line 2)
    invoked from within
"switch [lindex $command 0] {
ILN {
if {$::msnp13} {
$self handleILN $command
} else {
cmsn_ns_handler $command $message
..."
    (procedure "::NS::Snit_methodhandleCommand" line 27)
    invoked from within
"::NS::Snit_methodhandleCommand ::NS ::NS::Snit_inst1 ::ns ::ns {VER 1 MSNP12 CVR0}"
    ("uplevel" body line 1)
    invoked from within
"uplevel 1 $command $args"
    invoked from within
"$options(-name) handleCommand $command"
    (procedure "::Connection::Snit_methodreceivedData" line 38)
    invoked from within
"::Connection::Snit_methodreceivedData ::Connection ::Connection::Snit_inst2 ::NS::Connection1 ::NS::Connection1"
    ("uplevel" body line 1)
    invoked from within
"uplevel 1 $command $args"
    invoked from within
"::NS::Connection1 receivedData"
    ("uplevel" body line 1)
    invoked from within
"uplevel 1 $command $args"
    invoked from within
"ns receivedData"
>>> Code: NONE
[19:12:19] -----------------------------------------
[19:12:19] >>> AMSN version: 0.96b - AMSN date: 12/22/2005
[19:12:19] >>> TCL version : 8.4.5 - TK version : 8.4.5
[19:12:19] >>> tcl_platform array content : osVersion 2.6.11-6mdk byteOrder littleEndian machine i686 platform unix os Linux user famille wordSize 4
[19:12:19] -----------------------------------------

[19:12:19] gotNexusReply: loginurl=https://loginnet.passport.com/login2.srf
[19:12:19] gotNexusReply: finished before authentication took place
[19:12:29] Can't get online plugininfo.xml for Games (place 0 - URL )
[19:12:34] Can't get online plugininfo.xml for Desktop Integration (place 0 - URL http://amsn.sourceforge.net/autoupdater/plugins/deskop_integration/plugininfo.xml)


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: billiob on April 08, 2006, 07:59:03 pm
Try to use that font : http://webb.ens-cachan.fr/ftp/mirror/MPlayer/contrib/fonts/arialuni.ttf.bz2
update the cvs, it's fixed now.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: snipe2004 on April 08, 2006, 08:39:20 pm
Okay, I'll update,tx!
But where must I unzip your file? Under Windows I knew, but under Mandriva...


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: TheOne on April 09, 2006, 01:09:23 am
snipe2004

try this font... in amsn .. Tools> Preferences> Appearance tab. then click on change font. select (clearlyu)

this may fix half of the problem.

in mandriva u dont have to add single font.. just install all windows fonts.
there is an option.. i think u should know how.. if u dont see this http://linux.techteam.gr/docs/mandriva/10/starter/drakfont.html

remember to mount windows partition. and the fonts directory should be ... /Windows/Fonts


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: gesteur on September 22, 2006, 08:16:13 pm
Hi have the same problem, i cannot write arabic or armenian fonts, I'm using  amsn-0.96_rc1 on gentoo
I added these 2 languages in the "control center" ->"keyboard layout"
if i write something in kwrite or firefox i can see these utf-8 characters without problems....only in msn i wont see them.
if i write armenian or arabic in kwrite and then copy & paste it to the amsn chat box...it displays it, but it's a bit unconfortable to copy and paste everytime, lol.
I also tried to change the encodings in amsn preferences.....

could someone help me?


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on September 23, 2006, 11:54:29 am
Look for help on http://tcl.tk - it depends on them, not us, sorry...


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: gesteur on October 06, 2006, 03:02:39 pm
Quote from: "vivia"
Look for help on http://tcl.tk - it depends on them, not us, sorry...


Under Suse I can write in armenian....but under gentoo not. It wont let me write the characters...
could it depend on the tcl/tk version?


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on October 06, 2006, 03:48:39 pm
Well, there are two possible causes (that we can think of now) : One was with scim, so make sure you use tcl/tk 8.4.13 or later. Another one was with xorg, a user got it right after upgrading from ubuntu dapper to edgy, and it got fixed after a xorg upgrade. Good luck anyway........


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: gesteur on October 06, 2006, 03:56:07 pm
I've installed tcl/tk 8.4.13 now, I'm using xorg 7.1 but the window chat wont let me type armenian characters....



the strange thing is that with suse 9.1 (XFree, tcl/tk 8.4.6) i could write without problems in amsn.
and there the software is surely older....


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on October 06, 2006, 11:05:40 pm
:) The problem didn't exist on Dapper but it did on Edgy (which is a later version). Unfortunately I cannot help you any further, ask the tcl/tk team for help (They are always active and helpful on irc.freenode.net #tcl )


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: gesteur on October 07, 2006, 11:27:01 am
efxaristò vivia for the help :)


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: gesteur on October 09, 2006, 10:40:56 pm
the guys at #tcl helped me to solve the problem.
So, my problem was that the system encoding was set to iso-blabla the western european code.
First I had to change the system encoding to UTF-8.
Then I recompiled glibc and tcl/tk with unicode USE flag activated (do not know if it is necessary).




After this I can write armenian in aMSN.

to check which encoding TCL/TK uses tipe in the console
Code:
$wish

this opens a window
then type in the console

Code:
% encoding system


if it is UTF-8
try this command
Code:
% pack [text .t]


and now try to type in the opened windows with the language u want, the correct characters should appear.

recall: the system encoding which wish returns must be UTF-8.
Of course the aMsn preferences->appearance-> encoding must also be set to UTF-8.


NB: to use KDE, Firefox, Skype, KWrite, etc etc I did not have to change the system encoding to UTF-8, KDE did already the conversions.
somehow tcl/tk used the system encoding...and amsn uses tcl/tk...


cheers hov


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Oet on November 30, 2006, 12:04:26 am
Well, this doesn't solve my problems.

I'm typing in dutch, using chars like é and á en ë and so on.
trying to type those chars in aMSN doesn't work and gets me some strange \ue04 or so thing.
Tried that pack [text .t] thing on wish, and i can type the é chars and so just fine, so i'm guessing it's not tcl/tk that is the cause of this problem.
Also never had this with the 0.95 release..

any ideas? (using UTF-8 on aMSN and iso8859-1 on system)

Edit: Ok, after setting the same coding on amsn as found in wish using the encoding system cmd, it's working again!


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: chy1013m1 on December 03, 2006, 08:02:56 am
not too sure what happened.. I installed xgl , then revert back to just Xorg+Gnome, now my previously working SCIM+aMSN doesn't work anymore. I tried to recompile tcl/tk 8.5, aMSN 0.96, none of which worked. All I can think now is that Xorg-x-server 1.1.1 has a bug in it or something.

any thoughts?

I also switched to OXIM just to see what'd happen, but same for OXIM..sigh..
other applications work fine with either SCIM/OXIM.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on December 05, 2006, 02:33:33 pm
there *was* a bug in some version of xorg...


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: nesh87 on March 27, 2007, 07:41:29 am
hey guys sorry for the bump, but i was just wondering if there is a solution for this yet? i have installed the Arabic locale but still the letters are backwards..

i looked at tcl's site, couldnt find anything..?

thanks


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: kakaroto on March 27, 2007, 03:12:07 pm
Hi,
afaik, the solution was found and you should set your encoding to utf-8, did you try that ?


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: nesh87 on March 29, 2007, 09:52:26 am
yup i tried that, my system encoding is UTF-8 so is my Amsn encoding...i think i have tried everything that might solve the problem with no luck


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vega on June 18, 2007, 07:39:35 pm
Hello,

Maybe the problem is not from the encoding.

if you choose encoding:cp1252, and any font that supports arabic, then it will work but not correctly.
what I mean is that after choosing the encoding cp1252, and any font that supports arabic language then
I can see the arabic fonts but in reverse order after typing it, but while I'm typing I can't see it.

I have compared aMSN with GAIM, GAIM solved the problem by the following:
if you change the keyboard to arabic keyboard, then the layout of typing will change from left-to-right to right-to-left
and that will solve it.

I know that maybe all/most of the languages use left-to-right, except for arabic language.

It is better to develop aMSN so that it can handle the arabic language by the following:
when a user changes the keyboard to arabic, then the writing will be right-to-left instead of left-to-right.
otherwise it will be left-to-right.


I hope that will help.

thanks.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: faneca on July 11, 2007, 11:18:32 pm
This is a little off-topic, but hopefully it could help someone. We've just solved an issue with dead keys on the Spanish sub-forum, and I wanted to share it with non Spanish speakers. Some of us couldn't write accented letters (you know, vowels with acute -áéíóú-), but had no problems with e.g. "ñ" -n with tilde-. In fact, every dead key worked as a non-dead one: if you wanted to write an a with acute, you ended up with an acute alone followed by an a (á vs 'a), and so on.

The solution was to "clear" the variable XMODIFIERS before calling amsn. It had the value "@im=scim" because we use SCIM to write in other languages. Giving it a null value (or even "@im=" or "@im=none") did the trick. As an example, you can launch amsn from the console with the following command:
Code:
XMODIFIERS='' amsn


I would like to use SCIM within amsn (don't know how, maybe through XIM ??), but at least I left headaches behind ;-). If someone's interested, I'm using Ubuntu Feisty 7.04 - x86_64 with its "standard" packages (amsn v.0.96 2006/11/01, tcl/tk 8.4.14 -I think-, etc).

(BTW I noticed that writing such a character in a tcl/tk app, and then a few "normal" characters, when the program is idle -high system load situation, for example-, makes that character appear AFTER the rest of them, instead of its place. It is not very related to the above problem, but its strange how that subsystem treats dead keys anyway).


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: iridium on August 21, 2007, 02:16:14 pm
I have problems when try to type strange characters like:

'ñ' àèéòóú...........

I use two machines with ubuntu 7.04.

With the laptop amsn works perfectly. Not with the desktop.

The difference:


Desktop (it works  8) ):
Code:
francesc@francesc-desktop:~$ cat $LANG
cat: ca_ES.UTF-8: No such file or directory


Laptop  :twisted:
Code:
francesc@francesc-desktop:~$ cat $LANG
ca_ES.UTF-8@valencia



In the console I can change LANG variable and then amsn works
Code:
francesc@francesc-desktop:~$ LANG=ca_ES.UTF-8
francesc@francesc-desktop:~$ cat $LANG
cat: ca_ES.UTF-8: No such file or directory


The question is:

Can I change the LANG variable to the whole system (not just one opened terminal)?

Thanks,
Iridium


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: kakaroto on August 21, 2007, 02:44:46 pm
maybe use the 'locale' command, not sure if it's the right one.. or look in your gnome/kde configuration panel.. if not, search the net, if not, then ask in your distro's forums instead.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: faneca on August 22, 2007, 02:11:14 am
Quote
Can I change the LANG variable to the whole system (...) ?


Yes, you can. In Ubuntu, the file you should edit is /etc/default/locale (I think). While I don't think so, maybe you should reboot after the change just to be sure the whole system notices it.

BTW, I resolved all my problems with SCIM, but I did nothing! Not even update tcl/tk or scim, AFAIK :-/ . Tk apps started to work with scim just by themselves, although now dead keys don't work anymore when scim is deactivated (exactly the opposite case I had, I'm completely pointless about this). The good news, apart for beeing able to use scim, is that I no longer must tweak the environment for amsn, and also that there is a workaround to write in my native european language: install a scim input method for it (so now I have scim activated all the time, and just keep switching the input method). For the record, before this behavior, the gtk scim panel appeared in English, and now it is in my mother tongue.

I wonder if this helps someone, somehow.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Skippy le Grand Gourou on September 06, 2007, 07:14:39 pm
Quote from: "faneca"
I wonder if this helps someone, somehow.
Of course it does ! Well, I hope so... Can you please give your .xinitrc (or wherever there are) input method options (I mean XMODIFIERS, *_IMMODULE & cie) ?


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: faneca on September 06, 2007, 09:42:00 pm
Of course ;). Take a look at the last part of this message. I'd like to tell a few things first, though.

I don't remember exactly all the steps I made... just googled a lot and read some interesting things here and there. I'm pretty sure, however, that I didn't use im-switch (I've never installed it), because I had the impression it wouldn't do very well what I wanted: using a Latin (Spanish, in fact) layout as my primary input method (both for Spanish and Galician), while being able to switch to Greek and Japanese im's (and maybe others). Possibly I was wrong about this at that time, but now I don't care because it works :) (well, at least always worked, and is working right now, in all the gtk apps). Also, I do remember tweaking my ~/scim/* files.

As a side note (this issue is getting funnier and funnier), a couple of days ago, Japanese stopped working again in Tk apps... and what makes it even more interesting: now it fails in a completely different fashion. For instance, the Greek and Spanish input methods are happier than ever :), but while Japanese seems to work at first glance (i.e. you can switch input methods while the conversation window is focused, and you can see the embedded "preedit string" window), when it comes to insert the characters (Kanji and such) into the text, it puts only blanks (and Windows MSN users told me they see square characters when I tried to send them). Also, if I try and paste a Japanese string into the window (from another app), it inserts something like "\233\321\423\221\113" (well, this are not the correct numbers, but that's not the point). All of this worked flawlessly, say, last week. AND, AGAIN, I DON'T REMEMBER UPDATING ANY PACKAGES RELATED TO SCIM OR TCL/TK.  dO_ob  Funny, funny, damn funny  X^D.

Well, as I said in a previous message, I'm sitting on an Ubuntu Feisty (7.04) system. So here you have some interesting files:


/etc/X11/Xsession.d/74custom-scim_startup (I created this one, so this vars are set up system-wide for X; maybe you'd prefer to use .xinitrc or whatever):
Code:

export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
export XIM_PROGRAM="scim -d"
export QT_IM_MODULE="scim"



Somewhere in ~/.gnome2/session, I have:
Code:

(...)
18,RestartCommand=scim -d
(...)

Here, '18' is circumstantial. (If I'm right, this was not done by hand-editing, but using the "System | Preferences | Sessions" applet in the Gnome Ubuntu menu to create a new "start application" entry -- the command to put there, of course, is "scim -d").


~/.scim/global
Code:

/DefaultKeyboardLayout = Spanish
(...)



~/.scim/config
Code:

/DefaultIMEngineFactory/C = c6bebc27-6324-4b77-8ad4-6d41dcaf2e08
/DefaultIMEngineFactory/es_ES = c6bebc27-6324-4b77-8ad4-6d41dcaf2e08
/DefaultIMEngineFactory/gl_ES = c6bebc27-6324-4b77-8ad4-6d41dcaf2e08
/FrontEnd/ChangeFactoryGlobally = true
/FrontEnd/IMOpenedByDefault = true
/FrontEnd/OnTheSpot = true
/FrontEnd/SharedInputMethod = true
/FrontEnd/Socket/ConfigReadOnly = false
/FrontEnd/Socket/MaxClients = 512
/FrontEnd/X11/BrokenWchar = true
/FrontEnd/X11/Dynamic = true
/FrontEnd/X11/OnTheSpot = true
/FrontEnd/X11/ServerName = SCIM
/Hotkeys/FrontEnd/NextFactory = Hyper+Scroll_Lock
/Hotkeys/FrontEnd/Off =
/Hotkeys/FrontEnd/On =
/Hotkeys/FrontEnd/PreviousFactory = Shift+Hyper+Scroll_Lock
/Hotkeys/FrontEnd/ShowFactoryMenu = Alt+Hyper+Scroll_Lock
/Hotkeys/FrontEnd/Trigger = Zenkaku_Hankaku,Hangul,Control+Hyper+Scroll_Lock
/Hotkeys/FrontEnd/ValidKeyMask = Shift+Control+Alt+CapsLock+Meta+Super+Hyper
/Hotkeys/IMEngine/6e029d75-ef65-42a8-848e-332e63d70f9c = Control+Alt+Hyper+l
/Hotkeys/IMEngine/List = 6e029d75-ef65-42a8-848e-332e63d70f9c
(...)
/Panel/Gtk/Color/ActiveBackground = light sky blue
/Panel/Gtk/Color/ActiveText = black
/Panel/Gtk/Color/NormalBackground = #F7F3F7
/Panel/Gtk/Color/NormalText = black
/Panel/Gtk/DefaultSticked = false
/Panel/Gtk/Font = default
/Panel/Gtk/LookupTableEmbedded = true
/Panel/Gtk/LookupTableVertical = true
/Panel/Gtk/ShowStatusBox = false
/Panel/Gtk/ShowTrayIcon = true
/Panel/Gtk/ToolBar/AlwaysHidden = true
/Panel/Gtk/ToolBar/AlwaysShow = false
/Panel/Gtk/ToolBar/AutoSnap = true
/Panel/Gtk/ToolBar/HideTimeout = 2
/Panel/Gtk/ToolBar/POS_X = -1
/Panel/Gtk/ToolBar/POS_Y = -1
/Panel/Gtk/ToolBar/ShowFactoryIcon = true
/Panel/Gtk/ToolBar/ShowFactoryName = true
/Panel/Gtk/ToolBar/ShowHelpIcon = true
/Panel/Gtk/ToolBar/ShowMenuIcon = true
/Panel/Gtk/ToolBar/ShowPropertyLabel = true
/Panel/Gtk/ToolBar/ShowSetupIcon = true
/Panel/Gtk/ToolBar/ShowStickIcon = true
/UpdateTimeStamp = 1188953827:114437

Most of this was automatically created by scim the first time it was launched (launch it without -d switch from command line, then interrupt with Ctrl-C), but I think I tweaked some things around the first lines. I put here everything that can be of some interest, and wiped out the boring lines ;). Not sure about what that "c6bebc27-6324-4b77-8ad4-6d41dcaf2e08" thing may mean, but it seems to me that it is some kind of reference to the Spanish keyboard layout.


Finally, my  /etc/default/locale
Code:

LANG="gl_ES.UTF-8"
LANGUAGE="gl_ES:gl:es_ES:es:en_US:en_GB:en"



Finally, please note that I did some tests, changing "scim -d" to "scim -f X11 -d" everywhere, and back again.

If you need more information, don't hesitate to ask.

Faneca.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Skippy le Grand Gourou on September 07, 2007, 08:03:04 am
Thanks. Seeing your stuff I thought that it was the XIM_PROGRAM line that was missing (I had only a XIM_MODULE) but... no. Or not only...

Can you please tell me which versions of amsn and tcl/tk you are using ?

Edit : No way... I cannot even switch the input method while aMSN is on top.  :cry:
Edit2 : Well, I think I remember that I have to use tcl/tk 8.5, but I reinstalled 8.4 this morning for the 0.97RC1 version of aMSN from community's repo (archlinux)... I'll try to reinstall svn version, but (can you still tell which versions you are using please).


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: faneca on September 07, 2007, 12:43:21 pm
(Mmmmm, XIM_MODULE... it sounds quite interesting, I'll google to give it a try, but anyway, what value do you have on it?)

This are the Feisty packages I've installed along with their versions:

Code:

tcl8.4:  8.4.14-0ubuntu1
tk8.4:   8.4.14-0ubuntu2

(I don't have any other tcl/tk versions on this machine. In fact, there's no higher version in the stable Ubuntu distribution)

Code:

amsn:  0.96+dfsg1-0ubuntu2


Code:

scim,
libscim8c2a,
scim-gtk-immodule,
scim-modules-socket:   1.4.4-7ubuntu1

scim-anthy:  1.2.1-1build1

anthy,
libanthy0:  7900-3build1

scim-m17n:  0.1.3-2

libm17n-0:  1.3.1-1.1
m17n-db:    1.3.1-1.build1


If you're courious, I'm using m17n to write classic Greek (you know, with diacritics and such) - it's sooo nice for writing mathematics (maybe I'll be using tex in the future, but right now I don't have the need) :-)


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Skippy le Grand Gourou on September 07, 2007, 05:57:45 pm
Quote from: "faneca"
(Mmmmm, XIM_MODULE... it sounds quite interesting, I'll google to give it a try, but anyway, what value do you have on it?)
Don't bet on it... In fact I had these three lines and I'm quite sure they have almost no impact :
Code:
export XIM_MODULE=scim
export X_IM_MODULE=scim
export TK_IM_MODULE=scim
:lol:

Quote from: "faneca"
This are the Feisty packages I've installed along with their versions:
Code:
tcl8.4:  8.4.14-0ubuntu1
tk8.4:   8.4.14-0ubuntu2
(I don't have any other tcl/tk versions on this machine. In fact, there's no higher version in the stable Ubuntu distribution)
Yes, in fact I was mistaking, scim support was implemented (or at least improved) since tcl/tk 8.4.13, according to the changelogs (I think I was confusing with anti-aliasing support).

Quote from: "faneca"
Code:
amsn:  0.96+dfsg1-0ubuntu2
Mmh... 0.97RC1 here. Maybe a XXX* ? Unfortunately there is no easy way to downgrad a package on archlinux, so I have to install from source if y want to test 0.96... Anyway, I'll see if I have more chance this evening.
*[I don't remember how you call a a bug when it worked before and does not work anymore...  :oops: ]

Quote from: "faneca"
If you're courious, I'm using m17n to write classic Greek (you know, with diacritics and such) - it's sooo nice for writing mathematics (maybe I'll be using tex in the future, but right now I don't have the need) :-)
I don't know if that's what you meant, but be aware that you can also type tex WITH scim. ;)


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Skippy le Grand Gourou on September 07, 2007, 08:08:56 pm
Quote from: "Skippy le Grand Gourou"
Mmh... 0.97RC1 here. Maybe a XXX* ? Unfortunately there is no easy way to downgrad a package on archlinux, so I have to install from source if y want to test 0.96... Anyway, I'll see if I have more chance this evening.
*[I don't remember how you call a a bug when it worked before and does not work anymore...  :oops: ]
Tried the 0.96 one, doesn't help...  :cry:


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: faneca on September 08, 2007, 12:51:21 am
Good news: I'm stupid :D

To be a little more explicit, those (stupid? :D) Windows users made me think I was having trouble with scim when in fact I wasn't. Once another Windows user told me he was watching my kanji properly, I realized the only thing going wrong was *displaying* those characters on my system, i.e. I had a problem with fonts. Then, I just had to choose another font in the amsn config and the problem vanished. So scim was always working since I managed to get it working (I don't know if it was really me, or what had I done either :-/ , read my first post on this thread). BTW the copy&paste problem is still there, but only when I copy from the clipboard. When coping and pasting directly with the mouse, it goes like a charm. I believe this problem was always there waiting for me to notice.

What bothers me is not knowing how my xorg font configuration changed. I think it has to do more with xorg than with scim or tk or amsn, because I did not change tk or amsn config, and because running this command (to open tk with a text area window):
Code:

wish <(echo 'pack [text .t]') &

let me introduce kanji before, but now, with the same default font (at least it looks the same), kanji is not showing. Also, I'm sure I did not update the amsn/tk/scim packages, but I'm not so sure about gnome and xorg.

So where are we now?
1.- First, forget what I said about my "new" scim problem, in my last posts. Scim keeps working for me since it started working in tk apps for the first time.
2.- Skippy is still in trouble, although he seems to have taken the necessary steps. Has it something to do with distribution-customized packages? Don't know, but it's an idea I've just come into.

OK, I'll finish with some comments for you, Skip:
1.- You have respected case (scim vs SCIM) when assigning values to those env. vars, haven't you?
2.- When an ancient bug reappears it's called a regression, if I'm right ;)

Please keep me informed of your progress. And request whatever you need ;)


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Skippy le Grand Gourou on September 08, 2007, 09:16:54 am
1) Given your advice, I tried to change "export XMODIFIERS="@im=SCIM"" by "export XMODIFIERS="@im=scim"", but nothing new.

2) That's the word I was looking for. :-D

3) BTW, copy/past also works, that's just an input issue. I repeat, I can't even change scim method while in amsn, and just standard input works. I think this can help : I can't even put a "^" over a "e", it just gives "^e"...


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: faneca on September 08, 2007, 10:01:44 am
Quote from: "Skippy le Grand Gourou"
1) Given your advice, I tried to change "export XMODIFIERS="@im=SCIM"" by "export XMODIFIERS="@im=scim"", but nothing new.

In fact, although I'm unsure why, in that particular case it should be in capital letters (SCIM), while on the other variables should be in small ones (scim).

Quote from: "Skippy le Grand Gourou"
3) BTW, copy/past also works, that's just an input issue. I repeat, I can't even change scim method while in amsn, and just standard input works. I think this can help : I can't even put a "^" over a "e", it just gives "^e"...

Mmmm, this is new information, and I like it :). I was exactly in the same case before (you can read mi first posts on this thread). Please, try and do something: open a terminal and launch amsn this way...

Code:
XMODIFIERS='' amsn

This will prevent tk from using any special input method. If you are lucky, it will let you write "combinations" (I don't know what to call it), i.e. pressing a dead key won't write it immediately but will combine it with the next character you type, by means of using your standard X keyboard layout. The bad news, if this is what happens to you too, is that I simply don't know what I did (if I ever did something) to fix it and start using scim normally with tk apps :(.

So please try that and come back to tell me what happens.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Skippy le Grand Gourou on September 08, 2007, 10:49:17 am
Quote from: "faneca"
If you are lucky, it will let you write "combinations"
Yes it does ! :D
Quote from: "faneca"
(I don't know what to call it)
I think "combinations" is ok, or just "accents"... ;)
Quote from: "faneca"
The bad news, if this is what happens to you too, is that I simply don't know what I did (if I ever did something) to fix it and start using scim normally with tk apps :(.
Ok, anyway that's a new way where to look. I'll try to google on this this afternoon or tomorrow (and maybe reread the topic from the beginning :) ).

Thanks.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: faneca on September 08, 2007, 11:03:41 am
I'll post two more files I missed last time. Looking at their modification times, I guess I've made something with the first one. Experiment and feed us back ;)
EDIT: The 'something' I've made is changing the first line (it was " = en_US.UTF-8" before).

/etc/scim/global
Code:

/SupportedUnicodeLocales = gl_ES.UTF-8,es_ES.UTF-8,en_US.UTF-8,en_GB.UTF-8
/DefaultPanelProgram = scim-panel-gtk
/DefaultConfigModule = simple
/DefaultSocketFrontEndAddress = local:/tmp/scim-socket-frontend
/DefaultSocketIMEngineAddress = local:/tmp/scim-socket-frontend
/DefaultSocketConfigAddress = local:/tmp/scim-socket-frontend
/DefaultPanelSocketAddress = local:/tmp/scim-panel-socket
/DefaultHelperManagerSocketAddress = local:/tmp/scim-helper-manager-socket
/DefaultSocketTimeout = 5000

/etc/scim/config
Code:

# This file is encoded in UTF-8 encoding.
/FrontEnd/OnTheSpot = true
/FrontEnd/SharedInputMethod = true
/FrontEnd/ChangeFactoryGlobally = false
/FrontEnd/Socket/ConfigReadOnly = false
/FrontEnd/Socket/MaxClients = 512
/FrontEnd/X11/BrokenWchar = true
/FrontEnd/X11/Dynamic = false
/FrontEnd/X11/OnTheSpot = true
/FrontEnd/X11/ServerName = SCIM
/Hotkeys/FrontEnd/NextFactory = Control+Alt+Down,Shift+Control+KeyRelease+Shift_L,Shift+Control+KeyRelease+Shift_R
/Hotkeys/FrontEnd/PreviousFactory = Control+Alt+Up,Shift+Control+KeyRelease+Control_L,Shift+Control+KeyRelease+Control_R
/Hotkeys/FrontEnd/ShowFactoryMenu = Control+Alt+Right
/Hotkeys/FrontEnd/Trigger = Control+space,Shift+space,Zenkaku_Hankaku,Hangul
/Hotkeys/FrontEnd/ValidKeyMask = Shift+Control+Alt+CapsLock+Meta
/Panel/Gtk/Color/ActiveBackground = light sky blue
/Panel/Gtk/Color/ActiveText = black
/Panel/Gtk/Color/NormalBackground = #F7F3F7
/Panel/Gtk/Color/NormalText = black
/Panel/Gtk/Font = default
/Panel/Gtk/DefaultSticked = false
/Panel/Gtk/LookupTableEmbedded = true
/Panel/Gtk/LookupTableVertical = false
/Panel/Gtk/ShowStatusBox = false
/Panel/Gtk/ShowTrayIcon = true
/Panel/Gtk/ToolBar/AlwaysShow = false
/Panel/Gtk/ToolBar/AutoSnap = true
/Panel/Gtk/ToolBar/HideTimeout = 2
/Panel/Gtk/ToolBar/POS_X = -1
/Panel/Gtk/ToolBar/POS_Y = -1
/Panel/Gtk/ToolBar/ShowHelpIcon = true
/Panel/Gtk/ToolBar/ShowFactoryIcon = true
/Panel/Gtk/ToolBar/ShowFactoryName = true
/Panel/Gtk/ToolBar/ShowSetupIcon = true
/Panel/Gtk/ToolBar/ShowStickIcon = true
/IMEngine/RawCode/Locales = default


I'm backtracking all my steps. If I discover something new, I'll post it here. Ah, and I think all my posts are on this page, so don't look back too far ;).


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: kakaroto on September 08, 2007, 08:47:50 pm
Hello here, I don't really read all your posts because I understand nothing about all that, and I never use it :p
But I think that you've been able to gather some very helpful information in here, and I think it might be a good idea to put this as a tutorial in the wiki of aMSN.
If one of you is willing to help and would like to write that in the wiki, please tell me and I'll create an account for you (send me the username/password you'd want to have by PM (you can change the password after)).

Thank you in advance :)


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: faneca on September 08, 2007, 10:29:04 pm
Well, I can do it, but I'll start working on a new job in two days, and I'll be very busy from then. You'll have to be patient until I finally get the job done. And, in connection with the subject we are talking about in the last messages on this tread, I must say a few thing:

1.- There's a lot of people who have been working with scim enabled tk apps without problems at all, in several different Linux distributions. At least that's what it seems, and actually I thought I was suffering a "marginal" problem caused by my very particular setup (made almost completely by hand), so no one should have interest on the solution. But now that Skippy has appeared with the same problem, on a different distribution than me, it made me remember there was someone else in the spanish section of the forum with this issue, so I agree with you in that this is worth a troubleshooting section on the wiki/FAQ.

2.- This leads me to the second point. I solved the problem on my machine, but I tried so much different things that now I just can't recall which one did the trick. What makes it even worse, apart from my very bad memory :), is that things started to go well from one day to the other, giving me the impression that it wasn't me who solved it. This would have made sense if I only had updated some of my installed packages, but none of the related ones have been touched. And until now, I couldn't reproduce the previous buggy behavior. Nor have we solved Skippy problem yet.

What I really want to say with all this, is that IMHO we should first get to the root of the problem, fix it for Skippy as we work on it, and only then, write about it. I hope it won't take too long. We'll see.

Anyway, the workaround permits users to write properly, using their own keyboard layout, when they are not interested in using "exotic" input methods while at amsn or other tk apps, so maybe it already deserves a small answer in the FAQ. This could be enough (well written, of course):
Quote

Problems with scim/linux/dead keys?

Launch amsn this way from a terminal:
Code:
XMODIFIERS='' amsn &
It will deactivate scim for the app, but at least you'll be able to write deadkey+letter combinations. We are working on this issue.

Maybe you'll want to add this yourself right now ;-) Let me know what you think.

Regards,

faneca


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: kakaroto on September 09, 2007, 07:03:55 am
ok, thanks faneca. As I said, I didn't read all your posts since this is beyond me, I had a friend asking me about scim the  other day, and he tried amsn and scim and it didn't work, I tried it myself on his machine and it didn't work, so I thought that scim just doesn't work with Tk unless you use some trick. Which is why I asked for the solution (the 'trick') to be written in the wiki. I thought it was as simple as the XMODIFIERS thing you posted above (but to enable scim, not disable it). I also thought your post helped Skippy solve the problem...
When I get time, I'll try and read this post, or ask someone who understand scim to read it and draw conclusions and write them in the wiki.
Thanks for clarifying things.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Skippy le Grand Gourou on September 09, 2007, 09:14:57 pm
Ok, it works ! :D
Many thanks, faneca. After some tests, I figured out that the point was to add my unicode locale to the first line of /etc/scim/global. So in my case :
Code:
/SupportedUnicodeLocales = fr_FR.UTF-8,en_US.UTF-8

instead of just en_US.UTF-8. Then I am able to use dead-keys, and to switch scim methods ! :D

BTW, you were right, it seems that the 'scim' argument in XMODIFIERS has to be in capital letters.

So kakaroto, here are the steps to follow, if you want to adapt them for a tutorial :


Quote from: "[b
How to make SCIM to work within aMSN[/b]"]
1) Install tcl/tk >= 8.4.13, amsn >= 0.96, scim, and scim's language-specific packages (for instance, scim-pinyin for Chinese, scim-anthy for Japanese or scim-hangul for Korean).

2) If you have only one user or you want to enable SCIM for a specific user, create or modify the ~/.xinitrc file and add these lines at the beginning :
Code:
# SCIM
export XMODIFIERS='@im=SCIM'
export GTK_IM_MODULE="scim"
export XIM_PROGRAM="scim -d"
export QT_IM_MODULE="scim"
scim -d
If you want SCIM to be enabled for all users, you can put these lines in /etc/profile or create an initialization script.

3) Be sure to have your current locale in the first line of /etc/scim/global. For instance, if you use fr_FR.UTF-8 (you can know it by typing locale in a terminal), this line should look like :
Code:
/SupportedUnicodeLocales = fr_FR.UTF-8,en_US.UTF-8
If this is not the case, edit it (as root).

4) Restart your X server or reboot.

5) Enjoy ! :D


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: faneca on September 10, 2007, 12:05:37 am
Quote from: "Skippy le Grand Gourou"
Ok, it works ! :D
Many thanks, faneca.
You're welcome! Your feedback has been important to me: after all, I wanted to know what the hell I had done to get it working, I was becoming crazy.
Donc, merci à vous aussi, vous m'avez aidé beaucoup ;).

Ok, we are ready for the wiki, Kakaroto. I think the previous Skippy post is perfect, he explained all the steps very well. So IMHO there's no need to open accounts for me/us, you can do it yourself; but you can count on me anyway if you want ;)

BTW I'll try and test restoring that /etc/scim/global line this week, to see if I can reproduce the problem and confirm that was the cause -- even if it seems pretty straightforward to me now.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: kakaroto on September 10, 2007, 05:07:26 am
ok thanks guys, faneca and Skippy, this will probably be very helpful to others. I'll make it into the wiki!
Glad it works for both of you.
Skippy, the post you gave is also a very good tutorial, I don't think there's a need to modify it! :)
Bonne soiree! :)


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Skippy le Grand Gourou on September 10, 2007, 02:12:48 pm
Thanks for your comments. One thing that might be added is that there is also a "global" file in ~/.scim. Faneca, I think you'd better try with this one if you want, in order to be able to say if it's customizable for several users. ;)


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: faneca on September 10, 2007, 09:06:07 pm
Quote from: "Skippy le Grand Gourou"
One thing that might be added is that there is also a "global" file in ~/.scim. Faneca, I think you'd better try with this one if you want, in order to be able to say if it's customizable for several users. ;)

You read my mind ;). Just give me a couple of days, right now I'm really busy and I'd like to avoid the inconvenience of closing my session. It won't go beyond week end, though.

Regards


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: faneca on September 22, 2007, 08:02:14 pm
I'm sorry it took me so long to test that, I've been really busy the last two weeks. Thanks for your patience.

Anyway, I have good news. I confirmed in my own system those were both the problem and the solution. And it works no matter if the "/SupportedUnicodeLocales = ..., your_locale, ..." line goes in /etc/scim/global or in ~/.scim/global, as long as it is in one of them (the latter overriding the settings of the former, if they conflict). So even if a user does not have root access, he/she can set scim working properly. It also means each user could have a different configuration.

Add this to the FAQ properly, Kakaroto. And keep the good work!

Regards.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: billiob on September 23, 2007, 05:08:31 pm
You can edit the FAQ, it's a wiki !


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: kakaroto on September 24, 2007, 11:52:28 am
thanks for the answer, I will do it when I get time...
and billiob, no, it's a wiki, but we've resitricted access to it. those who want to help have to request us to create a user/pass for them because we were fed up of all the spam we were getting...


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Skippy le Grand Gourou on November 04, 2007, 05:14:31 pm
Mmmh... There might be another issue. On my girlfriend's computer which is under Ubuntu (Edgy), this procedure does not seem to be enough, I still can't get dead keys to work without exporting null into XMODIFIERS. However, .xinitrc does not seem to be taken into account, and I can't figure out (for the moment) how scim is launched. As I have no continuous access to this computer, it may take some time for me to understand what's wrong, so if another ubuntu user read these lines... ;)

Edit: Oh, yes : and XIM_PROGRAM is not set. I have to check which scim packages are installed, but I have to go for now.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: faneca on November 04, 2007, 10:16:40 pm
Hi, Skippy, comment ça va? Well, Edgy is already a little outdated (I've upgraded from feisty to gutsy a few weeks ago and scim still works), but I hope I can help you ^_~. The problem is I don't know which Xorg/Xfree86 version is your girlfriend's computer running; mine was always Xorg 7.x (and I've never used .xinitrc, FYI). I guess if you have a /etc/X11/Xsession.d/ directory, you're lucky. Create there a file (I did it myself some time ago) with the following contents, and name it, for instance, 74custom-scim_startup:

Code:

export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
export XIM_PROGRAM="scim -d"
export QT_IM_MODULE="scim"


That's for the environment vars. It won't harm to have them set system-wide. You can also launch the scim daemon there, I think, but I'd better put it on the user's session startup scripts.

The issue then is you'll have to find the right startup script to launch the scim daemon. If she's using ubuntu I suppose her desktop is a gnome; ~/.gnomerc may (or may not) be a valid place for it. A good alternative could be simply using the gnome session config tool (In the gnome's main menu, go to "System | Preferences | Sessions", then click on "Add" and put the command "scim -d" there) to configure that. With gutsy, I think my startup files are now *.desktop stuff placed into ~/.config/autostart (you know, freedesktop thing).

I'm not sure if I'm really answering your questions, and I was a little messy, so please give me some feedback. Regards.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Skippy le Grand Gourou on November 05, 2007, 10:10:23 pm
Hi faneca. You are right in all your assumptions. :) And by the way, I don't really want to upgrade from edgy to gutsy, because I played with so many files that I would not be able to repair anything in a few hours (which would already be to long for her...) in case of problems.

After posting yesterday, I had a look on which packages were installed, and figured out that it was a mess... I removed all uim related packages, tried to play with im-switch which was installed, but then removed it also to restart from a clean base. Now there are only scim related packages.

Unfortunately it was late and I don't remember what I did after that for now... I wanted to kill the launch of scim in order to start from nothing then apply the good ol'method, however scim restarted all the time... Then I left. I'll try again next week-end or the one after.

Thanks for your support. ;)


Title: Solution maybe
Post by: Splatt on November 19, 2007, 05:38:13 pm
For me i only had problem with some chars. It worked for me to set it to iso-8859-1. Even if i should use UTF-8 (the one that's supposed to be used (with the chars))


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Gonzalo on July 25, 2008, 02:26:29 pm
Hi.
I am running aMSN 0.97 in Poseidon Linux / Ubuntu 8.04 (re-installed today since it said there was something new). But a problem I got even before is that accents are not working. I get 'a instead of á in Spanish or Portuguese!
Automatic, UTF-8.... not working for me (and now in Kopete I have the same problem, no accents, no special characters).


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: kakaroto on July 25, 2008, 07:27:01 pm
did you read this thread completely and followed all the instructions ??? ?????


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: mercutio22 on December 01, 2008, 03:44:01 am
I can't type as well. Ubuntu 8.10 amd64.

Its worth pointing out I can type with accents and all until  I  get the message  other party joins the conversation. Changing focus to another windows and back into amsn fixes the problem for a short while until another amsn window shows someone joining a conversation. Its weird. It used to work a few days ago before I changed the skin and activated some plugins. Maybe its related.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: kakaroto on December 01, 2008, 04:37:51 am
hi mercutio, which plugins did you enable ? that could help...
could you disable all the plugins and see if it fixes the issue? if it does, then could you enable them one by one until you find the plugin that caused this behavior? thanks.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: mercutio22 on December 01, 2008, 12:15:08 pm
Quote from: "kakaroto"
hi mercutio, which plugins did you enable ? that could help...
could you disable all the plugins and see if it fixes the issue? if it does, then could you enable them one by one until you find the plugin that caused this behavior? thanks.


I am afraid that even turning off every plugin didn't resolve the issue. Changing the skin as well. I am using SCIM and starting amsn with
Code:
XMODIFIERS='' amsn &


Solved the problem for me.

I am still baffled though. I am pretty very sure it used to work before I messed around with the skins. (I can faintly remember it was a skin change - not a plugin change - that triggered the behavior, but I might be wrong).


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: kakaroto on December 02, 2008, 03:59:00 am
maybe just a coincidence... maybe you updated some packages on your system and scim was one of them and you didn't notice the problem and you changed the skin at the same time...


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: mercutio22 on December 02, 2008, 06:44:05 am
Quote from: "kakaroto"
maybe just a coincidence... maybe you updated some packages on your system and scim was one of them and you didn't notice the problem and you changed the skin at the same time...


I have access to another laptop with SCIM (supposedly) in which amsn  does work. Maybe we can investigate differences between them two.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: afrox on June 09, 2009, 01:36:40 pm
Quote from: "mercutio22"
Quote from: "kakaroto"
hi mercutio, which plugins did you enable ? that could help...
could you disable all the plugins and see if it fixes the issue? if it does, then could you enable them one by one until you find the plugin that caused this behavior? thanks.


I am afraid that even turning off every plugin didn't resolve the issue. Changing the skin as well. I am using SCIM and starting amsn with
Code:
XMODIFIERS='' amsn &


Solved the problem for me.

I am still baffled though. I am pretty very sure it used to work before I messed around with the skins. (I can faintly remember it was a skin change - not a plugin change - that triggered the behavior, but I might be wrong).


So do you guys know any solution to use Spanish characters by clicking on the menu instead of using  
Code:
XMODIFIERS='' amsn &
on the console?

is there a way to modify the icon or something?

If I uninstall scim, i wont be able to use the áéíóú characters in any program.

thanks


Title: not a problem anylonger.
Post by: mercutio22 on June 09, 2009, 05:28:04 pm
I ceased to experience this issue in Jaunty Jackalope so I can launch the program straight from the icon.

If you still experience this, you can create a bash script with that line and make the icon point to it, just like creating a shortcut in window$, so you don't have to type it every time you launch amsn.

Good luck


Title: Re: not a problem anylonger.
Post by: afrox on June 09, 2009, 11:31:24 pm
Quote from: "mercutio22"
I ceased to experience this issue in Jaunty Jackalope so I can launch the program straight from the icon.

If you still experience this, you can create a bash script with that line and make the icon point to it, just like creating a shortcut in window$, so you don't have to type it every time you launch amsn.

Good luck


I tried,  to modify the link, but it wont work:
Detalles: Ha ocurrido un error al ejecutar el proceso hijo «XMODIFIERS=» (No existe el fichero ó directorio)=
Deatils: Some error happened when executing the "child" process "XMODIFIERS=" (no such file or directory).

When I configured my scim file to es_ES, it did work as it should (this is àèèèóü), but the keyboard would only work at times. I followed this: but it won't work

Is there a way to uninstall scim or something whithout spoiling the whole keyboard configuration??

It is a little annoying problem actually


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: kakaroto on June 10, 2009, 01:41:53 am
Hi,
I think there's other input methods, scim, xim, cim or whatever, try maybe a different input method than scim...
and the "XMODIFIER=" (no such file or directory) issue is normal, I suggest you create a small script : /usr/local/bin/start_amsn
Code:
#!/bin/bash
XMODIFIERS="" amsn

then make the menu icon launch start_amsn instead of amsn... it should work this way...


Title: create a BASH script.
Post by: mercutio22 on June 10, 2009, 02:20:26 am
Did you try to execute a   BASH script (http://tldp.org/HOWTO/Bash-Prog-Intro-HOWTO-2.html) with that line in it?


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: afrox on June 11, 2009, 01:22:38 pm
Quote from: "kakaroto"
Hi,
I think there's other input methods, scim, xim, cim or whatever, try maybe a different input method than scim...
and the "XMODIFIER=" (no such file or directory) issue is normal, I suggest you create a small script : /usr/local/bin/start_amsn
Code:
#!/bin/bash
XMODIFIERS="" amsn

then make the menu icon launch start_amsn instead of amsn... it should work this way...


Hey boys, it did the work for me, thanks for your support Kakaroto!


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: berdux on June 29, 2009, 12:05:28 am
hello,

i have the problem with the freezing keyboard when someone comes online (i explain it exactly here: http://www.amsn-project.net/forums/viewtopic.php?p=39151#39151)

it seems to work fine if i type in terminal this
Code:
XMODIFIERS='' amsn &

though i can type greek normally (with accents αάεέοό) i cannot type japanese (on amsn windows), i understand this happens because i start amsn without the use of scim or sth.

i will read again carefully next weekend the thread to see what i am missing (what to change in files etc). for the time i have a little problem, the script thing did not work, it says: cannot run start_amsn, access denied. (sorry for the trouble, i am a noob with linux :) )
how can i solve this? (for i have to type in terminal the above code and keep the terminal window open..)

thanks in advance


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: kakaroto on June 29, 2009, 01:56:27 am
Hi again, glad it (partially) works... I don't know about japanese, vivia might help you (she always writes japanese with amsn and it works fine)... about the script, it has to be executable for you to execute it... just do this in a terminal :
Code:
chmod +x /usr/local/bin/start_amsn

You can also probably do it through your desktop, by right clicking, properties, permissions, and enabling the execute checkbox...


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on June 29, 2009, 01:59:28 am
Hi,

I ended up removing scim and using uim instead. Works like a charm.

I could not solve the freezing keyboard issue with scim, and this was the main reason why I removed it and went for uim. It's way less buggy anyway, and you don't need the XMODIFIERS trick!


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: kakaroto on June 29, 2009, 02:08:53 am
humm.. ok thanks vivia!
So, we can basically summarize this whole thread with "use UIM instead of SCIM" ? wow.. what a waste of text ! :p


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: berdux on July 04, 2009, 09:12:18 am
hello!

so i uninstalled SCIM and installed UIM. the problem with the freezing keyboard has gone. i can write japanese now on most windows, except amsn and skype (maybe others as well, haven't tested it yet). i should search this more before posting but i really do not have the time now (again :S). just reporting my status :P
i will find some time tomorrow and find the solution to this, i think i saw it someplace when i was searching for my first problem :)

ありがとうございます。



(ps. by the way, i just noticed, vivia are you greek?)


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: afv on July 04, 2009, 04:04:36 pm
I just uninstalled SCIM and installed UIM and seems to me (maybe I didn't test enough) that the problem with the accented letters (áéíóú…) appearing with a delay is gone! Thanks!! :D

(It also seems to be quicker when pasting some text (sometimes the text pasted took some seconds to appear, before this) :))


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: fhoffmann on July 31, 2009, 08:57:53 am
I was having the exact problem as berdux-- losing keyboard functionality when keeping an IM window open and the other person would enter or leave conversation. While replacing SCIM with UIM does indeed avoid this problem now I am unable to type Japanese on aMSN, also like berdux... When I'm in an aMSN window the keyboard shortcuts I have assigned to switch between languages seem to be ignored by UIM.. If I manually select the input type via the UIM toolbar I still get my default input, which is english. Am I overlooking a simple setting?


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on July 31, 2009, 06:50:54 pm
berdux: ότι θα βοηθούσα Έλληνα να γράφει Ιαπωνικά στο aMSN, δε θα το φανταζόμουν!! :)

@berdux, fhoffmann: Which distribution are you using? Can you try typing Japanese in xterm? If not, maybe the problem is that the uim-xim bridge is not installed. Unfortunately I cannot remember by heart how to install it and I cannot find the nice howto that I had. You could at least try running uim-xim manually before starting aMSN.


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: fhoffmann on July 31, 2009, 10:02:17 pm
vivia -
I am using Ubuntu, Jaunty... I discovered I had a few references to SCIM left over:
im-switch -c then choose one of the UIM options
now UIM recognizes my keyboard shortcuts and Japanese and Korean text input work with aMSN. The only problem I have is-- as I type, instead of showing the hiragana or katakana I see boxes then when I press enter it shows the correct font... I suspect it is just that... an issue with a font. I will post back here when I figure what I'm missing incase anyone else has this problem. It would be great if we could figure out all these little hangs people are having when using multi-lingual setups with aMSN and throw it to the wiki... It was a bit annoying to read through 4 pages of posts then see that the workaround is to use some other software...  :lol:


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: Stian1979 on August 16, 2009, 09:03:26 am
I tryed scim and refuse to work on amsn and openoffice.
uim don't seam to have mps traditional chinese.
I'm back to fighting with scim


Title: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: setzer on October 05, 2009, 10:09:43 pm
Stian1979 - Well, I suppose that u followed the entire topic and is still having problems. I's been some time since I last read this topic so I don't remember everything that it says. However, I suggest you to try using iBus as your default IM. I recently swtched to iBus and didn't find any problems with amsn. In fact, I didn't configure anything to make it work, except for exporting XMODIFIERS, GTK_IM_MODULE, QT_IM_MODULE and TK_IM_MODULE. You should give it a shot...


Title: Re: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on January 02, 2010, 06:20:25 pm
Problem with accented characters getting misplace is fixed: http://www.amsn-project.net/forums/index.php/topic,7610.0.html


Title: Re: Problems typing foreign languages?(was Arabic Fonts Problem)
Post by: vivia on July 15, 2010, 05:50:48 pm
I just found two workarounds to the problem with scim input freezing: https://bugs.launchpad.net/ubuntu/+source/scim/+bug/66104