aMSN Forums
May 28, 2018, 10:45:23 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: 1 [2] 3 4
  Print  
Author Topic: Port Forwarding behind a router/firewall  (Read 33475 times)
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #15 on: November 21, 2009, 09:36:29 pm »

Hi, welcome to the forums.
First, nice first post, thanks for the details and respectful post!:)
for file transfers, the fact that amsn thinks you are firewall *might* affect the connection.. it will have no effect only for the webcam feature.
If you want to do for example sending webcam and receiving webcam, that's already 2 connections.. sending 2 or 3 files at the same time, that's 2 or 3 connections, that's why we suggest you open a range of 10 connections.
I have now re-enabled the connectivity checker, hoping that the website traffic has slowed down now that the release is 1 week old.
Logged

KaKaRoTo
Skyee
Newbie

Offline Offline

Posts: 7


View Profile
« Reply #16 on: November 22, 2009, 12:06:59 pm »

Thank you very much kakaroto.
Since you re-enabled the connectivity checker, I can send files in full speed again Smiley

You said it *might* affect the connection, for me it *has* affected the connection. I don't know how it is for other users, but I am thankful for the fast help!
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #17 on: November 23, 2009, 01:49:51 am »

no problem, glad it works.. it also seems the website is not being slowed down, so that's good Smiley
yes, it might affect the connection, it depends on who is sending the file and on the connectivity of the other person.. in some use cases, it won't affect it, in other use cases, it will. (in your case, sending files, I guess it always affects it)
Logged

KaKaRoTo
sgsollie
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #18 on: December 22, 2009, 10:47:06 pm »

Hey guys,

I've got the same issue here. Can confirm, port range is definitely correctly forwarded. Connection check fails and I'm still getting the white screen. Can usually view friends webcams without much of an issue.

The connectivity checker also doesn't work. Keeps saying I'm behind a firewall.

I am slightly concerned that it is my router. It seems pretty cheap and nasty (bt voyager) - Any suggestions?

Cheers
Ollie
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #19 on: December 24, 2009, 12:02:32 am »

the connectivity checker DOES WORK, it's your port forwarding that doesn't work... so try to fix your router, google for how to forward ports correctly if you don't know how.
Logged

KaKaRoTo
sgsollie
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #20 on: December 26, 2009, 12:03:48 am »

Mate, i am a network engineer. I know how to forward ports ok.

Theres something up here. Can provide a tcpdump if you wish?
Logged
sgsollie
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #21 on: December 26, 2009, 12:20:23 am »

Apologies for that, previous reply wasn't too helpful.

But yes, I'm 100% sure i've forwarded these ports correctly,

Copied from OSX network settings
AirPort is connected to (my SSID) and has the IP address 192.150.150.101. - thats a static IP range we use at home.


Detect IP address automatically is set in aMSN, seems to be working - currently showing me the internet IP of my router.


Router settings:
Forwarded range: 6890 to 6900
protocol: both
Towards IP: 192.150.150.101

Router is a linksys wrt54g (in this house)

Still weird file transfers and white webcam.

Connectivity test always says im behind a firewall.
Are there any other ports I should be fowarding here?

My starting port in amsn is 6891.
Logged
sgsollie
Newbie

Offline Offline

Posts: 5


View Profile
« Reply #22 on: December 26, 2009, 12:42:00 am »

I APOLOGISE SOOOO MUCH


It was an issue with my macs firewall Wink amsn was set to allow all incoming connections. BUTTT I think that was a different instance of amsn I have installed elsewhere for some reason. - Allowing all incoming connections solved the issue. - Will configure my macs 'firewall' accordingly.

I work in tech support and I understand how frustrating it can be, 99% of problems like this are user error.

So yes, sorry sorry sorry sorry sorry!

Smiley
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #23 on: December 26, 2009, 01:10:40 am »

hahahaha, thank you sooo much for realizing your mistake and apologizing for it! :p
Your first message was a bit rude (not a lot though) but still ok, the second one made me feel "ok, he apologized on his own, he must be a nice guy.. " then I thought I'd suggest checking for firewalls or to check if the ports aren't blocked by your ISP (some ISPs block all ports, others have their users inside a LAN).
Anyways, just glad you fixed it! Smiley And I knew it was a PBKAC error :p
Logged

KaKaRoTo
BurningWave
Newbie

Offline Offline

Posts: 22


View Profile
« Reply #24 on: December 27, 2009, 07:18:03 pm »

Hi,
I'm a little bit confused.

Webcam with aMSN doesn't work. The Ports are free and Mac OS X Firewall allows aMSN to connect.
The strange is that the File Transfer does work and Skype Webcam and Audio does work with the ports of aMSN.

So something is very strange there...
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #25 on: December 28, 2009, 01:56:42 am »

file transfer would still work but at a lower speed, and skype uses a different technology that would make it work no matter what. webcam doesn't because WLM has a bug specific to the webcam feature.
test your ports in preferences->connection tab.
Logged

KaKaRoTo
BurningWave
Newbie

Offline Offline

Posts: 22


View Profile
« Reply #26 on: December 28, 2009, 10:45:00 am »

The test says that I am behind a firewall or a router. But I can't understand why.
In the configuration of my router the Ports are free, I know about that and every start of aMSN the Mac OS X Firewall asks me if I want to allow aMSN to connect and I always click "Accept".

The thing I am confused about is that all the time I had Mac OS X 10.5 Leopard the Webcam does not work. After updating to 10.6.0 (!!!) Snow Leopard the Webcam had worked but directly after the Update to 10.6.1 it suddenly does not work again and I did not change everything at router or the firewall configuration in System-preferences.

That is the thing I am not able to understand. Sometimes I thing there is something wrong with the Firewall of Mac OS X but I do not know...
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #27 on: December 29, 2009, 04:54:53 am »

Hi,
maybe you're misinformed, the router wouldn't show those ports "are free", you should have a custom rule that you wrote yourself, saying to *forward* those ports 6891 to 6900 in TCP to your local IP address, with your local IP address written in the rule, and that rule 'enabled'.
also, your firewall popping and you click 'accept', is probably to allow aMSN to connect to the msn servers, I'm not sure if it's to allow someone from outside to connect to your computer, that's different. Try disabling the firewall entirely and test it.. maybe someone else who knows better about macosx firewall could help you out.
Finally, I don't think the upgrade changed anything, it was probably just a coincidence.. don't forget that it would work if either one of you (you or your friend) is not firewalled, maybe by coincidence when you had 10.6.0, your friend wasn't firewalled, and now he is.. or you tried with a different person...
Logged

KaKaRoTo
Drizz
Newbie

Offline Offline

Posts: 12


View Profile
« Reply #28 on: December 30, 2009, 12:00:44 am »

Hi, im sorry that its probably glaringly obvious to some, but i have just bought my first Mac, and im not that computer literate. My web cam is white too and also doesnt stay active for more than 10 seconds or so. Is there a easy to understand step by step guide to resolve this please?
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #29 on: December 30, 2009, 10:34:11 am »

@Drizz: welcome to the forums,
the easy step by step guide is easy to find...
look up the model of your router, (usually in a sticker at the bottom or rear), then open google.com and type "how to forward ports <insert your router's model here>".
Logged

KaKaRoTo
Pages: 1 [2] 3 4
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!