aMSN Forums
May 26, 2018, 06:49:08 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: New forum for aMSN !!
 
   Home   Help Search Login Register  
Pages: [1] 2
  Print  
Author Topic: aMsn0.98-1 floods Desktop w/blocked/deleted contacts @login  (Read 18463 times)
Solomon999
Newbie

Offline Offline

Posts: 16


View Profile
« on: November 14, 2009, 07:29:22 pm »

Hello:

I just updated to the aMsn 0.98.1 (Mac) and it keeps flooding my desktop screen at every new login with all my old blocked and deleted contacts (100+).
I tried painstakingly to delete each and every one again by denying the request to contact me, but it does not work as each time I logged into aMsn, the SAME entire list appears again as if I did not delete them.
My old aMsn 0.97 did not have this problem ,except the usual complaint that I appear offline when I'm online.
I tried going into the Preferences>privacy tab>"Allow only added list to contact me" function but still does not work.

I even tried removing the 0.98-1 version and reinstalling the 0.97 version, but this time I cannot even log in. Sigh.
Now I have no choice but reload 0.98-1 version again and tolerate the bugs.

Can anyone advise how to stop these blocked/deleted contacts from appearing? Thanks!!!

Sol :shock:
Logged
tktoronto
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #1 on: November 15, 2009, 12:25:16 am »

I have the same issue and it is completely annoying. Can anyone help.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #2 on: November 16, 2009, 06:39:27 pm »

Hi, welcome to the forums,
the new 0.98.1 version of aMSN uses a newer protocol version which is more complete and works quite differently from before.
the problem you are having is probably caused by the fact that you have exceeded the limit of 1500 contacts (the limit is PER list, so 1500 contacts in allow list, 1500 contacts in block list). I suggest you open amsn's preferences, go to privacy tab, and delete anyone that shouldn't be there anymore (those who are not in your list and who also deleted you from their list). Read the FAQ to understand the color coding of each contact to help you decide who to delete.
I know you'll probably request now that we add a 'multiple selection' support for those lists, and i'd just like to say that it's in the TODO list and will be added.. sometime in the future...
i hope this helps.
Logged

KaKaRoTo
tktoronto
Newbie

Offline Offline

Posts: 3


View Profile
« Reply #3 on: November 16, 2009, 11:31:22 pm »

HI thanks for your response. I did what you said but i have no idea how to delete contacts on privacy other than move them to block.. Even so I cant block for some reason. I have chose only users i accepted are allowed to contact me but i try to move accepted users to blocked and doesnt work either. the small windows that ask me if i want to accept the users, i cant even find them on any of the lists in the privacy section. I also cant find anything on colours in faq. Perhaps you can still help me.





Quote from: "kakaroto"
Hi, welcome to the forums,
the new 0.98.1 version of aMSN uses a newer protocol version which is more complete and works quite differently from before.
the problem you are having is probably caused by the fact that you have exceeded the limit of 1500 contacts (the limit is PER list, so 1500 contacts in allow list, 1500 contacts in block list). I suggest you open amsn's preferences, go to privacy tab, and delete anyone that shouldn't be there anymore (those who are not in your list and who also deleted you from their list). Read the FAQ to understand the color coding of each contact to help you decide who to delete.
I know you'll probably request now that we add a 'multiple selection' support for those lists, and i'd just like to say that it's in the TODO list and will be added.. sometime in the future...
i hope this helps.
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #4 on: November 17, 2009, 12:13:56 am »

Hi again, to delete a user, select the user, then right click (or command-click) on him to get a popup window allowing you to delete that user from that list. moving a contact to the blocked list won't help, it will just decrease one list and fill up another one...
Of course you didn't find those users that amsn asks you about, it's because they cannot be added to either list, that's why aMSN keeps telling you about them...
About the colors, it's right here :
http://www.amsn-project.net/wiki/FAQ#In_the_preferences.27_privacy_tab.2C_what_do_the_different_colors_in_the_contacts_mean.3F
Logged

KaKaRoTo
Solomon999
Newbie

Offline Offline

Posts: 16


View Profile
« Reply #5 on: November 27, 2009, 09:08:16 pm »

Hi, Thanks for the advice.

The problem is when I go to the privacy tab to delete the blocked names, it will now come back as a "new" invite for my acceptance to my contact list cos now that they have been released from the original blocked list. I understand about the 1500 limit but  I seriously doubt I blocked that many (mine about 100+).

Now, instead of staying cleared off the desktop screen when I go thru the tedious task of removing them after every log in, these blocked list will flood my screen again every half hour or so and I go thru the same ritual again Sigh.

I have no issue using the old aMsn version but seems they dun work anymore.

Is there anyway I can stop this problem besides using a new msn id? Thanks again.
:shock:
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #6 on: November 28, 2009, 02:38:06 am »

if the blocked list does not have 1500 users (you say about 100) then don't delete people from it, check the allow list instead!
Logged

KaKaRoTo
Solomon999
Newbie

Offline Offline

Posts: 16


View Profile
« Reply #7 on: December 01, 2009, 07:12:47 am »

My allowed list only has 2 persons.  Serious..:lol:  :shock:

Now u understand why I'm so perplexed. :?:
Logged
arantes
Super Power User
**
Offline Offline

Posts: 364



View Profile
« Reply #8 on: December 01, 2009, 10:16:25 pm »

All your contacts who are not blocked are supposed to be in your allow list! Aren't they ? You have only two contacts ? Oo
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #9 on: December 01, 2009, 10:56:54 pm »

@arantes: I guess he blockes all his contact list and only unblocks people he needs to talk to.
@Solomon999: ok, I'm also perplexed then.. could you please do the following :
1 - open amsn (disable autoconnect if it has that)
2- wait a little bit
3 - press Ctrl-S from the login window
4 - press Ctrl-D from the login window
5 - two windows will appear, press the 'Clear' button in both of them
6 - In the one that says "Status log", there's an entry at the bottom above the buttons, type in it "set ::soap_debug ~/Desktop" (or /User/<your mac username>/ or some other directory path)
7 - connect
8 - wait until those windows start popping
9 - wait some more...
10 - click the save to file button on both windows, and save the files
11 - You will find a bunch of files in your Desktop (or whatever directory you set in step 6), adding with _req.xml and _resp.xml
12 - Look for a RST.srf_req.xml file, open it, edit it, you'll find your username and password in there, remove them!
12 - Take the files you just saved (protocol and status logs) as well as the xml files you found on your Desktop (or whatever) and put them all in a zip file
13 - Email all that to me at "kakaroto AT kakaroto.homelinux.net", put "aMSN logs" in the subject and give me a link to this thread in the email so I know why you sent it to me.
14 - Wait until I figure out what the hell went wrong, and either give you proper advice (since my original supposition seems to be wrong) or fix it in aMSN if it was a bug that we didn't know about.

Good luck!
Logged

KaKaRoTo
Solomon999
Newbie

Offline Offline

Posts: 16


View Profile
« Reply #10 on: December 03, 2009, 02:50:45 am »

OK kakaroto, gimme some time to figure out your instructions and revert.
Thanks again. appeciate it.
Cheers. :wink:
Logged
Solomon999
Newbie

Offline Offline

Posts: 16


View Profile
« Reply #11 on: December 30, 2009, 08:29:17 am »

Seasons greetings!

Hey Kakaroto. I tried your instructions but it does not work. It keeps saying "invalid command" when I type " set::soap_debug~/Desktop"
I tried all variations to this command, including the " " or using one : instead of the 2 :: you gave.
Any idea?
Thanks again..Happy New Year !  Cheesy
Logged
kakaroto
Administrator
Super Power User
*****
Offline Offline

Posts: 9428


View Profile WWW
« Reply #12 on: December 30, 2009, 10:39:51 am »

it's "set <space> ::soap_debug <space> ~/Desktop"
Logged

KaKaRoTo
Solomon999
Newbie

Offline Offline

Posts: 16


View Profile
« Reply #13 on: December 31, 2009, 03:50:38 pm »


Got the things done & sent you.

Thanks.
« Last Edit: December 31, 2009, 05:45:21 pm by Solomon999 » Logged
Solomon999
Newbie

Offline Offline

Posts: 16


View Profile
« Reply #14 on: December 31, 2009, 03:53:06 pm »

PS: Happy New Year !
« Last Edit: December 31, 2009, 05:45:42 pm by Solomon999 » Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!